Warum füllt tmux / byobu beim Kopieren einer Auswahl ungültige Zeichen auf meinem Bildschirm?

13

Wenn ich eine Auswahl aus tmux mit einer Fensteraufteilung kopiere, füllt sich mein Bildschirm mit überflüssigen Zeichen. Je nach Größe der Auswahl könnte es sich um eine Menge oder nur eine Zeile handeln. Die folgenden Bilder zeigen:

Dann nach dem Schlagen, um die Auswahl zu treffen:

Beachten Sie alle ungültigen Zeichen im rechten Fensterbereich.

Wie kann ich dieses Verhalten loswerden?

    
dpb 05.08.2014, 17:53
quelle

2 Antworten

13

Es gibt eine Option set-clipboard , die versucht, Ihre Auswahl mit einer Escape-Sequenz in die x-Zwischenablage zu kopieren.

:set-option -s set-clipboard off

gnome-terminal unterstützt diese Methode der Verwendung der Zwischenablage nicht, die das Standard-Terminal in Ubuntu ist.

    
dpb 05.08.2014, 17:53
quelle
3

Bearbeiten ~/.tmux.conf oder mit Byobu $HOME/.byobu/.tmux.conf :

set -g set-clipboard off
Igor Parra 07.05.2016 16:08
quelle

Tags und Links