SSH Berechtigung verweigert (öffentlicher Schlüssel), aber root ssh funktioniert

13

Ich versuche, ssh Zugang für ein Benutzerkonto, das ich mit Chef auf einem digitalen Ozean Ubuntu 12.04 Server erstellt habe einzurichten. Ich hatte die Optionen in Digital Ocean eingestellt, um automatisch meinen Mac ssh-Schlüssel zu kopieren, wenn das Tröpfchen erstellt wird.

Ich kann mich ohne Probleme als root anmelden, aber mein anderer Benutzer kann sich nicht authentifizieren. Dies scheint ein häufiges Problem zu sein, und ich überprüfte einige der anderen Antworten und fand diesen Befehl, um weitere Informationen zu erhalten:

ssh -vvv -i id_rsa user@serverIP

Die Protokolle für den root-Benutzer (der erfolgreich ist) mit diesem Befehl sind

debuggen

1: Offering RSA public key: /Users/evan/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Server accepts key: pkalg ssh-rsa blen 279
debug2: input_userauth_pk_ok: fp snip!
debug3: sign_and_send_pubkey: snip!
debug1: read PEM private key done: type RSA
debug1: Authentication succeeded (publickey).

fehlgeschlagener Benutzer:

debuggen

1: Authentications that can continue: publickey
debug3: start over, passed a different list publickey
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /Users/evan/.ssh/id_rsa
debug3: send_pubkey_test
debug2: we sent a publickey packet, wait for reply
debug1: Authentications that can continue: publickey
debug1: Trying private key: /Users/evan/.ssh/id_dsa
debug3: no such identity: /Users/evan/.ssh/id_dsa: No such file or directory
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.

Was für mich bedeutet, dass der öffentliche Schlüssel falsch ist. Aber wenn ich mich als root-Benutzer anmelde und zu home/otheraccount/.ssh/authorized_keys gehe, kann ich sehen, dass mein ssh-Schlüssel da ist. Ich dachte, dass es vielleicht einen Fehler gab, also habe ich cp .ssh/authorized_keys ~/home/otheraccout/.ssh/authorized_keys gemacht, aber das hat nicht geholfen. Ich weiß nicht wo ich sonst hinschauen soll.

mein etc/ssh/sshd_conig :

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
"sshd_config" 88L, 2508C
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile     %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication no

# GS

SAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding no
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60

AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server
UsePAM no
Banner /etc/ssh_banner

bearbeiten:

drwx------ 2 deploy deploy 4096 Apr 20 06:00 .ssh
-rw------- 1 deploy deploy 820 Apr 20 05:35 authorized_keys

Bearbeiten2:

Wie in den Kommentaren vorgeschlagen: /var/log/authlog :

Apr 21 04:59:30 localhost sshd[586]: User deploy not allowed because account is locked
Apr 21 04:59:30 localhost sshd[586]: input_userauth_request: invalid user deploy [preauth]

Ich habe versucht, sudo usermod --expiredate -1 deploy zu machen, und es hat no changes

zurückgegeben     
user2936314 20.04.2014, 12:05
quelle

2 Antworten

16
  • SSH-Anmeldungen können aus verschiedenen Gründen fehlschlagen (falsche Verzeichnis- / Dateiberechtigungen, falsche Schlüssel usw.) und der verbindende Client erhält nur Permission denied oder No more authentication methods to try oder einen allgemeinen Fehler.

  • Der genaue Grund für den fehlgeschlagenen Anmeldevorgang ist abhängig von der Syslog-Konfiguration in ssh log /var/log/auth.log oder /var/log/secure verfügbar.

clement 21.04.2014, 17:35
quelle
3

Das gleiche Problem für mich frisch CentOS7 installieren.

1. check home dir Berechtigungen und ~ / .ssh und ~ / .ssh / authorized_keys Berechtigungen (wie @clement sagt)

chmod o-w ~/; chmod 700 ~/.ssh; chmod 600 ~/.ssh/authorized_keys

2. überprüfen Sie / etc / ssh / sshd_config Einstellungen & amp; & amp; service sshd restart (nach jeder Änderung) Sinnvoll: Probieren Sie "LogLevel VERBOSE" in sshd_config aus.

Ich habe immer noch ein Passwort erhalten, nachdem ich alles überprüft habe, was in Ordnung war.

Führen Sie den ssh-Client mit den -vvv-Protokollen aus:

debug3: send_pubkey_test 
debug2: we sent a publickey packet, wait for reply

Server (/ var / log / secure) Protokolle:

Failed publickey for * from * port * ssh2: RSA *
Der

ssh-Server sendet keine weiteren Fehlerinformationen an den Client, da dies ein Sicherheitsrisiko darstellen würde.

Wenn ich sshd auf verschiedenen Ports 'sshd -p 5555 -d' ausgeführt habe. Der Schlüssel hat funktioniert. Passwortlose Anmeldung ok. WTF?

SAD :-( um zu sagen, dass ich selinux deaktiviert habe (set SELINUX = deaktiviert in / etc / selinux / config) und neustarten. Passwordless login funktioniert dann ok.

meine aktuellen Einstellungen für sshd_config:

[root@hp-bl-05 ~]# grep -vE "^#|^$" /etc/ssh/sshd_config  
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
SyslogFacility AUTHPRIV
LogLevel VERBOSE
RSAAuthentication yes
PubkeyAuthentication yes
AuthorizedKeysFile  .ssh/authorized_keys
HostbasedAuthentication yes
PasswordAuthentication yes
ChallengeResponseAuthentication no
GSSAPIAuthentication no
GSSAPICleanupCredentials no
UsePAM yes
X11Forwarding yes
UseDNS no
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT
AcceptEnv LC_IDENTIFICATION LC_ALL LANGUAGE
AcceptEnv XMODIFIERS
Subsystem   sftp    /usr/libexec/openssh/sftp-server

Also wäre es schön zu wissen, könnten wir etwas kleines in selinux ändern, um passwortloses ssh-Login zu bekommen. Kann jemand die Antwort verbessern?

gleich hier: link

    
gaoithe 04.05.2016 14:52
quelle

Tags und Links