Ncurses-Eingabeaufforderungen sehen in PuTTY von Windows aus fehlerhaft aus

12

Byobu sieht in PuTTY sehr gebrochen aus. Ich habe das Problem bei der Schlüsselzuordnung bereits behoben, aber dieses Problem ist weder in der Manpage noch in Google angegeben:

Beachten Sie die falsch platzierte Position der Fensterliste, die gebrochene Auswahlposition, die Duplizierung des letzten Fensters, das zufällige a oben rechts und die falsch platzierte Apply-Option. Sie können dies nicht sehen, aber die letzte Option kann nicht ausgewählt werden.

Gibt es eine Option in PuTTY, die ich verwenden muss, um dies richtig zu sehen?

    
TheLQ 11.12.2010, 00:47
quelle

5 Antworten

10

Putty für das Lesen von Utf8 konfigurieren. Kitt - > config - > Fenster - > Übersetzung  wähle utf in "Daten erhalten in ..." Dies ist kein Byobu-Problem, sondern ein Kitt-Problem.

Siehe auch:

Joe Fisher 02.10.2011 18:51
quelle
8

In Bezug auf Putty habe ich diese Notiz vor einiger Zeit der Manpage byobu (1) hinzugefügt:

> PuTTY  users have reported that the
> F2, F3, and F4 shortcut keys are not
> working properly.  PuTTY sends the
> same escape sequences as the linux
> console for F1-F4 by default.  You can
> fix this problem in the PuTTY config,
> Terminal -> Keyboard -> Function keys:
> Xterm R6.

Siehe:

Dustin Kirkland 11.01.2011 18:54
quelle
3

Ubuntu verwendet UTF-8 für sein Terminal, aber Byobu verwendet offenbar den Zeichensatz "ISO-8859-1 (Westeuropäisch)" für seine Menüs. Sie können den Zeichensatz in Windows festlegen - > Übersetzung.

Ich habe den folgenden Code im Internet gefunden und bin damit immer noch zufrieden. byobu hat vielleicht mehr Optionen, aber auch ich mag das ( ~/.screenrc ):

startup_message off
hardstatus alwayslastline
hardstatus string '%{= kG}[ %{G}%H %{g}][%= %{=kw}%?%-Lw%?%{r}(%{W}%n*%f%t%?(%u)%?%{r})%{w}%?%+Lw%?%?%= %{g}][%{B}%Y-%m-%d %{W}%c %{g}]%{w} %l'
shelltitle "$ |bash"
termcapinfo xterm ti@:te@
altscreen on

Hinweis: Für byobu muss shelltitle "$ |bash" entfernt / kommentiert werden, andernfalls funktioniert byobu nicht.

    
Lekensteyn 11.12.2010 11:23
quelle
0

Damit byobu in Putty gut aussieht, sollten Sie zwei Änderungen vornehmen.

Ändern Sie zunächst Ihre Tastatur in xterm-R6, wie bereits erwähnt, aber Zweitens: Führen Sie auf Ihrem Linux-Computer den Befehl als normaler Benutzer aus: byobu-select-backend und wählen Sie dann die Option screen (normalerweise 2).

Sollte jetzt großartig funktionieren! Viel Spaß!

    
DanielS 25.03.2013 09:25
quelle
0

Es hat für mich funktioniert (passend für Putty - temporär):

  

Fenster - > Übersetzung - > Remote-Zeichensatz: DEC-MCS

Für eine endgültige Lösung in Ihrer Anwendung:

  1. füge in der Datei .bashrc (für alle aktuellen Benutzer) oder in etc / bash.bashrc (für alle Benutzer)
  2. hinzu
  

NCURSES_NO_UTF8_ACS = 1

  1. Stellen Sie sicher, dass Sie Folgendes haben:

    • sudo apt-get -install ncurses

    • sudo apt-get install libncursesw5-dev

  2. Im Code hinzufügen: #include <locale.h> #include <ncurses.h> // Fluch ändern ------------------------------------- // in main hinzufügen setlocale (LC_TYPE, "");

  3. Kompilieren Sie die Anwendung mit -lncursesw , etwa wie folgt:

      

    gcc -o arquivo arquivo.c -lncursesw

Edvaldo Silva 06.08.2017 02:59
quelle

Tags und Links