Chrome-Fenster sind sehr träge, wenn sie in verschiedenen Arbeitsbereichen aktiv sind

12

Ich habe ein Problem mit Google Chrome auf meinem 16.10-Laptop. Wenn mindestens ein Google Chrome-Fenster in verschiedenen Arbeitsbereichen geöffnet ist, wird Chrome sehr träge. Interessanterweise ist dies nur der Fall, wenn bestimmte Websites in einem der Fenster angezeigt werden. Ich konnte nicht herausfinden, was der spezifische Trigger ist, aber es könnte etwas mit Flash oder HTML5 zu tun haben. Dies ist sicherlich der Fall für Youtube und Google Maps, aber auch für dict.cc, das Werbung anzeigt. Wenn ich eine dieser Seiten geöffnet habe, aber das Fenster minimiert habe, gibt es kein Problem.

Ich habe das auch mit Firefox getestet, aber in diesem Fall funktioniert alles gut.

Vielleicht hat jemand eine Idee?

Danke!

    
tz39R 15.11.2016, 22:29
quelle

4 Antworten

4

Das Problem wurde gelöst, als ich die Hardwarebeschleunigung deaktivierte. Das Scrollen ist immer noch etwas weniger flüssig, wenn YouTube auf einem anderen Arbeitsbereich läuft, aber das ist kaum bemerkbar.

    
tz39R 20.11.2016, 17:36
quelle
4

Ich laufe am 16.04.02 auf einem XPS 13 9360 (Kaby Lake) mit einer Intel 915 GPU.

Nach dem Upgrade des Kernels von 4.4.0 auf 4.8.0 (durch Installation des Hardware Enablement Stack) habe ich diese Probleme bekommen.

Ich habe festgestellt, dass nach Anweisungen zur Umgehung im Fehlerbericht das Problem lösen. Ich habe gerade die folgende Zeile am Ende in meinem /etc/enviroment hinzugefügt:

LIBGL_DRI3_DISABLE=1

Ich habe auch die in Kommentar # 31 vorgeschlagene Lösung versucht, aber das Durcheinander mit meinen externen Monitoren, also habe ich diese Änderung rückgängig gemacht.

    
Erik Torsner 03.05.2017 00:13
quelle
1

Das Aktivieren der DRI3-Option in xorg.conf scheint das Problem für mich behoben zu haben.

Stellen Sie sicher, dass die DRI3-Option in /etc/X11/xorg.conf aktiviert ist. Ich musste die Datei mit dem folgenden Inhalt erstellen:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "SwapBuffersWait" "0"
    Option      "DRI" "3"
EndSection

Ich verwende Intel-Treiber, also müssen Sie sich vielleicht umsehen, um die richtige Zeichenfolge zu finden, die Ihre darstellt.

Diese Lösung erspart das Festlegen der Umgebungsvariable LIBGL_DRI3_DISABLE , und Sie sollten den Browser nicht ohne Hardwarebeschleunigung ausführen müssen.

    
Cam Schmidt 22.05.2017 00:12
quelle
0

Im Moment behalte ich nur beide / alle Fenster im selben Arbeitsbereich. Das scheint weniger ärgerlich als der Umgang mit langsamen Videos, aber vielleicht werde ich es irgendwann ändern.

    
colan 20.04.2017 02:39
quelle

Tags und Links