Android Studio rendert Ubuntu Mono Font nicht gut

13

Es erkennt es nicht einmal als Monospaced-Schriftart. Dann wird nur Anti-Aliasing angezeigt, wenn die Schriftgröße auf 20 oder höher eingestellt ist. Aber für andere Schriften tut es es bei 16.

Das Ergebnis sind hässlich aussehende Schriftarten und Augenbelastungen bei 16, die immer noch groß sind.

Ich verwende diese Einstellungen in studio64.vmoptions Datei

-Dawt.useSystemAAFontSettings=lcd
-Dswing.aatext=true
-Dsun.java2d.xrender=true

Ich habe verschiedene Einstellungen für Dawt.useSystemAAFontSettings ausprobiert und immer noch das gleiche Problem.

Ubuntu Monospace-Schrift sieht in Eclipse und anderen Text-Editoren gut aus. Wo in Eclipse ist es Größe 12 und es wird gut gerendert.

Hier sind einige Screenshots Ubuntu Mono 16:

Ubuntu Mono 20

Source Pro 16 (Ich denke, kommt mit Studio)

Ubuntu Mono 12 in Eclipse (ideal für mich)

Ich habe die Bilder imgur hochgeladen, da diese Seite die Bilder komprimiert und die Qualität beeinträchtigt ist.

Gibt es eine andere Einstellung, die steuert, welche Größe Anti-Aliasing für eine Schriftart aktiviert. Gibt es eine Möglichkeit, die im Android Studio verwendete dpi-Einstellung zu steuern?

Jeder andere hat andere Font-Empfehlungen. Ich habe droid mono und andere Standard-Udo, die mit Ubuntu kommen, ausprobiert.

Ich benutze Android Studio 0.86, Oracle's Java 7 auf Ubuntu 12.04 mit Nvidia-Treibern.

    
pt123 26.10.2014, 02:01
quelle

3 Antworten

2

Das Problem ist nicht Anti-Aliasing - alle Ihre Beispiele zeigen, dass der Text Anti-Aliasing fein ist.

Der Unterschied liegt in einem Aspekt des Font-Renderings, der "Hinting" genannt wird - das obere Ubuntu Mono-Beispiel zeigt ein starkes Hinting, während das untere Ubuntu Mono-Beispiel ein glatteres Hinting zeigt. Hinting deformiert die Buchstabenformen, um sie besser an das Pixelraster anzupassen und ein knackigeres Aussehen zu verleihen.

Ob Sie das eine oder das andere mögen, ist eine Frage der persönlichen Vorliebe. Der obere ist sicherlich sehr klar zu lesen, aber auf Kosten der Verformung der Buchstabenformen.

Die Java-Umgebung verwendet statt ihrer globalen Einstellungen einen eigenen Font-Renderer, daher der Unterschied.

Dafür gibt es verschiedene Fixes, die in diesem Link unter stackoverflow.com beschrieben sind:

Link

Dieser sieht ziemlich einfach aus (ich habe das nicht getestet):

Versuchen Sie,

hinzuzufügen
export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=gasp'

zu Ihrer ~ / .bashrc

Aber die gewählte Lösung ist komplexer.

    
thomasrutter 23.07.2015 13:42
quelle
0

Gefunden sehr einfache und sehr knifflige Lösung Link zum Video Der Typ hat gerade einen Link zu einem JRE aus dem Intellij Idea-Ordner erstellt und ihn in den Android Studio-Ordner und Vuala eingefügt!

    
maks1m 23.08.2016 17:46
quelle
0

zum Auflösen von JAVA abgeholt Option:

folge einfach dem einfachen Schritt:

Öffnen Sie ein Terminal:

sudo -i
[sudo] password for amit: ******* <------ Your system password
gedit /etc/profile

{Jetzt wird ein Editor geöffnet. Löschen Sie nichts, im letzten Teil, wo Sie Ihren JAVA PATH nach fi setzen, schreiben Sie einfach

unset _JAVA_OPTIONS

und speichern Sie es und schließen Sie

Nach diesem Typ wieder in Ihr Terminal

exit
. /etc/profile

alle werden jetzt gesetzt, check

java -version
java version "1.8.0_112"
Java(TM) SE Runtime Environment (build 1.8.0_112-b15)
Java HotSpot(TM) 64-Bit Server VM (build 25.112-b15, mixed mode)
    
Amit 18.02.2017 07:36
quelle