Unity läuft langsam. Wie kann ich die Leistung verbessern?

12

Ich mag es, wie Unity aussieht, aber ich habe zwei Probleme:

  1. Unity 3D
    Wenn ich mich mit Unity 3D anmelde, wird mein PC langsamer, ich habe ein AMD II X3 mit 2GB RAM, Nvidia Gforce 6150SE nForce 430 / PCI / SSE2 integriert.
    Wenn ich versuche, das Armaturenbrett zu öffnen, brauche ich viel Zeit zum Öffnen. Meistens dauert es bis zu 5 Sekunden. Während die Öffnung verschwommen und unreagiert bleibt, brauchen sogar die Apps oder Ordner die gleiche Zeit zum Öffnen und die gleiche Reaktion. p>

  2. Einheit 2D Wenn ich mich mit Unity 2D anmelde, geht mein PC schneller, das einzige Problem ist, dass ich Unity nicht so konfigurieren kann, wie ich möchte. Ich versuche, das Unity-Plugin in CCSM zu konfigurieren.
    Zum Beispiel: Ich habe "hide Launcher" in "Never" geändert. Es speichert keine Änderungen, selbst wenn ich meinen Computer neu starte.

Ich weiß nicht, ob das Problem mit Unity 3D oder mit meinem PC ist.

    
Cesar Gomez 16.10.2011, 01:36
quelle

5 Antworten

16

Gehen Sie in CCSM zu den Optionen für Ubuntu Unity Plugin und ändern Sie im Tab Experimentell die Option Dash Blur von "Active Blur" zu "Static Blur" oder "No Blur".

Sie können auch in die Option Composite wechseln und die Option "Refresh-Rate erkennen" deaktivieren und die Option Aktualisierungsrate auf über 60 erhöhen.

Um die Leistung weiter zu steigern, müssen Sie Nvidias proprietäre Treiber installiert haben (stellen Sie sicher, dass Sie die neueste Version verwenden). Gehen Sie in NVIDIA X Server-Einstellungen und in GL-Einstellungen öffnen Ändern Sie "Bildeinstellungen" in "Hohe Leistung".

Denken Sie daran, dass diese Optionen nur für * Unity 3D *

gelten     
Evan 18.10.2011, 09:55
quelle
2

Sie können CCSM nicht dazu veranlassen, Unity-2D zu konfigurieren, da es compiz nicht zum Anzeigen von Unity verwendet. Sie müssen den dconf-editor benutzen oder Sie können dieses Tool benutzen:

link

Hoffe, das hilft.

Luis Da Costa     

aliasbody 16.10.2011 02:03
quelle
0

Ich hatte die gleiche Sache mit ati-Treiber ist ein Problem, weil einige Treiber die Prozeduren "GLX_EXT_texture_from_bitmap" nicht unterstützen, ist es notwendig, AIGLX zu arbeiten. Wenn es kein AIGLX gibt, geht alles durch XGL, einschließlich 3D und daher langsam.

    
Radziej 19.10.2011 15:45
quelle
0

Versuchen Sie, die nvidia-96 Treiber zu installieren. Unity 3d funktioniert danach gut für mich.

Auch Compiz Tweaks werden helfen.

    
martu 20.10.2011 05:19
quelle
-1

Versuchen Sie, den CCSM (CompizConfig Settings Manager) zu verwenden, um zuerst andere Plugins zu deaktivieren.

Hilft das?

    
fixedit 16.10.2011 01:52
quelle

Tags und Links