Fehler in dmesg - Test-WP ist fehlgeschlagen, Schreibe aktiviert [Duplikat]

12

Ich habe Probleme mit dem Cache des Laufwerks und weiß nicht, was diese Probleme verursacht. Das ist mein dmesg:

[11690.011238] sd 6:0:0:0: [sdb] Asking for cache data failed
[11690.011248] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[11741.720851] sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled
[11741.722965] sd 6:0:0:0: [sdb] Asking for cache data failed
[11741.722975] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[11793.433011] sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled
[11793.435347] sd 6:0:0:0: [sdb] Asking for cache data failed
[11793.435356] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[11845.140846] sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled
[11845.143098] sd 6:0:0:0: [sdb] Asking for cache data failed
[11845.143102] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[11896.856723] sd 6:0:0:0: [sdb] Test WP failed, assume Write Enabled

Es gibt Hunderte dieser Zeilen. Es ist passiert, seit ich Ubuntu 12.04 64bit beta2 von meinem pendrive installiert habe. Jetzt habe ich nichts bei / dev / sdb. Ich weiß nicht, ob diese Fehler mein System weniger ansprechbar machen, aber ich denke, dass dmesg nicht so aussehen sollte.

Meine Kernelversion: 3.2.0-24-generic .

Haben Sie eine Idee, wie Sie es lösen können?

Vielen Dank im Voraus.

    
mescam 05.05.2012, 16:33
quelle

5 Antworten

9

Ich habe das gleiche Problem mit der offiziellen Version von 12.04 LTS. Ich glaube auch, dass das System weniger ansprechbar ist. Laut einigen Quellen ist es harmlos. (ich kann anscheinend nur 2 links posten)

Die folgende Ansicht ist eine Fehlerausgabe eines integrierten Kartenlesers:

link

Es ist bestätigt, dass es sich bei

um ein Upstream-Problem handelt

link

Führen Sie lsusb aus und finden Sie das fehlerhafte Gerät

nathan@Ham-Bone:~$ lsusb 

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader

In meinem Fall ist es der Realtek-Multicard-Reader, der eine schnelle Überprüfung von

ermöglicht
$ dmesg | grep realtek
[    4.716068] usbcore: registered new interface driver ums-realtek
$ lsmod | grep realtek
ums_realtek            17920  0 

enthüllt ein Modul ums-realtek

$sudo rmmod ums_realtek

Behebt das Problem auf reversible Weise für mich. Das ist

$sudo modprobe ums_realtek

aktiviert den Kartenleser erneut. Ich habe nicht getestet, ob es funktioniert, da ich es nie benutze.

Wenn dies nicht funktioniert, gibt es andere Möglichkeiten, USB-Geräte zu deaktivieren, indem Sie sie im / sys / -Verzeichnis aufheben.

    
N8tron 06.05.2012, 16:57
quelle
6

Ich habe festgestellt, dass das Laden des Treibers mit der Option ss_en = 0 funktioniert. Tun

echo "ums-realtek ss_en=0" |sudo tee -a /etc/modules

macht die Änderung dauerhaft.

Weitere Erklärung:

Bei dem Versuch herauszufinden, warum diese Meldung auftritt, habe ich die Optionen für die beiden beteiligten Module, ums-realtek und usb-storage, untersucht. Ich hatte nicht das Gefühl, dass das Laden und Entladen des ums-realtek-Moduls jedes Mal eine geeignete Lösung ist, da ich häufig den Kartenleser verwende.

Moduloptionen prüfen:

# modinfo ums-realtek 
  parm: auto_delink_en  enable auto delink (int)
  parm: ss_en           enable selective suspend (int)
  parm: ss_delay        seconds to delay before entering selective suspend (int)

Die Untersuchung, was diese Optionen waren, brachte kein Ergebnis, und ich fühlte mich nicht geneigt, den Autor per E-Mail zu stören. Da dieser Treiber auch den USB-Speicher verwendet, war die Option "Suspend" möglicherweise standardmäßig aktiviert (z. B. um den Akku von Laptops zu schonen) und die Meldungen resultieren aus Wakeup-Query-Suspend-Sequenzen. Da es mir egal war, ob das Gerät ständig eingeschaltet war oder nicht, habe ich versucht, diese Option auf 0 (Aus) zu setzen, und es funktioniert.

    
Kaulbach 12.07.2012 22:24
quelle
0

Ich bekam das gleiche Problem, nachdem ich Ubuntu 12.04 Server installiert hatte. Ich habe gedit installiert, um die Protokollierungsstufe zu ändern (lache nicht darüber, dass ich gedit verwende). Bei der Installation von gedit wurden auch viele Archivpakete von ubuntu.com installiert. Nach der Installation ließ ich meinen Monitor an und der PC blieb unberührt, um zu sehen, ob er erneut auftritt und nicht. Dies scheint das Problem für mich gelöst zu haben. Ich sage nicht, dass du gedit installieren sollst, aber vielleicht entfernt man die Archivpakete, die mit gedit geliefert werden. Hoffe, das hilft.

    
Jason 15.05.2012 21:28
quelle
0

Das Entladen des Treibers funktioniert für mich! Ich benutze nie den Kartenleser, also war dies eine gute Option, sonst hätte ich die Option 'ss_en = 0' gesetzt     

sep69 14.08.2012 09:52
quelle
0

Ich habe die gleiche Ausgabe in dmesg erhalten, als ich versehentlich den IDE-Anschluss auf einem Datenträger einen Schritt gefunden hatte, der am IDE-zu-USB-Adapter falsch ausgerichtet war. Das kann die Ursache Ihres Problems sein.

    
Anders Lugnér 23.08.2012 18:39
quelle

Tags und Links