CIFS-Mount durch fstab beim Booten nicht mounten

14

Ich habe eine CIFS-Freigabe auf meinem NAS, die ich beim Booten bereitstellen möchte - sie wird von meinem MythTV-Server als Hauptmedienspeicher verwendet. Ich habe einen Eintrag in fstab hinzugefügt, damit er geladen werden kann, aber es ist nicht möglich. Es scheint, als würde fstab nach Durchsicht meiner Systemprotokolle gelesen, bevor meine Netzwerkschnittstellen online sind. Kann ich den fstab -Eintrag bearbeiten, um dies zu ändern?

Der fstab -Eintrag zum Einhängen der Freigabe lautet:

\192.168.0.26\mythtv\media  /media/mybooklive  cifs  username=user,password=pass,umask=002,uid=136,gid=144,iocharset=utf8   0       0

Nach dem Start kann es problemlos geladen werden, wenn ich sudo mount -a ausstelle, und es gibt keine anderen Probleme.

Danke!

    
douggro 03.01.2014, 20:05
quelle

5 Antworten

7

Es ist ein Syntaxfehler. Ich denke, Sie brauchen ein "/" und nicht ein "\" wie dieses.

//192.168.0.26/mythtv/media  /media/mybooklive  cifs  username=user,password=pass,_netdev,umask=002,uid=136,gid=144,iocharset=utf8  0 0

Weitere Informationen finden Sie unter: Link .

    
Panther 04.01.2014, 16:35
quelle
19

Haben Sie versucht, die Option _netdev zu Ihrem fstab -Eintrag hinzuzufügen? Sie würden es mit den anderen Optionen wie

in Ihre Zeichenfolge einfügen
//192.168.0.26/mythtv/media  /media/mybooklive  cifs  username=user,password=pass,_netdev,umask=002,uid=136,gid=144,iocharset=utf8   0       0

_netdev soll den Mount verzögern, bis das Netzwerk verbunden ist.

    
djmadscribbler 03.01.2014 20:22
quelle
9

Wenn _netdev nicht funktioniert, versuchen Sie die Option:

  

x-systemd.automount

stattdessen

. Es funktioniert, indem das Laufwerk beim ersten Zugriff gemountet wird.

Um den Automount zu testen, müssen Sie die Freigabe der Freigabe aufheben, wenn sie aktuell angehängt ist:

$ sudo umount /media/mybooklive

Starten Sie anschließend die remote-fs systemd-Einheit erneut:

$ sudo systemctl daemon-reload
$ sudo systemctl restart remote-fs.target
    
t-dome 09.09.2016 21:06
quelle
4

Ich verwende den Raspbian-Stretch-Build vom 2017-09-07 und hatte das gleiche Problem. Ich konnte dieses Problem jedoch überwinden, indem ich in raspi-config ging und unter dem Menü Boot Options die Option "Wait for network at boot" aktivierte.

    
Chris 26.11.2017 12:22
quelle
2

- Das Verwenden von Schrägstrichen (/) hat es NICHT für mich korrigiert.
-Auch das Hinzufügen der Option _netdev zu meinem /etc/fstab -Eintrag wurde für mich NICHT korrigiert.

Was ich getan habe, um dieses Problem (auf meinem Pi3) zu beheben, ist, dass Sie /etc/rc.local so ändern, dass Sie 20 Sekunden lang schlafen (indem Sie sleep 20 aufrufen) und dann mount -a aufrufen. Auf diese Weise, obwohl das Netzwerk noch NICHT verbunden ist, wenn das System die fstab-Datei zum ersten Mal liest, also das Einhängen fehlschlägt, zwinge ich das System, hier 20 Sekunden zu warten (und gibt dem Netzwerk Zeit, eine Verbindung herzustellen). Dann erzwinge ich den Aufruf von mount -a erneut, um alle Laufwerke in der fstab -Datei bereitzustellen.

So sieht meine /etc/rc.local -Datei jetzt aus:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# Print the IP address
#GS notes: a *minimum* of sleep 10 is required for the mount below to work on the Pi 3; it failed with sleep 5, but worked with sleep 10, sleep 15, and sleep 30
sleep 20
_IP=$(hostname -I) || true
if [ "$_IP" ]; then
  printf "My IP address is %s\n" "$_IP"
  mount -a #GS: mount all drives in /etc/fstab
fi

exit 0

Fertig! Es funktioniert jetzt perfekt für mich!

Referenzen:

Gabriel Staples 21.03.2017 04:09
quelle

Tags und Links