Wie installiere ich XULRunner, da es eine Anfrage für Pencil ist? [Duplikat]

11

Ich installiere Pencil und erhalte den folgenden Fehler: xulrunner: not found. XULRunner ist eine Voraussetzung für Pencil. Wie installiere ich XULRunner und seine Abhängigkeiten?

    
diff 17.05.2011, 22:01
quelle

5 Antworten

14

Sie können die neueste Quelle von XULRuner installieren, indem Sie Folgendes ausführen:

sudo add-apt-repository ppa:ubuntu-mozilla-daily/ppa
sudo apt-get update
sudo apt-get install xulrunner-2.0 xulrunner-2.0-dev xulrunner-2.0-gnome-support xulrunner-dev

Nach der Installation müssen Sie update-alternatives hinzufügen, so dass es standardmäßig verwendet wird:

sudo update-alternatives --config xulrunner 

Seien Sie vorsichtig, dass dieser ppa auch eine aktualisierte Version von Firefox und Thunderbird enthält.

    
sebikul 07.05.2011, 23:38
quelle
6

Sie können xulrunner-Apps tatsächlich ausführen, ohne xulrunner zu installieren und nur firefox verwenden.

Wenn Sie auf link klicken, heißt es:

  

Firefox 3 und neuer wird mit einem privaten XULRunner-Paket ausgeliefert, das jede kompatible XULRunner-Anwendung mit dem Schalter -app ausführen kann.

Also entpackte ich gerade die .tar.gz-Verteilung des Stifts, navigierte in das Verzeichnis user / share / pencil (oder was auch immer) und tat:

firefox -app application.ini

tada! Keine zusätzlichen Installationen erforderlich.

    
Asfand Qazi 20.08.2013 21:19
quelle
4

Sie müssen eines der Pakete xulrunner-1.9.2 oder xulrunner-2.0 installieren, je nachdem, welche Version von xulrunner Sie benötigen.

    
Florian Diesch 17.05.2011 22:21
quelle
2

Obwohl spät, aber jeder, der hier stolpert, müssen Sie XULRunner nicht mehr herunterladen. Laden Sie einfach ihre Veröffentlichung von ihrer Website herunter und Sie können loslegen. Es funktioniert mit Raring gut!

    
Stefano Mtangoo 30.05.2013 00:41
quelle
1

Es ist kein neues Paket mehr verfügbar.

Vom Link

Legen Sie Folgendes in eine Datei und führen Sie sie aus. Es wird eine Version heruntergeladen, die Ihrer aktuellen Firefox-Version entspricht. Extrahieren Sie die Dateien und erstellen Sie aus praktischen Gründen einen symbolischen Link.

FIREFOX_VERSION='grep -Po  "\d{2}\.\d+" /usr/lib/firefox/platform.ini'
ARCH='uname -p'
XURL=https://ftp.mozilla.org/pub/mozilla.org/xulrunner/releases/$FIREFOX_VERSION/runtimes/xulrunner-$FIREFOX_VERSION.en-US.linux-$ARCH.tar.bz2
cd /opt
sudo sh -c "wget -O- $XURL | tar -xj"
sudo ln -s /opt/xulrunner/xulrunner /usr/bin/xulrunner
    
Richard Ayotte 29.05.2013 23:02
quelle