Kein Sound auf Ubuntu 12.04

11

Nachdem ich Ubuntu 12.04 installiert habe, gibt es keinen Ton mehr auf meinem Kopfhörer (hinteres Anschlussfeld).

Ein Toneinstellungen & gt; Wiedergabe, schien es, dass die Sounds erkannt wurden, nachdem ich "play sound" gewählt habe.

Kann jemand dieses Problem beheben?

Danke.

    
Denni 12.05.2012, 04:02
quelle

11 Antworten

10

Link

Ich habe gerade Schritt 1 getan und dann meinen Laptop neu gestartet und der Sound funktioniert.

Wenn Sie Ubuntu 12.04 oder später verwenden, führen Sie diesen Befehl aus und starten Sie ihn neu:

  

Lesen und verstehen Sie genau, was diese Befehle bewirken. Zum Beispiel sudo apt-get install   Befehl enthält den gesamten Ubuntu-Desktop . Dies wird wahrscheinlich erstellen    Probleme für Benutzer der anderen Ubuntu-Varianten - ein Kubuntu-Benutzer   Ich möchte nicht, dass die Unity-Schnittstelle installiert wird. Während das Ergebnis von   Das Ausführen der vorgeschlagenen Befehlsfolge unten kann in der Tat sicher beheben   Hörprobleme, sei dir bewusst, dass es sich um einen sehr stumpfen Ansatz handelt und könnte   unbeabsichtigte Folgen haben.

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa;              \ 
sudo apt-get update;                                           \ 
sudo apt-get dist-upgrade;                                     \ 
sudo apt-get install linux-sound-base alsa-base alsa-utils gdm \           
     ubuntu-desktop  linux-image-'uname -r' libasound2;        \
sudo apt-get -y --reinstall install linux-sound-base alsa-base \ 
     alsa-utils gdm ubuntu-desktop  linux-image-'uname -r'     \     
     libasound2;                                               \ 
killall pulseaudio;                                            \  
rm -r ~/.pulse*;                                               \
sudo                                                           \ 
    usermod -aG $(                                             \
          cat /etc/group |                                     \
          grep -e '^pulse:' -e '^audio:' -e '^pulse-access:'   \
          -e '^pulse-rt:' -e '^video:' |                       \
          awk -F: '{print }' |                               \ 
          tr '\n' ',' |                                        \
          sed 's:,$::g'                                        \ 
    ) $(whoami)

Fügen Sie den gesamten Codeblock mit STRG - SHIFT - V in Ihr Terminal ein und drücken Sie die Eingabetaste.

    
Antonio_Sid 20.06.2012 10:49
quelle
7

Versuchen Sie Folgendes:

sudo killall pulseaudio
sudo alsa force-reload
    
erik 05.10.2012 17:25
quelle
4

Was auch immer Sie tun, geben Sie nicht den riesigen Code auf der ersten Antwort ein! Es hat meinen Login-Bildschirm komplett ruiniert.

Verwenden Sie einfach killall pulseaudio im Terminal.

    
Joseph Beck 03.08.2012 23:05
quelle
3

Warst du gedämpft? Probieren Sie für Pulseaudio pavucontrol aus und überprüfen Sie, ob die Stummschalttaste auf der Registerkarte Output Devices aktiviert ist:

    
Xiè Jìléi 12.05.2012 04:40
quelle
1

Ich hatte das gleiche Problem, ich habe meine Lautsprecher in den hinteren Audioausgang gesteckt und es funktionierte. Beim Sound-Test unter "Stereo-Modus" funktioniert die Front links / rechts, aber wenn ich es in 5.1 setze, werden meine Lautsprecher auf die hinteren Kanäle konvertiert, wie sie sein sollen. Also lasse ich es einfach in Stereo (das sind sie sowieso).

Obwohl, wenn Sie einen Laptop oder "non-HD Audio" Hardware haben (nur ein Line In, Line Out, Mic), ist dies nicht möglich.

Auch das seltsame Ding war mein Frontpanel-Audio funktioniert gut, muss etwas doof mit den Realtek HD-Audiotreibern sein ...

    
Andy 08.08.2012 08:37
quelle
1

Ich hatte das gleiche Problem wie das OP für eine kleine Weile und ich habe es schließlich herausgefunden.

Überprüfen Sie Ihr BIOS und stellen Sie sicher, dass Ihr Onboard-Audio aktiviert ist. Nicht automatisch oder deaktiviert. Meine war auf Auto und nichts würde 12.04 das Gerät sehen lassen.

    
Bill Todd 14.12.2012 02:21
quelle
1

Das ist, was es für mich repariert hat.

Terminal öffnen

sudo gedit /etc/modprobe.d/modprobe.conf

Eine neue Datei wird geöffnet, eine Zeile darunter schreiben und dann speichern.

options snd_hda_intel model=mb5

Datei schließen Starten Sie den Computer neu.

Danke an Kein Ton auf einem iMac

    
Akshat Kedia 27.08.2013 12:42
quelle
0

Dies hat nicht für meinen Fall Ubuntu AMD 64 12.04 mit HP Quad Core PC 5 GB RAM funktioniert. Andere Probleme gab es und Sound verschwand nach Updates und anderer Software-Installation. Könnte auch ein Script-Bug vorliegen? Lokalisierte Dateien und von der Homepage delegiert. festgestellt, dass Kubuntu-Treiber für den PC mit der DVD-ISO war NVidea MCP61 verwendet sudo apt-get installieren Nvidea MCP61

Gefundene synaptische Dateien, die beschädigt wurden und versucht haben, sie zu beheben. Un installiert oder entfernt, installiert, aktualisiert die dritte Datei.

Wurde vom PC deaktiviert und neu gestartet, nachdem auf die Installation von Updates und Upgrades gewartet wurde. Am nächsten Tag ist die Toneinstellung wieder normal und die Dummy-Ausgangseinstellung ist weg.

    
Tom Sucic 24.09.2012 08:32
quelle
0

In einem Terminal habe ich gstreamer-properties ausgeführt, Eingabe und Ausgabe zu ALSA Advanced Linux Sound Architecture gezwungen und neu gestartet. Dann hat es gut funktioniert!

    
broomie 20.08.2012 11:21
quelle
0

Versuchen Sie Folgendes zu lesen: Skype FAQ - Soundsystemwechsel

    
Vladimir S. 18.06.2013 09:13
quelle
0

O-Taste. Ich sehe dein Problem. Ich hatte es auch. Versuche dies. Es ist sicher und funktionierte für mich.

Öffnen Sie das Terminal und geben Sie

ein
  

alsamixer

Drücken Sie S und wählen Sie die Option HD-Audio Allgemein. Blättern Sie zu Autom. Und deaktivieren Sie es Jetzt drehen Sie alle Lautstärkeoptionen auf Drücken Sie Esc, um

zu beenden

Fertig!

Versuche jetzt etwas zu spielen Viel Glück;): D

    
Jatttt 19.06.2014 21:33
quelle

Tags und Links