Mauszeiger seltsames Problem

9

Ich habe letzte ubuntu installiert (10.10), aber von einem Jahr und tausend Updates, Videotreiber Updates, Hunderte von Tricks, der Mauszeiger ist wie ein HÄSSLICHES Quadrat ...

gezeigt

Dies sind die Screenshots:


Ich habe keine Ahnung, was ich tun soll, um dieses Problem zu lösen. Jeder von euch hat eine Idee, es zu lösen?

Bearbeiten: Dieses Problem wurde ab 8.10 +!

gefunden

Bearbeiten Sie 2, Grafikkartenspezifikationen:

[email protected]:~$ hwinfo --gfxcard
35: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_1106_3230
  Unique ID: VCu0.QX54AGQKWeE
  Parent ID: vSkL.CP+qXDDqow8
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "VIA K8M890CE/K8N890CE [Chrome 9]"
  Vendor: pci 0x1106 "VIA Technologies, Inc."
  Device: pci 0x3230 "K8M890CE/K8N890CE [Chrome 9]"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x81b5 
  Revision: 0x11
  Memory Range: 0xd0000000-0xdfffffff (rw,prefetchable)
  Memory Range: 0xfa000000-0xfaffffff (rw,non-prefetchable)
  Memory Range: 0xfbcf0000-0xfbcfffff (ro,prefetchable,disabled)
  IRQ: 16 (10026 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001106d00003230sv00001043sd000081B5bc03sc00i00"
  Driver Info #0:
    Driver Status: viafb is not active
    Driver Activation Cmd: "modprobe viafb"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #17 (PCI bridge)

Primary display adapter: #35
[email protected]:~$ 

danke,
A

    
elp 13.01.2011, 01:31

2 Antworten

3

Sie haben eine VIA-Grafikkarte, das ist einer der am schlechtesten unterstützten Grafikchipsätze.

Was passiert ist, dass der Hardware-Cursor (das ist ein spezieller Teil der Grafikkarten-Fähigkeit, die einen schönen glatten Cursor erzeugt) beschädigt wurde. Normalerweise liegt das daran, dass der gesamte Videospeicher verwendet wurde.

Wenn Sie in das BIOS gehen und die Menge an RAM erhöhen können, die dem integrierten Videogerät zur Verfügung gestellt wird. Dies kann das Problem für Sie lösen.

Es kann immer noch ein Treiberproblem sein, wie ich am Anfang sagte, VIA wird nicht gut unterstützt, so dass Sie vielleicht auf eine NVIDIA, Intel oder ATI Grafikkarte aufrüsten möchten.

    
Martin Owens -doctormo- 22.01.2011, 23:08
2

Wenn Ihre /etc/X11/xorg.conf -Datei existiert und einen Device -Abschnitt hat, können Sie sie so einstellen, dass sie einen Software-Cursor verwendet. Fügen Sie einfach die Zeile

hinzu
Option        "SWCursor" "true"

in diesem Abschnitt. Dieser sollte bewirken, dass der Cursor in Software gerendert wird, nicht von der Grafikkarte.

    
Paul Fisher 25.01.2011 08:08

Tags und Links