dell 7520 (inspiron 15R SE), Gebläse auf volle Geschwindigkeit am 12.04., 12.10., 13.04

9

Der Lüfter meines dell inspiron 7520 (inspiron 15R SE) läuft ständig mit voller Geschwindigkeit und viel Lärm.

technische Details:

  • GRAFIK: 2GB AMD RADEON HD 7730M, umschaltbar / hybrid mit Intel 4000-Grafik
  • INTEL CORE I5-3210M 2.50
  • 6 GB RAM
  • 1080hd-Anzeige
  • 750 GB Festplatte
  • Dual-Boot-Win7 64 und Ubuntu 12.10 64
  • BIOS Version A09 (1. Januar 2013 = neueste)

Ich habe eine Menge Vorschläge aus tausenden von Foren ausprobiert, sie haben nicht alle geholfen, der Fan dreht sich weiter. Hier ist eine Liste der Dinge, die ich getan habe, vielleicht kann ich jemandem helfen, die Arbeit zu vermeiden, oder jemand hat eine Lösung, die ich noch nicht ausprobiert habe:

die nutzlosen Optionen

  1. versucht verschiedene Betriebssysteme: In Windows 8 und 7 funktioniert alles einwandfrei. ubuntu 12.04, 12.10, 13.04 jeweils 32bit und 64bit ich habe laute Lüfter

  2. BIOS-Optionen / Update: Ich aktualisierte Bios von A07 zu A09, keine Änderung der fanspeed Intel Speedstep, Intel Smart Response, AHCI, ATA-Modus, keine Änderungen der Lüftergeschwindigkeit

  3. mit verschiedenen Partitionstabellen, Boot-Modi: Ich benutzte Uefi Boot auf einer Gpt-Partition, auf MBR und Legacy-Boot, keine Änderungen in der Lüftergeschwindigkeit

  4. Umschalter: Das einzige, was wenig hilft, ist die switcheroo Optionen Von diesem Link Link das Ausschalten der AMD-Karte spart eigentlich nur Strom, reduziert aber nicht die Lüftergeschwindigkeit

    echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
    
  5. Energieoption: Dieser Link Probleme mit Dell Inspiron7520 und Ubuntu 12.04 war bisher am hilfreichsten Kommentar, es reduziert Lüftergeschwindigkeit sofort, aber mit wenig CPU-Auslastung steigt wieder auf volle Geschwindigkeit ... also keine befriedigende Lösung.

    echo "min_power" | sudo tee /sys/class/scsi_host/host*/link_power_management_policy
    

    Das Herausziehen des Netzsteckers reduziert in den meisten Fällen die Lüftergeschwindigkeit, läuft aber von Zeit zu Zeit mit voller Geschwindigkeit.

  6. Grafiktreiber: Die Katalysatorfahrer haben überhaupt nicht funktioniert. Ich probierte einmal etwas anders aus 12. etwas bis zu 13.2 beta Nach der Installation Einheit oder Compiz hat nicht funktioniert und ich hatte einen leeren Desktop-Bildschirm, neben Lüftergeschwindigkeit würde sich nicht ändern.

  7. Kernel: Ich habe mehrere Kernel bis zum neuen Quantum 3.7 ausprobiert, nichts hat sich geändert

  8. i8kutils / lm-Sensoren, pwmconfig: um den Lüfter manuell zu steuern lm Sensoren mit pwmcontrol haben nicht funktioniert (keine kompatiblen Sensoren erkennen ... so etwas) i8kutils aus diesem Thread link kontrollierte die Ventilatoren und hielt das Geräusch niedriger, aber die Temperatur steigt und der Ventilator fängt an sich ein paar Sekunden zu drehen und stoppt, startet wieder und stoppt und so weiter, das ist noch beunruhigender als mit voller Geschwindigkeit zu laufen ... also keine Option für mich.

  9. Jupiter: Jupiter spart Batteriestrom, reduziert aber nicht die Lüfterdrehzahl.

und hier kommt die fragwürdigste Sache. Mein Mitbewohner hat genau das gleiche Modell. Der Unterschied ist, dass sie die BIOS-Version A02 hat (oder A04 nicht sicher jetzt), mit einer 1 TB Festplatte und kein 1080 hd Display und ubuntu 12.04 Dual Boot Win 7 jede 32bit funktioniert gut aus der Box. Ich habe versucht, BIOS auf A04 Downgrade aber funktioniert nicht, ein Fehler auftritt.

Ich arbeite viel zu lange daran, ich bin seit Monaten dahinter. ich versuche sogar, mich in Fenstern wohl zu fühlen, obwohl ich nie wieder zu thas os zurückkehren möchte.

Grüße zanza

Ich habe lm-sensors ausgeführt und ich weiß nicht wirklich, wie ich die Ausgabenachricht interpretiere. auf dem anderen oben erwähnten Laptop, gleiches Modell mit kleinen Unterschieden zeigt es neben temp1 auch temp2

Mein lm-sensors zeigt dies:

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +43.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +43.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +41.0°C  (high = +87.0°C, crit = +105.0°C)

radeon-pci-0100
Adapter: PCI adapter
temp1:        +48.0°C  

lm-sensors des anderen Laptops (dasselbe Modell, mit Unterschieden wie oben erwähnt) zeigt dies:

acpitz-virtual-0
Adapter: Virtual device
temp1:        +27.8°C  (crit = +106.0°C)
temp2:        +29.8°C  (crit = +106.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +50.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +50.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +51.0°C  (high = +87.0°C, crit = +105.0°C)

kann mir jemand erklären, was es bedeutet?

    
zanza 05.02.2013, 19:50

9 Antworten

1

Also hatte ich das gleiche Problem mit meinem Inspiron, aber ich habe eine Nvidia 630m und eine Intel GPU. Um es zu lösen, verwende ich Hummel, da er meine Leistungsanforderungen erfüllt und damit mein Notebook nicht überhitzt. Ich weiß nicht, ob es solche Software für AMD gibt, aber Sie sollten danach suchen, da der Lüfter aus diesem Grund nonstop arbeitet.

    
user178016 24.07.2013 17:35
0

Hast du diesen Beitrag hier angesehen? Link

  

(4) OPTIONAL: Skript zum Ausschalten des Laptops

     

Dieses nächste Skript wird zum Ausschalten des Computers verwendet. Weil, in meinem   Fall, wenn ich den Computer ausschalte, ohne beide Karten einzuschalten   (besonders wenn die integrierte Karte eingeschaltet ist und die diskrete Karte ist   aus), der Lüfter läuft mit voller Geschwindigkeit, wenn ich ihn wieder einschalte und nur stoppe   nach dem Neustart. Um dies zu vermeiden, kann dieser andere Launcher verwendet werden   um den Computer auszuschalten:

    
oliver.prado 11.02.2013 21:47
0

Ich hatte das gleiche Problem, und nachdem ich den ganzen Tag lang gelebt hatte, hörte mein Ventilator auf, Lärm zu machen. Dies hat mit der Verwendung von GPU zu tun. Ich habe einige Vorschläge von askubuntu ausprobiert, aber der für mich arbeitete von der AMD Website.

Gehen Sie zu link und wählen Sie aus der Liste die Grafikkarte aus, die Sie auf Ihrem PC haben . Laden Sie es herunter und machen Sie die Datei ausführbar und führen Sie sie über Terminal aus. Etwas grafisches Installationsprogramm wird auftauchen, wählen Sie, was am besten zu Ihnen passt (ich wählte nicht Gewohnheit), und nach der Installation, starten Sie einfach Ihren PC neu.

Ich habe jetzt kein Lüftergeräusch und meine Grafik funktioniert einwandfrei. Ich habe auch AMD Catalyst Manager zum Spielen mit ...

    
user126851 16.02.2013 18:29
0

Ich habe ein ziemlich ähnliches Modell.

Ich habe den Katalysatortreiber installiert (HD 7700 Radeon). VGAswitcheroo funktioniert bei mir überhaupt nicht - es hängt die Maschine. Viele verschiedene Revisionen des Katalysatortreibers und des BIOS. (Ich bin jetzt bei A09). Ich denke nicht, dass es eine Möglichkeit gibt, das BIOS zurückzusetzen, aber ich erinnere mich, dass einige frühere Modelle eine Reihe von Kontakten auf dem Motherboard haben, die Sie erden können und die BIOS in den ursprünglichen Zustand zurückversetzt. Aber das waren Desktop-Maschinen und vor über einem Jahrzehnt.

Mein Lüfter scheint hochzufahren, wenn es nötig ist - aber er wird nicht heruntergefahren, wenn er nicht benötigt wird.

Ich habe das gleiche Problem mit Speed-Step. (scheint beim Aufwachen aus dem Ruhezustand standardmäßig 2,10 GHz zu sein und erfordert jedes Mal eine manuelle Neukonfiguration).

Außerdem muss ich jedes Mal, wenn ich neu starte, Bluetooth deaktivieren. Diese Einstellung wird nicht beibehalten.

Was ich für meinen Fan mache, benutze ich "sudo i8kfan 0 0" (von i8kutils) in einem Terminal, um den Lüfter herunterzufahren. Aber ich muss die Hardware-Sensoren-Anzeige und den PSensor verwenden, um mir zu sagen, ob es jemals überhitzt ist (weil manchmal der Lüfter nicht hochdreht; wenn die Zimmertemperatur zu heiß ist und die CPU-Last steigt). Ich benutze CPU Scaling Frequency Indicator, um den Takt auf 1,2 GHz herunterzufahren (was für fast alle Zwecke gut ist), und dies hält die Temperatur im Allgemeinen niedrig, so dass ich den Lüfter bei 0 oder 1 betreiben kann (abhängig von der Lufttemperatur) .

Ich habe auch ein Conky-Setup, das die CPU-Frequenz sowie die Wärme- und Lüftergeschwindigkeitsbeziehung verfolgt. Damit habe ich immer einen visuellen Hinweis. (Es ist kein Problem, dass ich manuell überwachen muss, wenn ich die Fans nur bei 2 belasse, das ist volle Geschwindigkeit, aber dann ist es laut).

Ich würde es wirklich mögen, wenn es ein Werkzeug gäbe, das diese Faktoren automatisch und dynamisch ausbalancieren könnte. Und vor allem die Override der Lüftergeschwindigkeit - ohne eine Befehlszeile verwenden zu müssen, in der ich mich authentifizieren muss.

    
NDP 14.06.2013 08:58
0

Ich habe das gleiche Modell, aber mit einer höheren Spezifikation. Ich benutze kein Ubuntu, aber ich hatte das gleiche Problem mit der Lüftergeschwindigkeit. Als ich im Internet nach Lösungen suchte, fand ich diese und einige andere. Ich hoffe, das Folgende ist hilfreich.

echo "min_power" | sudo tee /sys/class/scsi_host/host*/link_power_management_policy

Das hilft ein wenig. Aber haben Sie versucht, diesen Befehl auszuführen?

pm-powersave true

Dieses Skript stellt nicht nur min_power , sondern auch viele andere leistungsbezogene Verbesserungen ein.

Sie können auch versuchen, eine Datei /etc/modprobe.d/i915-kms.conf zu erstellen und die folgende Zeile in die Datei einzufügen. Ich habe das hier hier .

options i915 modeset=1 i915_enable_rc6=1 i915_enable_fbc=1 lvds_downclock=1 semaphores=1

Abhängig von der Kernel-Version, die Sie verwenden, ist der akzeptable i915_enable_rc6 -Wert anders. Der Patch hier beschreibt den Unterschied. Sie können modinfo i915 | fgrep i915_enable_rc6 ausführen, um zu sehen, ob ein höherer Wert als 1 zulässig ist.

    
majie 08.07.2013 16:04
0

Überprüfen Sie die Diskussion über diesen Bug, den ich kürzlich geöffnet habe. Es hat viele gute Ratschläge und Links für Dell Inspiron Maschinen. Link

    
Muhammad Gelbana 29.01.2014 08:43
0

Sie haben nicht erwähnt, dass Sie Intel (R) Graphics Installer für Linux erwähnt haben. Ich hatte selbst einige Fanprobleme. Das Problem scheint der Konflikt zwischen CPU- und GPU-Grafik zu sein. Intel Grafik-Installer hat es gelöst.

Leider unterstützt es zur Zeit Ubuntu 14.10 nicht, daher habe ich es gelöst, indem ich die Nvidia X Server-Einstellungen verwendet habe und CPU-Grafik wie gewünscht ausgewählt habe.

    
VRR 13.03.2015 15:50
0

Ich habe endlich eine Lösung gefunden. Ich habe "Integrated NIC" im BIOS deaktiviert. Es verhindert, dass mein Lüfter laut wird. Ich führe gerade Ubuntu 15.04.

:)

    
FRED99 14.07.2015 23:55
-1

Versuchen Sie es

Link

und dann wählen Sie die Lüftergeschwindigkeit und ändern Sie wie Sie wollen;)

    
Unon11 11.05.2013 13:06

Tags und Links