Unicode Zeichen erscheinen nicht in gnome Terminal für vim airline

9

Ich weiß, dass das schon einige Male gefragt wurde, aber keine der Antworten funktionierte für mich.

Ich verwende den GNOME-Terminal als Standard in Ubuntu 14.10 und ich kann nicht Unicode-Zeichen richtig zu zeigen, erhalten, vor allem in vim Fluggesellschaft.

Ich habe die Zeichencodierung für Unicode UTF8 im Terminalmenü festgelegt.

und LANG gibt utf8 zurück:

echo $LANG
en_US.UTF-8

Ich habe eine gepatchte Schriftart von Link

installiert

Ich habe wahrscheinlich auch andere Tipps auf Stackexchange ausprobiert, an die ich mich jetzt nicht mehr erinnern kann und sehe immer noch die komischen Zeichen:

Wenn ich dieselbe Schriftart unter OSX mit iterm installierte, funktionierte es sofort.

Ich habe auch versucht in anderen Terminals auf dem gleichen System wie Guake oder mit Ctrl-Alt-F1 und das Ergebnis ist das gleiche. Ich habe es innerhalb oder außerhalb von tmux versucht.

Jede Hilfe ist willkommen.

    
Bastian 11.01.2015, 21:27

1 Antwort

5

Ich habe eine Unicode-Testdatei hochgeladen, die Sie herunterladen und dann cat in Ihrem Terminal herunterladen sollten.

>

cat ~/Downloads/Unicode-sample.txt und dann Shift + PgUp und Shift <+ kb> PgDn im Terminal, um zu überprüfen, ob alle Zeichen angezeigt werden richtig.

Wenn Sie in Ihrem Terminal die gleichen Ergebnisse erhalten wie beim Öffnen der ursprünglichen Quelldatei In Ihrem Browser ist Ihre Schriftart in Ordnung; Andernfalls ist es eine zweifelhafte Schrift: Verwenden Sie eine andere Schriftart. (Ich benutze "Envy Code R")

Und sobald das Terminal in Ordnung ist, werden alle Anwendungen, die im Terminal ausgeführt werden, auch in Ordnung sein!

    
Fabby 14.01.2015 20:00