Bildschirm-Dimmen nach 60 Sekunden (MacBook mit 12.04)

9

Ich benutze Ubuntu 12.04 auf einem MacBook Air - alles funktioniert gut, abgesehen davon, dass der Bildschirm nach 60 Sekunden Aktivität abdunkelt. Gibt es eine Möglichkeit, dies zu stoppen?

Mein Computer ist am Netzstrom. Wenn ich das Gerät nicht mehr benutze, wird die Hintergrundbeleuchtung der Tastatur nach 30 Sekunden ausgeschaltet (das ist in Ordnung). Nach einer Minute wird der Bildschirm um etwa 50% abgeblendet - das ist nervig , besonders wenn man ein Video anschaut oder eine lange Textseite liest.

Meine Einstellungen für "Helligkeit und Sperre" scheinen gut zu sein:

Ich habe es versucht

gsettings set org.gnome.settings-daemon.plugins.power idle-dim-time 600

Aber das macht keinen Unterschied - es dimmt immer noch nach 60 Sekunden, egal welchen Wert ich eingestellt habe.

Ich habe auch gconf-editor verwendet, aber anscheinend nicht /apps/gnome-power-manager/backlight

Ich verwende nicht Unity - nur den Standard-Gnome-Desktop.

Gibt es eine Möglichkeit, dieses Verhalten zu ändern? Ich nie möchte, dass mein Bildschirm abgedunkelt wird. Ich bin ziemlich glücklich, es manuell mit den Tasten F1 und F2 zu steuern.

BEARBEITEN

Nein - Koffein funktioniert nicht. Der Bildschirm wird immer noch dunkel.

Nein - das Ändern des DPMS funktioniert nicht.

Nein - Bearbeiten von Sachen in dconf funktioniert nicht.

Nein - Ich habe keine andere Power-Manager-Software installiert.

    
Terence Eden 04.04.2014, 14:21

2 Antworten

3

Sie könnten versuchen, Koffein als temporäre Lösung zu verwenden. Sie können Koffein installieren, indem Sie den folgenden Befehl in Ihrem Terminal ausführen ( Strg + Alt + T

)
sudo apt-get install caffeine

Um eine Lösung zu finden, könnten Sie folgende Dinge tun:

Führen Sie den folgenden Befehl in Ihrem Terminal aus:

xset -q

Wenn die Energiespareinstellungen aktiviert sind ( DPMS is enabled ), müssen Sie sie deaktivieren.

Sie können das tun, indem Sie Folgendes ausführen:

xset s off
xset s noblank
xset -dpms

Dadurch sollte der Bildschirm nicht mehr gedimmt werden. xset -dpms übersteht einen Neustart nicht, sodass Sie den Befehl entweder zu /etc/rc.local oder zu ~/.xprofile hinzufügen können.

Wenn dies nicht funktioniert von xset -q zeigt Ihnen, dass die Energiesparmöglichkeiten deaktiviert sind Kommentar und ich werde versuchen, die nächste Methode, die ich kenne

check / org / gnome / settings-daemon / plugins / power mit dem dconf-editor, um zu überprüfen, ob idle-dim-time auf 600 gesetzt ist und ob das Kontrollkästchen aktiviert ist funktioniert nicht deaktivieren Sie das Kontrollkästchen "aktiv".
Wenn das Ihr Problem nicht behebt, haben Sie wahrscheinlich ein alternatives Energiesparprogramm installiert und wenn Sie herausfinden können, was das andere Programm ist, kann ich Ihnen vielleicht helfen.

Wenn Sie keine andere Energiespar-Software installiert haben, können Sie überprüfen, ob eine Live-DVD das gleiche Problem hat? Wenn dies nicht der Fall ist, wird auf jeden Fall eine Energiesparfunktion ausgeführt, die nicht aus der Verpackung kommt. Wenn es das gleiche Problem gibt, gibt es nur eine Sache, die mir möglicherweise funktioniert.

    
Arno van der Weijden 06.05.2014 11:45
2

Installieren von xbacklight und dann Ausführen von xbacklight -set 7 und xbacklight -time 500 sollte funktionieren (OP hat dies bestätigt)

sudo apt-get install xbacklight
    
dschinn1001 12.05.2014 22:25

Tags und Links