Die Maus kann nach dem Drücken der Umschalttaste nicht in gEdit zurückgegeben werden

9

Wenn Sie gEdit eingeben, verschwindet die Maus standardmäßig und Sie können sie durch Bewegen der Maus wiederherstellen. So können Sie mit Ihrer Maus machen, was Sie wollen.

Aber wenn ich Shift oder Strg oder Enter drücke und die Maus verschiebe, um es wieder auf den Bildschirm zu bekommen, wird es nicht funktionieren . Die Maus wird angezeigt, wenn sie bewegt wird und plötzlich verschwindet. Also kann ich keine Aktionen ausführen. Das ist ein sehr seltsamer Fehler. Um die Maus zurück zu bekommen, muss ich mit der rechten Maustaste auf den Editor klicken.

Ist das ein bekannter Fehler? Wie kann ich es reparieren? Hat nur gEdit (Version 3.10.4 ) diesen Fehler? Sollte ich es auf niedrigere Version herunterstufen?

Ich habe das auf leafpad Text Editor getestet und dieses Problem existiert dort nicht.

2. Fehler

Wenn Sie eine Weile tippen (z. B. 30 Minuten oder länger), lässt gEdit das Tippen nicht mehr zu, aber Sie können die Datei speichern und andere Dinge tun. Es wird keinen Cursor geben, um es wieder normal zu machen, Sie müssen das Fenster gEdit schließen und ein neues starten.

Soweit ich getestet habe, ist dieses "neue gEdit" viel zu fehlerhaft.

Gibt es andere einfache (oder nicht) Texteditoren wie gEdit mit Code-Markup und anderen Sachen?

AKTUALISIEREN

Wenn gEdit in root ( gksudo gedit ) ausgeführt wird, scheint dieser Fehler nicht zu existieren. Also, warum tritt dieser Fehler im normalen Benutzer und nicht im root auf?

    
Subin 28.04.2014, 06:28

2 Antworten

4

Dieser Fehler wurde nicht behoben und ich entschied mich für einen anderen Texteditor. Ich fand Geany und es ist großartig. Es hat nicht den Fehler auf gEdit .

Also, ich denke, die Lösung besteht darin, zu einem neuen Texteditor zu wechseln, bis (oder nicht) dieser Fehler behoben ist.

Eigenschaften von Geany

  • Leichtgewicht
  • Grundlegende Funktionen einer IDE haben
  • Schneller als gEdit
  • einige Abhängigkeiten
  • Unterstützt viele Dateitypen
  • Habe Plugins & amp; Code Markup (Syntax Hervorhebung)
  • Ähnlich wie gEdit (Ansicht von Sidebar & amp; Nachrichtenfenster deaktivieren)

UPDATE - Fehler behoben

Wie von August Karlstrom berichtet wurde , Der Mausfehler gEdit wurde behoben, als ich IBus als Standard-Tastatureingabesystem deaktivierte. Hier ist, wie Sie es deaktivieren können:

Öffnen Sie ein Terminal und führen Sie den folgenden Befehl aus:

  

gnome-language-selector

Ein Fenster namens Sprachunterstützung wird geöffnet. Ändern Sie im Fenster die Option Tastatureingabemethodensystem in none anstelle von IBus , und schließen Sie das Fenster.

Die Änderungen werden erst wirksam, nachdem Sie Ihren Computer neu gestartet (neu gestartet) haben.

    
Subin 04.05.2014, 08:56
1

Installieren Sie einfach ibus-gtk:

sudo apt-get install ibus-gtk

Und öffne deine Sitzung erneut.

Quelle: Link

    
Ludo6431 04.02.2015 21:41

Tags und Links