Ubuntu 14.04: Fehler mit "apt-get update": W: Ignoring Liefert eine Zeile mit DepCompareOp

9

Ich bekomme diesen Fehler jedes Mal, wenn ich apt-get update

mache
Ign http://ni.archive.ubuntu.com trusty/multiverse Translation-en_US           
Ign http://ni.archive.ubuntu.com trusty/restricted Translation-en_US           
Ign http://ni.archive.ubuntu.com trusty/universe Translation-en_US             
Reading package lists... Done                                                  
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
...
...
...
...
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: Ignoring Provides line with DepCompareOp for package libreoffice-l10n
W: You may want to run apt-get update to correct these problems

Dieser Fehler trat nach dem Upgrade von LibreOffice 5.2 auf 5.3 mit LibreOffice PPA auf: ppa:libreoffice/ppa .

Die Sache ist, dass alles gut funktioniert. Ich kann das System aktualisieren / aktualisieren, ich kann Pakete installieren, Pakete löschen usw. Das Problem ist nur mit dem Fehler.

Ich habe versucht: apt-get autoclean , apt-get clean , apt-get autoremove , apt-get install -f und viele andere Dinge und nichts entfernt diesen hässlichen Fehler.

    
Carlos Estrada 06.02.2017, 15:02

3 Antworten

3

Laut Fehlerbericht # 1662227 liegt das daran, dass das PPA für LibreOffice keine Übersetzungsdateien für Sprachen bereitstellt abgesehen von Englisch.

Sie können entweder

  1. ignorieren diese Warnmeldung als ein kosmetisches Problem oder
  2. Entfernen / deaktivieren Sie die LibreOffice-PPA und verwenden Sie stattdessen die Pakete aus den Repositorys von Canonical.
David Foerster 24.02.2017 08:58
1

Anstatt PPA herunterzuladen, können Sie versuchen, es mit Snap zu installieren.

sudo snap install libreoffice

zum Aktivieren von Snap-Paketen in 14.04 ausführen

sudo apt-get install snapd

Quellen: Libreoffice 5.3 Snap-Paket , ubuntu 14.04 einrasten

Stellen Sie sicher, dass die vorhandene Installation zuerst gelöscht wird.

    
Sirajus Salekin 06.02.2017 16:18
0

Die Paketbeschreibung in debian / control im PPA ist falsch und besagt, dass die l10n - * - Pakete für 5.3 l10n-5.2 enthalten würden.

Das Paket muss neu erstellt werden; Siehe Dieses Forum zu Ubuntu-Benutzern für eine Anleitung.

    
fatabbott 22.04.2017 09:39

Tags und Links