Unity wird nicht geladen, es wird kein Starter angezeigt, kein Dash wird angezeigt

538

Wenn ich mich anmelde, passiert nichts.

Mein Desktop-Hintergrund wird angezeigt.

Kein Strich, kein Launcher, nichts.

    
jrg 14.12.2010, 18:24

34 Antworten

470
  

Diese Antwort gilt für Ubuntu-Versionen, auf denen Compiz ausgeführt wird.

     

Diese Antwort setzt voraus, dass Unity durch Compiz läuft. Wenn Sie compiz nicht installiert haben Diese Antwort trifft nicht auf Sie zu.

Sie müssen nur das Unity-Plugin wieder einschalten. Das Problem ist, dies ist ein Schmerz im unteren Bereich, weil Sie jetzt keine grafische Methode haben, um dies zu tun. Also:

  1. Versuchen Sie, ein Terminal mit Strg + Alt + T zu öffnen.
    Dies funktioniert möglicherweise nicht, aber Sie können mit der rechten Maustaste auf den Desktop klicken und "Terminal hier öffnen" auswählen. Andernfalls müssen Sie möglicherweise durch Drücken auf ein "hartes" Terminal wechseln Strg + Alt + F1 und melden Sie sich an.

  2. Installieren Sie compizconfig-settings-manager durch Ausführen von

    sudo apt-get install compizconfig-settings-manager
    
  3. Dann führe es mit folgendem Befehl aus:

    DISPLAY=:0 ccsm &
    

    Der erste Teil teilt dem Terminal mit, auf welche Anzeige es geladen werden soll (sonst hat es keinen Hinweis).

  4. Wenn Sie in Schritt 1 zu einem TTY gewechselt haben, wechseln Sie zurück zum Grafikserver, indem Sie Ctrl + Alt + F7 drücken (oder manchmal Strg + Alt + F8 .).
    Dort sollte ein CompizConfig-Einstellungsmanager auf Sie warten.

  5. Finden Sie das Unity-Plugin. Aktivieren Sie es. Sie werden gefragt "Ubuntu Unity Plugin erfordert das Plugin OpenGL. Aktivieren Sie das Ubuntu Unity Plugin / OpenGL aktivieren"

  6. Alles sollte zum Leben erweckt werden. Wenn dies nicht der Fall ist, müssen Sie möglicherweise neu starten. Sie können dies tun, indem Sie zum Terminal zurückkehren und sudo reboot ausführen.

Oli 08.11.2011, 00:23
167

Eine für mich gute Lösung (hat das gleiche Problem gelöst):

in einem Terminal:

export DISPLAY=:0   
sudo dconf reset -f /org/compiz/

und dann

setsid unity
    
user155373 04.05.2013 02:50
72

In 13.04 und 14.04:

unity --replace ist veraltet. Verwenden Sie stattdessen Folgendes:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Starten Sie neu, wenn es nicht sofort funktioniert.

    
Brandon Bertelsen 27.04.2013 04:39
60

Für 12.10 und darunter:

Drücken Sie Ctrl + Alt + T für ein Terminal, und führen Sie ccsm aus. Aktivieren Sie anschließend das 'Unity'-Plugin.

Möglicherweise müssen Sie dann auch unity --replace ausführen.

    
xyzzyman 02.10.2011 04:33
51

Es empfiehlt sich zu prüfen, ob der Grafiktreiber für die Verwendung der Hardwarebeschleunigung und für OpenGL konfiguriert ist. Versuchen Sie, in den Ubuntu- und Ubuntu-Foren nach Informationen zu suchen, die für Ihre GPUs und Ihren Ubuntu-Geschmack relevant sind. Für Hybridgrafikbenutzer siehe den letzten Abschnitt "Hybridgrafik".

Möglicherweise möchten Sie den compizconfig-settings-manager und stellen Sie sicher, dass das Unity-Plugin aktiviert ist (siehe Was sind einige Probleme mit CCSM und warum sollte ich es vermeiden wollen? ).

Für 12.04 und neuer

  1. Wechseln Sie in tty1 durch Drücken von Strg + Alt + F1 und melden Sie sich an.

  2. Installieren Sie compizconfig-settings-manager durch Ausführen von

    sudo apt-get install compizconfig-settings-manager
    
  3. Führen Sie es dann folgendermaßen aus:

    export DISPLAY=:0
    ccsm
    

    Der erste Teil teilt dem Terminal mit, auf welche Anzeige es geladen werden soll (sonst hat es keinen Hinweis).

  4. Drücken Sie Strg + Alt + F7 (oder Ctrl + Alt + F8 manchmal), um zur grafischen Anzeige zurückzukehren, auf der sich ein CompizConfig Settings Manager-Bildschirm befindet.

  5. Finden Sie das Unity-Plugin. Aktivieren Sie es.

  6. Alles sollte zum Leben erweckt werden. Wenn dies nicht der Fall ist, müssen Sie möglicherweise neu starten. Sie können dies tun, indem Sie zu tty1 zurückkehren und sudo reboot ausführen.

Wenn die Einheit immer noch nicht geladen wird, versuchen Sie Folgendes:

dconf reset -f /org/compiz/
unity --reset-icons &disown

Starten Sie neu, wenn es nicht sofort funktioniert.

Für 11.10 und älter

Wenn Sie auf ein TTY hoffen ( Strg + Alt + F1 bis F6 ), und führen Sie Folgendes aus:

DISPLAY=:0 unity --replace

Es wird Unity auf TTY 7 zurückgesetzt ( Strg + Alt + + F7 ).

Sie können auch Folgendes versuchen:

DISPLAY=:0 unity

Das funktioniert jedoch nicht, wenn auf der Anzeige 0 bereits ein Windows-Manager ausgeführt wird (es wird ein Fehler ausgegeben. Verwenden Sie in diesem Fall einfach unity --replace ).

Wenn Unity absolut nicht den Neustart verweigert, versuchen Sie Folgendes:

Installieren Sie gnome-panel :

sudo apt-get install gnome-panel

Dann auf Display 0:

ausführen
DISPLAY=:0 gnome-panel

Sie sollten dann Gnome-2-Bedienfelder auf Ihrem Desktop haben, die Sie zum Abmelden verwenden können.

Hybridgrafik

Einige sehr nützliche Informationen und weiterführende Informationen für Benutzer von Hybridgrafiken finden Sie hier .

Sobald die GPUs für die 3D-Beschleunigung und OpenGL entsprechend konfiguriert sind, können Sie:

  1. Installieren Sie Nvidia-Treiber von link :

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    oder:

    Ich würde wirklich die stabile PPA vorziehen, , aber es ist scheint noch keine Pakete für 13.04 zu haben . Update: Diese scheinen ab 25. September verfügbar zu sein. Ich würde dieses stabile PPA installieren - Sie können es versuchen, aber ich habe es nicht getestet.

    Die von Ubuntu bereitgestellten Nvidia-Treiber waren bereits installiert und ich habe sie einfach von diesem PPA aus installiert, indem ich sie hinzufügte und ein Paket-Update mit update-manager durchführte.

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    
  2. Installieren Sie Bumblebee über den Link

    UPDATE: Ab dem 6. Oktober scheint ppa:xorg-edgers/ppa auch Hummel zu enthalten. Wenn Sie also von diesem PPA aus installieren, sollten Sie das Hinzufügen des Bumblebee PPA überspringen und stattdessen von hier aus installieren.

    Wenn Sie in Schritt 1 den stabilen PPA ausgewählt haben, installieren Sie den stabilen PPA von Bumblebee wie folgt:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. UPDATE: Aktualisieren Sie nach dem Hinzufügen der PPA (s) Ihre Paketlisten:

    sudo apt-get update
    

    Wenn Sie bereits nvidia-Treiber aus Ubuntus Standard-Repositorys installiert haben, aktualisieren Sie einfach, um die neue Version aus dem in Schritt 1 ausgewählten Repository zu erhalten:

    sudo apt-get upgrade
    sudo apt-get install bumblebee
    
  4. Führen Sie die folgenden Befehle aus, um Unity 'zu reparieren' (von brandon-bertelsen s Antwort auf Unity wird nicht geladen, kein Launcher, kein Dash wird angezeigt ):

    dconf reset -f /org/compiz/
    unity --reset-icons & disown
    
Mark Shuttleworth 27.12.2010 13:45
32

Der einfachste Weg, dies zu tun, ist, die Tastenkombination Ctrl + Alt + T zu drücken, um ein Terminal zu erhalten und dann auszugeben:

rm -rf ~/.compiz-1 ~/.config/compiz-1

und Ihre Einheitssitzung wird vor Ihren Augen wiederkommen.

Diese Technik ist besser als das erneute Starten von ccsm, da Sie in den Fehlerzustand von OP gelangen können, ohne die Einheit in ccsm versehentlich zu deaktivieren. Sie können es einfach erhalten, indem Sie versehentlich die Schaltfläche "Einstellungen" in ccsm drücken.

    
achiang 10.11.2011 06:55
25

Ich hatte auch dieses Problem. Ich löste es, indem ich den Inhalt der Datei ~ / .config / compiz-1 / compizconfig löschte und relog.

rm -rf ~/.config/compiz-1/compizconfig/*
    
dome cs 30.10.2011 07:23
21

Ich hatte genau das gleiche Problem.

Wenn Sie den Compiz Config Settings Manager installiert haben, ist das Unity Desktop Plugin möglicherweise deaktiviert.

Melden Sie sich bei einem Unity 2D-Desktop an und überprüfen Sie, ob er in CCSM wie folgt aktiviert ist

Unity Shell wird nicht auf dem Standarddesktop geladen, wenn das Kontrollkästchen nicht markiert ist und Sie die Sitzung in Ihrem Bild anzeigen.

    
Mark Rooney 22.10.2011 09:09
19

Entwickler beheben immer Fehler. Daher besteht die Alternative darin, zu warten und den Fortschritt bei der Fehlerbehebung zu verfolgen ( abonnieren zur Unity-Entwicklung in Launchpad ).

  1. Drücken Sie Strg + Alt + F2 .

  2. Anmelden.

  3. Führen Sie sudo shutdown -r now in einem Terminal aus.

  4. Wählen Sie auf dem Anmeldebildschirm nach dem Neustart Ihres Systems Unity 2D (vorerst). Klicken Sie mit der rechten Maustaste auf das Kettenrad-Symbol.

  5. Warten Sie auf einen Fix für Unity 3D / Ubuntu 11.10 (z. B. eine Woche).

  6. Aktualisieren Sie Ihr System, um den Fix zu erhalten. in einem Terminaltyp sudo apt-get update && sudo apt-get upgrade .

UPDATE: Ich konnte dies mithilfe von ccsm vom Unity 2D-Login aus beheben.

(Dies ist angepasst an diesem Beitrag in den Ubuntu-Foren .)

  1. Wählen Sie im Anmeldebildschirm Unity 2D und melden Sie sich an.

  2. Installieren Sie ccsm (CompizConfig Settings Manager) durch Ausführen in einem Terminal: sudo apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra .

  3. Starten Sie ccsm und wählen Sie die Kategorie Desktop aus. Aktivieren Sie das Ubuntu Unity Plugin . Wenn Sie aufgefordert werden, Konflikte zu lösen, wählen Sie für alle Konflikte die Schaltfläche MITTEL. Schließen Sie ccsm , wenn Sie fertig sind.

  4. Starten Sie neu, wählen Sie Unity (3D) und melden Sie sich an.

david6 15.10.2011 23:47
13

Ich habe ein Asus U36SD mit einer "Optimus" -Einstellung (Intel + Nvidia GPUs). Ubuntu 12.04 funktionierte einwandfrei, aber bei einem Upgrade auf 12.10 trat dieses Problem in 13.04 auf und bestand fort. Ich habe es durch die folgenden Schritte geschafft:

  1. Installieren Sie Nvidia-Treiber über den Link .

    ODER:

    Ich würde die stabile PPA unter link , wirklich vorziehen aber es scheint noch keine Pakete für den 13.04 zu haben . Update: Diese scheinen ab 25. September verfügbar zu sein. Ich würde dieses stabile PPA installieren - Sie können es versuchen, aber ich habe es nicht getestet.

    Die von Ubuntu bereitgestellten Nvidia-Treiber waren bereits installiert und ich habe sie einfach von diesem PPA aus installiert, indem ich sie hinzufügte und ein Paket-Update mit update-manager durchführte. UPDATE:

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    (was ich getan habe) oder:

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    

    (stabile Version auch für 13.04 jetzt - nicht von mir getestet).

  2. Installieren Sie Bumblebee über den Link

    UPDATE: Seit dem 6. Oktober scheint ppa: xorg-edgers / ppa auch Hummel zu enthalten. Wenn Sie also von diesem PPA aus installieren, sollten Sie das Hinzufügen des Bumblebee PPA überspringen und stattdessen von hier aus installieren.

    Wenn Sie in Schritt 1 den stabilen PPA ausgewählt haben, installieren Sie den stabilen PPA von Bumblebee wie folgt:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. UPDATE: Aktualisieren Sie nach dem Hinzufügen der PPA (s) Ihre Paketlisten:

    sudo apt-get update
    

    Wenn Sie bereits nvidia-Treiber aus Ubuntus Standard-Repositorys installiert haben, aktualisieren Sie einfach, um die neue Version aus dem in Schritt 1 ausgewählten Repository zu erhalten:

    sudo apt-get upgrade
    

    Installieren Sie Bumblebee

    sudo apt-get install bumblebee
    
  4. Führen Sie die folgenden Befehle aus, um Unity zu "reparieren" (von brandon-bertelsen s Antwort auf Unity wird nicht geladen, kein Launcher, kein Dash wird angezeigt ):

    dconf reset -f /org/compiz/ 
    unity --reset-icons &disown
    
Thomas Arildsen 02.05.2013 12:45
12

Das ursprüngliche Poster der doppelten Frage, das durch Bearbeiten seiner eigenen Frage gelöst wurde:

  

Lösung gefunden: .Xauthority in meinem Zuhause löschen (oder umbenennen)

    
mateo_salta 08.08.2012 22:41
10

Für 13.10:

Nur um sicherzustellen, dass alles installiert ist:

sudo apt-get install --reinstall unity ubuntu-desktop

Laden Sie anschließend alles neu:

dconf reset -f /org/compiz/ && unity --reset-icons &disown

Ich habe es gerade ausprobiert und es funktioniert!

Quelle:

link

Wenn alles andere fehlschlägt:

Denken Sie daran, immer Backups zu erstellen! Manchmal ist eine Neuinstallation jedoch gut, installieren Sie Ubuntu neu

    
Jared Burrows 06.12.2013 01:07
10

Dies ist mir auch in Ubuntu 16.04 nach einem Upgrade von Unity- und Compiz-Paketen passiert. Keines der oben genannten hat funktioniert.

Die einzige Möglichkeit, Launchers und Beans zurückzubekommen, bestand darin, das Verzeichnis .cache in meinem Haus zu entfernen (während es NICHT bei Unity angemeldet war).

    
lorenzo-bettini 20.09.2016 09:27
9

Es scheint ein Problem mit 12.04 Unity 3D und den aktuellen Nvidia-Treibern zu geben.

Siehe diesen Beitrag (Unity 3d funktioniert nach der Installation nicht mehr.) 12.04) für Details, wie Sie das Problem umgehen können.

Ich habe einen 32 Bit Pentium 4 3.06 GHz Compaq D520SFF, einen Nvidia GeForce 6200, der den Kernel 3.2.0-24-Generic-Pae ausführt, und hatte genau das gleiche Problem (2D funktioniert, 3D nicht) und Beim Downgrading der Nvidia-Treiber hat 3D in wenigen Minuten für mich funktioniert.

    
Heimdall 01.05.2012 01:38
8

Für die Symbole ist Nautilus verantwortlich. Schreiben Sie nautilus & in ein Terminal, nicht schließen , und die Symbole werden wieder angezeigt.

BEARBEITEN 10/10/2013 : Für Nautilus können Sie auch Alt + F2 eingeben, um die Unity-Eingabeaufforderung zu öffnen und% co_de zu schreiben % in der globalen Such- / Eingabeaufforderung-CLI. Ein Datei-Explorer wird geöffnet. Sie können es schließen, wenn Sie möchten.

    
air-dex 26.12.2012 16:14
8

Ich hatte ein ähnliches Problem:

Unity mit 14.04 in Kombination mit IBM Notes9 führte zu merkwürdigem Verhalten (Mausklicks würden nicht mehr funktionieren). Mein Workaround war, ein Terminal zu öffnen und Unity durch Eingabe von unity & neu zu starten.

Das letzte Mal, als ich das getan habe, hat es die Einheit total verderbt - der No Dash, kein Launcher, nichts, nichts. Ich glaube, ich habe JEDEN Vorschlag ausprobiert, der auf dieser Seite aufgeführt ist - nichts davon hat geholfen.

Aber ein Kollege hatte endlich die Antwort, die für mich funktionierte:
Ich habe das Unity-Tweak-Tool installiert. Dann habe ich unity-tweak-tool --reset-unity ausgeführt und neu gestartet.

Danach war die Einheit wieder lebendig. Offensichtlich waren alle vorherigen Konfigurationsänderungen an unity verschwunden, aber darum geht es bei --reset-unity .

Und der große Vorteil dieser Lösung: Sie müssen nur ein einzelnes Paket hinzufügen und Ihre Änderungen an der Unity-Konfiguration wiederholen. Sie müssen compiz jedoch nicht zurücksetzen, ccsm installieren oder alle anderen langwierigen Aktivitäten ausführen.

Update:

Die andere -Lösung, die ich heutzutage sehr hilfreich finde, kommt aus hier - dem Punkt : Manchmal müssen Sie Ihre ~ / .config / dconf / user-Datei (oder besser: ziehen Sie eine "funktionierende" Sicherung ein).

    
GhostCat 04.06.2014 12:21
6

Wenn Sie hoffen, in eine tty ( Strg + Alt + F1 bis F6 ), und führen Sie Folgendes aus:

DISPLAY=:0 unity --replace

Es wird Unity um 7 zurückgesetzt ( Strg + Alt + + F7 ).

Sie können auch Folgendes versuchen:

DISPLAY=:0 unity

Das funktioniert jedoch nicht, wenn auf der Anzeige 0 bereits ein Windows-Manager ausgeführt wird (es wird ein Fehler ausgegeben. Verwenden Sie in diesem Fall einfach unity --replace ).

Wenn Unity absolut nicht den Neustart verweigert, versuchen Sie Folgendes:

Installieren Sie gnome-panel :

sudo apt-get install gnome-panel

Dann auf Display 0:

ausführen
DISPLAY=:0 gnome-panel

Sie sollten dann Gnome-2-Bedienfelder auf Ihrem Desktop haben, die Sie zum Abmelden verwenden können.

Ich finde, dass Unity am 13.04 mit meiner Nvidia-Karte wirklich fehlerhaft ist. YMMV.

    
Seth 19.05.2013 20:07
5

Ich hatte ungefähr 3 Mal, wo ich die Ctrl + Alt + F1 brauchte, um die Arbeit nicht zu verlieren und es durcheinander kam ... Ich habe auch Nvidia. Ich möchte das vorschlagen:

Strg + Alt + F1 (ok, leerer Bildschirm) Geben Sie Ihr Login ein, drücken Sie die Eingabetaste und dann das Passwort (alles auf einem leeren Bildschirm). Geben Sie dies jetzt ein:

sudo startx -- :1

muss das Kennwort erneut eingeben und eingeben Dadurch wird eine X-Sitzung unter Ctrl + Alt + F8 geöffnet (springt automatisch dazu) Erstellen Sie nun eine neue leere Textdatei mit dem Namen runBash.sh und geben Sie Folgendes ein:

bash

Speichern Sie es, ändern Sie die Berechtigungen in ausführbare Dateien und führen Sie es aus. Sie erhalten ein wirklich entlastendes Terminal, das Sie daran erinnert, warum Linux gut ist! : D

Wenn Sie fertig sind, denken Sie daran, Ctrl + Alt + F1 , drücken Sie Ctrl + C. (beendet die neue X-Sitzung), geben Sie exit und Enter ein, um die Terminalsitzung (leerer Bildschirm) zu beenden. Wenn Sie der Meinung sind, dass Sie den Exit nicht richtig eingegeben haben, drücken Sie einfach Strg + C und geben Sie ihn erneut ein. Machen Sie es nicht zu schnell.

Damit Sie es verbessern können, erstellen Sie ein Skript, damit Sie so wenig wie möglich eingeben können. Trotzdem müssen Sie immer noch viel eingeben, wenn der Bildschirm leer ist, aber es ist besser als nichts:)

Suchen Sie immer noch nach der endgültigen Strg + Alt + F1 der richtigen Lösung Ubuntu 12.04 + nvidia.

    
Aquarius Power 28.05.2012 01:39
4

Wenn Sie eine Beschleunigungsgrafikkarte neben der Standardgrafikkarte verwenden, ist dies möglicherweise auf die Installation der Treiber zurückzuführen. Einige Aktualisierungen der Treiber für Beschleunigungsgrafikkarten in Systemen mit zwei Grafikkarten neigen dazu, in einigen Systemen instabiles Verhalten zu zeigen. Ich habe eine Nvidia-Karte und eine Intel-Karte. Das passierte bei mir, als ich Nvidia-Treiber installierte. Launcher und Panel würden vom Desktop verschwinden. Wenn Sie eine Nvidia-Karte verwenden, kann die Installation von Bumblebee eine temporäre Lösung sein: link

    
user153634 01.05.2013 12:46
4

Die erste Antwort funktioniert gut, mit der Ausnahme, dass ich Unity selbst installieren musste:

sudo apt-get install unity

dann ausführen:

ccsm

und aktivieren Sie Unity:)

    
sobi3ch 26.11.2013 02:22
4

Ich hatte so ziemlich das gleiche Problem unter 12.04. Die Unity war mit meiner alten GPU langsam, daher habe ich Unity 2d für Monate als Desktop verwendet. Aus offensichtlichen Gründen lehnte es plötzlich die Anzeige von Launchpad und Titelleiste (für alle Benutzer) ab. Die Wiedervereinigung von Unity in CCSM, wie hier vorgeschlagen, war Teil der Lösung, aber keine der anderen Maßnahmen, die hier, dort oder in mehreren anderen verwandten Themen vorgeschlagen wurden, einschließlich, aber nicht beschränkt auf:

  • Neuinstallation von Unity

  • Neuinstallation von Ubuntu Desktop

  • Entfernen aller relevanten Konfigurationsinformationen (z. B. Compiz, gconf usw.)

hat mir geholfen, diese Symptome unter 12.04 (64 Bit) vollständig zu beheben.

unity --reset

würde für mich nicht funktionieren. Nachdem eine Vielzahl von Fehler- und Informationsmeldungen zugestellt wurde, hing es immer an:

Setting Update "run_key"

wie im Protokoll gezeigt, das in der Thread mit dem Titel "Unity is verschwunden" für die Ausführung ohne Argumente angezeigt wird .

Ich habe festgestellt, dass die Fehlermeldung von:

gesendet wurde
/usr/lib/nux/unity_support_test -p

ähnelte einigen der von unity --reset :

gemeldeten Fehler

Fehler beim Laden von gemeinsam genutzten Bibliotheken: libGL.so.1: Freigegebene Objektdatei kann nicht geöffnet werden: Keine Datei oder Verzeichnis.

Nach langer Suche habe ich folgende Lösung gefunden:

  • Ermitteln Sie den Pfad von libGL.so.1 mit dem Befehl locate libGL.so.1 .

  • Fügen Sie der Bibliothek in / usr / lib / einen Link hinzu, wie im folgenden Beispiel gezeigt:

    sudo ln -s /usr/lib/i386/mesa/libGL.so.1 /usr/lib
    

    (Mit freundlicher Genehmigung von JD Bartlett )

  • Starten Sie den Computer neu.

Dadurch konnten nicht nur unity_support_test-p und unity --reset ausgeführt werden, sondern auch Unity 2D konnte gestartet werden. Ich habe keine Ahnung, was meine Probleme verursacht hat, aber seit dem Erstellen der oben genannten Links (einige Wochen jetzt) hatte ich keine weiteren Probleme.

    
R B 20.12.2013 11:42
4

Als ich versehentlich ein Upgrade von 12.04 LTS Ubuntu auf 13.04 durchgeführt habe, musste auch ich mit den gleichen Problemen konfrontiert werden, z. B. fehlende Seitenmenüleiste, keine Fensteroptionen, keine Möglichkeit, zwischen Anwendungen zu wechseln ( alt - tab ) und ich konnte nicht einmal Fenster auf den Bildschirm ziehen. Nachdem ich so viele Optionen verfolgt hatte, erhielt ich die folgenden Befehle, um diese Probleme zu beheben.

sudo apt-get remove aspell #may not be relevant
sudo apt-get remove dictionaries-common

Neustart (Sie können sudo reboot verwenden)

sudo apt-get install compizconfig-settings-manager
sudo apt-get install dictionaries-common
sudo apt-get install lightdm

Neustart (Sie können sudo reboot verwenden)

dconf reset -f /org/compiz/
unity --reset-icons & disown

Ich habe Aspell wegen widersprüchlicher Abhängigkeiten tatsächlich entfernt. Möglicherweise besteht keine Korrelation zwischen diesem Problem. Ich denke, dass das Installieren von lightdm und das Zurücksetzen von compiz mir bei der Behebung dieses Problems geholfen haben     

Bunti 16.05.2014 18:20
4

Dies geschieht, wenn Sie sich mit einem anderen tty anmelden und versuchen, als gleicher Benutzer X (mit startx oder initx) zu starten.

Ubuntu läuft beispielsweise in tty7. Mit Strg + Alt + F1 wird tty1 geöffnet. Melden Sie sich als derselbe Benutzer an und führen Sie startx aus. Gehen Sie zurück zu tty7, melden Sie sich ab und melden Sie sich an. Sie erhalten nur das Desktop-Hintergrundpapier.

Um das Problem zu lösen, wählen Sie tty1, login, entfernen Sie die .Xauthority-Datei in Ihrem Home-Verzeichnis, logout sich aus, login. Gelöst

    
user85164 27.04.2013 08:59
2

Ich hatte das gleiche Problem, nachdem ich sudo apt-get install kubuntu-desktop gemacht hatte, was meine lightdm-Installation aus irgendeinem Grund brach. Ich laufe hier 16.04.

Drücken Sie ctrl - alt - F1 , um zum Terminal zu gelangen, und dann:

sudo service lightdm stop
sudo apt-get remove lightdm
sudo apt-get update && sudo apt-get install lightdm
sudo reboot

Das hat es für mich behoben, nachdem ich stundenlang meine Haare ausgezogen hatte.

    
localhost 07.10.2016 17:29
2

Für Ubuntu 16.04 gearbeitet:

Ich habe compizconfig durch Entfernen des Cache zurückgesetzt (tatsächlich macht der Befehl ein Backup, damit er wiederhergestellt werden kann).

Führen Sie die folgenden Befehle aus und loggen Sie sich danach aus:

mv ~/.cache/compizconfig-1 ~/.cache/compizconfig-backup

setsid unity

Achtung: Dadurch werden Ihre benutzerdefinierten Unity-Einstellungen entfernt.

    
Oleksandr Shpota 09.03.2018 00:49
1

Ich habe das gleiche Problem und habe das Problem gelöst, indem ich pycharm's terminal verwendet habe.

 - Go to my-computer -> user -> share ->  
 - open pycharm and its terminal
 - sudo apt-get update
 - sudo apt-get upgrade 
 - sudo apt-get install --reinstall ubuntu-desktop
    
Muhammad Taqi 02.06.2015 14:26
1

Anscheinend war das Beheben des zweiten Monitors der Fix, und dann konnte ich die richtigen Treiber installieren und aktualisieren.

    
user2580915 27.07.2015 20:08
1

Ich habe viele der in diesem Thread genannten Lösungen sowie andere Lösungen ausprobiert. Endlich hat das für mich funktioniert:

dconf reset -f /org/compiz/

dann

setsid unity

Danke an alle für Ihren Beitrag.

    
Ashu 17.01.2016 02:00
1

Heute bin ich auf eine Situation gestoßen, in der der Benutzer meines Skripts beschlossen hat, es zu starten, indem der Aufruf des Skripts in seine Datei $HOME/.profile gestellt wird. Daher konnte Unity nicht gestartet werden.

Die Skripts sind von Natur aus sequenziell, daher wartete .profile im Grunde auf das Ende des Skripts und Unity konnte nicht gestartet werden, wenn .profile nicht ausgeführt wurde.

Ich habe dasselbe getan, das Skript von .profile aufgerufen und das gleiche Ergebnis erhalten - mein Hintergrundbild für den Anmeldebildschirm blieb dort, es wurde kein Bindestrich oder Startprogramm angezeigt, es konnte weder mit der rechten Maustaste auf den Desktop geklickt werden, noch andere Aktionen ausgeführt werden Melden Sie sich bei TTY1 an.

Die Lösung bestand darin, die entsprechende Zeile von .profile zu entfernen. Es ist möglich, einen Befehl von .profile mit dem kaufmännischen Und-Formular <command> & zu trennen. Das Problem ist jedoch, dass jedes Mal, wenn ein Benutzer das Terminal öffnet oder sich bei TTY anmeldet, eine neue Instanz dieses Befehls erzeugt wird. Daher würde ich dringend raten, keine Programme von .profile zu starten, es sei denn, Sie wissen, was Sie tun.

Link zum Originalskript und zur Diskussion hier: link

    
Sergiy Kolodyazhnyy 28.02.2016 04:10
1

Ich hatte dieses Problem, ich habe eine Menge Dinge ausprobiert und sogar die Einheit aktiviert, aber nichts hat funktioniert. Zuerst müssen Sie TTY (Strg + Alt + F1) öffnen und sich anmelden. Verwenden Sie jetzt

    env DISLAY:=0 gnome-terminal        

Schließen Sie TTY mit Strg + Alt + F7 und verwenden Sie dann (im Terminal)

dconf reset -f /org/compiz/

Verwenden Sie danach

sudo reboot
    
TheEpicstarlord 07.01.2017 14:09

Tags und Links