apt-get Ansprüche 16.04 LTS existiert nicht [duplizieren]

0

Ich benutze derzeit Ubuntu 15.04 und möchte auf 16.04 LTS aufrüsten. Ich versuche:

sudo do-release-upgrade

Aber ich verstehe:

Checking for a new Ubuntu release
No new release found

Wie komme ich voran? Gibt meine Installation einfach die falsche Versionsnummer an - wie kann ich das herausfinden?

Ich meine, es sieht so aus, als wäre ich immer noch am 15.04.

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:    15.04
Codename:   vivid

Welche nächsten Schritte kann ich nehmen?

AKTUALISIEREN

Ich folgte den Anweisungen in How to Software installieren oder von einer alten nicht unterstützten Version upgraden? , die viele 404-Fehler verursacht haben. Dann erkannte ich, dass "vivid" nicht in link war und die Suche diese URLs auf link und, Bingo, Updates funktionieren so, wie sie sollten.

TL; DR: Die Quellenliste war eindeutig falsch. Es wurde behoben.

    
Matthew Brown aka Lord Matt 01.06.2017, 20:01

1 Antwort

5

Es gibt keine Möglichkeit, einfach von 15.04 auf 16.04 zu aktualisieren. Sie müssten zuerst auf 15.10 upgraden und dann auf 16.04 upgraden. In der Theorie könnten Sie dies tun, siehe How to Software installieren oder von einer alten nicht unterstützten Version upgraden? , dies wird jedoch länger dauern und fehleranfälliger sein als eine Neuinstallation.

IMO, du bist am besten dran, deine Daten zu sichern und eine neue Installation durchzuführen. Solange Sie Ihr Laufwerk nicht als Teil der Installation formatieren, sollten Ihre Daten in $ HOME beibehalten werden. Wenn nicht, müssten Sie das Backup wiederherstellen.

Siehe Wie ubuntu neu installieren und Home-Verzeichnis beibehalten und Installieren Sie Ubuntu neu, ohne Daten im Home-Ordner zu verlieren

    
Panther 01.06.2017 20:08