IntelliJ IDEA-Tastenkürzel können unter Ubuntu nicht verwendet werden

115

Ich bin sehr neu bei Ubuntu und habe ein Problem, von dem ich nicht weiß, wie ich es beheben kann. Ich habe sogar versucht, im Internet nach Antworten zu suchen, aber vielleicht kenne ich die richtigen Begriffe nicht, um danach zu suchen.

Ich arbeite mit IntelliJ IDEA , einer Anwendung für die Entwicklung. Und ich bin sehr an die Tastaturkürzel gewöhnt, aber als ich von Windows XP auf Ubuntu 13.10 umgestellt habe, funktionieren einige Abkürzungen nicht mehr. Zum Beispiel:

  • Strg + Alt + & lt; (linker Pfeil)
  • Alt + F8

Gibt es einen Grund, warum? und gibt es eine Lösung dafür? Oder vielleicht nur etwas, um mich auf meiner Suche zu führen.

Vielen Dank im Voraus.

    
Rodrigo Sasaki 28.01.2014, 13:01
quelle

9 Antworten

184

Wie ein bisschen Lesen mir beigebracht hat, ist Intellij IDEA eine tastaturzentrische IDE. Was es bedeutet, ist, dass eine Verwendung damit arbeiten kann, ohne die Maus zu berühren. Außerdem verwalte ich die Tastenbelegung.

Für Ubuntu

Siehe zum Ändern von Tastenkombinationen?

Hier finden Sie eine Liste der Optimierungen, die Sie mit den Standard-Systemtastenbindungen vornehmen müssen, damit sie die IntelliJ IDEA-Aktionen (in Klammern aufgeführt) nicht beeinträchtigen.

  
  • Deaktivieren Sie die Aktion "Schattenfenster", die Strg + Alt + S (Dialogfeld Einstellungen)
  • zugewiesen ist   
  • Ändern oder deaktivieren Sie die Sperrbildschirmaktion, die Strg + Alt + L (Reformatcode)
  • zugewiesen ist   
  • Ändern oder deaktivieren Sie die Aktion "Terminal starten", die Strg + Alt + T (Surround mit)
  • zugewiesen ist   
  • Ändern oder deaktivieren Sie die Aktion Zu Arbeitsbereich wechseln, die Strg + Alt + Pfeiltasten (Navigation)
  • zugewiesen ist   
  • Deaktivieren Sie die Move-Fensteraktion, die Alt + F7 <(find usages)
  • zugewiesen ist   
  • Ändern oder deaktivieren Sie die Aktion Fenstergröße ändern, die Alt + F8 (Ausdruck auswerten)
  • zugewiesen ist   

Hoffe, das hilft!

Hinweis: Sie können Ubuntu-Verknüpfungen immer wieder auf den Standardzustand zurücksetzen. Sehen Sie sich einfach Wie kann ich Standard-Tastaturkürzel wiederherstellen? , falls Sie verloren sind .

Quelle: - Intellij IDEA-Keymap

    
AzkerM 28.01.2014, 13:39
quelle
28

Ich bin auch auf dieses Problem gestoßen, meine Lösung war jedoch anders.

Kein Hack oder Ändern der systemweiten Tastenbelegung erforderlich

IntelliJ hat verschiedene Keymaps, die Sie je nach Betriebssystem ändern können.

Sie können Ihre IntelliJ Keymap aus den Einstellungen ändern.

Gehe einfach zu Settings -> Keymap und wähle deine gewünschte Keymap aus dem Dropdown aus. In meinem Fall habe ich "Default for GNOME" gewählt, da ich Ubuntu Gnome 16.04 verwende.

    
Francisco C. 25.06.2016 07:18
quelle
9

Für ubuntu 18.04 LTS Strg + Alt + Links (Intellij Idee Kontextkonflikt)

  • installiere den Dconf Editor in der ubuntu Software
  • Starten Sie den Dconf Editor, gehen Sie zu / org / gnome / desktop / wm / keybindings / switch-to-workspace-links

  • Doppelklick wie unten

  • verwenden Sie den Standardwert (klicken Sie auf Aus) - & gt; Benutzerdefinierter Wert (wie ich oder sonst)

  • Sie könnten es jetzt in intellij Idee verwenden

    
think 06.05.2018 11:42
quelle
5

Ich habe dieses Skript erstellt, das alle zusammenstoßenden Verknüpfungen zwischen Ubuntu (getestet mit 15.10) und IntelliJ (und wahrscheinlich mehr Jetbrains-Produkten) deaktiviert. Es deaktiviert sie in Ubuntu.

Es erstellt auch eine Sicherungsdatei, damit Sie Ihre vorherigen Einstellungen wiederherstellen können.

Damit einige Tastenkürzel nicht deaktiviert sind, kommentieren Sie sie im Array KEYS aus.

#!/bin/bash
set -euo pipefail

# Disables Ubuntu shortcuts that clash with IntelliJ Idea (and probably other
# Jetbrain products).
#
# Creates a backup file to restore the previous settings. To not have some
# shortcuts disabled, comment them out in the 'KEYS' array.
#
# Tested on : Ubuntu 15.10
# Author    : Jonas Gröger

readonly BACKUP_FILE="undo-fix-shortcuts-$(date +%s%N).sh"
readonly KEYS=(
    "/org/gnome/desktop/wm/keybindings/toggle-shaded"
    "/org/gnome/settings-daemon/plugins/media-keys/screensaver"
    "/org/gnome/settings-daemon/plugins/media-keys/terminal"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-down"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-up"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-left"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-right"
    "/org/gnome/desktop/wm/keybindings/begin-move"
    "/org/gnome/desktop/wm/keybindings/begin-resize"
    # To disable resetting a value, just comment out the line
)
readonly DISABLED_VALUE="['disabled']"

main() {
    # Make backup
    printf "#!/bin/bash\n" >>  "$BACKUP_FILE"
    for key in "${KEYS[@]}"; do
        local value
        value=$(dconf read "$key")
        printf "dconf write \"%s\" \"%s\"\n" "$key" "$value" >> "$BACKUP_FILE"
    done

    # Disable all Ubuntu shortcuts
    for key in "${KEYS[@]}"; do
        dconf write "$key" "$DISABLED_VALUE"
    done
}
main

Sie können es von hier bekommen:

wget -O fix-shortcuts.sh https://gist.githubusercontent.com/JonasGroeger/94cfa1071fa12572f465/raw/fix-shortcuts.sh
    
Jonas Gröger 16.12.2015 22:40
quelle
3

Unter hier finden Sie eine Möglichkeit, Ubuntu-Verknüpfungen programmgesteuert und nur dann zu deaktivieren, wenn die Fenster bestimmter Anwendungen aktiv sind.

Verwenden Sie diese Werte insbesondere (vorausgesetzt, Sie verwenden die JetBrains Toolbox mit ihrem Standardinstallationspfad; passen Sie sie andernfalls an):

apppattern = "JetBrains"
backupfile = "~/.local/share/JetBrains/keymap_backup"

Während das Skript läuft, werden Ubuntu-Verknüpfungen immer funktionieren, außer wenn IDEA et al. Fokus haben.

Ich habe eine Sammlung von JetBrains-spezifischen Verknüpfungen hier ; Eingabe ist erwünscht.

    
Raphael 22.12.2016 14:32
quelle
2

Nur um ein wenig über die ausgezeichnete Antwort von AzkerM zu erweitern:

  
  • Deaktivieren Sie die Move-Fensteraktion, die Alt + F7 zugewiesen ist (Verwendungen finden)      
        
    • von Einstellungen - & gt; Tastatur - & gt; Verknüpfungen - & gt; Windows - & gt; Fenster verschieben
    •     
  •   
  • Ändern oder deaktivieren Sie die Aktion Fenstergröße ändern, die Alt + F8 zugewiesen ist (Ausdruck auswerten)      
        
    • von Einstellungen - & gt; Tastatur - & gt; Verknüpfungen - & gt; Windows - & gt; Fenstergröße anpassen
    •     
  •   
    
WillC 24.02.2016 12:15
quelle
1

Ich benutze Ubuntu 16.04 und was passierte, war, als ich diese Tastenanschläge benutzte (Strg-Alt-Links / Rechts), das Fenster wurde in der Größe verändert und platzierte sich rechts oder links von meinem Bildschirm. Ich habe versucht, diese Tastaturbelegungen in den folgenden Einstellungen zu deaktivieren: Einstellungen / Tastatur / Navigation, obwohl ich keine Arbeitsbereiche aktiviert habe. Es hat das Verhalten, das ich sah, immer noch nicht verhindert.

Glücklicherweise habe ich Compiz geöffnet und bin über das Window Management / Grid-Plugin gestolpert, das diese Tasten zugeordnet hat, um Fenster in einer Gitterposition zu platzieren. Ich habe dieses Plugin deaktiviert und jetzt funktionieren meine IntelliJ-Tastenkürzel gut mit Strg-Alt-Links / Rechts.

    
Jason White 14.06.2016 00:08
quelle
1

Nur ein kurzer Workaround:
Wenn Sie eine " Windows " - Taste auf Ihrer Tastatur haben, können Sie sie einfach zur gesamten Tastenkombination hinzufügen - das sollte funktionieren. Zum Beispiel:

  • Strg + Win + Alt + T (Surround mit)
  • Win + Alt + F8 (Ausdruck auswerten )
guzoff 28.11.2017 21:53
quelle
0

Für Ubuntu 16.04 gehe zu Einstellungen & gt; Keyboard und finden Sie die bestimmte Kombination im Widerspruch zu Ihrem gewünschten Klick darauf und aktualisieren Sie die Kombination zu einem neuen.

    
Cengkuru Michael 29.10.2017 10:22
quelle