Unity lädt nicht, kein Launcher, kein Dash wird angezeigt

533

Wenn ich mich anmelde passiert nichts.

Ich bin mit meinem Desktop-Hintergrund vorgestellt.

Kein Dash, kein Launcher, nichts.

    
jrg 14.12.2010, 18:24

30 Antworten

464
  

Diese Antwort wendet Versionen von Ubuntu an, auf denen Compiz läuft.

     

Diese Antwort setzt voraus, dass Unity durch Compiz ausgeführt wird. Wenn Sie compiz nicht installiert installiert haben Diese Antwort trifft nicht auf dich zu.

Sie müssen nur das Unity-Plugin wieder einschalten. Das Problem ist, dass es ein Problem ist, weil Sie jetzt keine grafische Methode dafür haben. Also:

  1. Versuchen Sie, ein Terminal mit Strg + Alt + T zu öffnen Dies funktioniert möglicherweise nicht, aber Sie können versuchen, mit der rechten Maustaste auf den Desktop zu klicken und "Terminal hier öffnen" zu wählen. Andernfalls müssen Sie möglicherweise zu einem "harten" Terminal wechseln, indem Sie drücken Strg + Alt + F1 und loggen Sie sich ein.

  2. Installieren Sie compizconfig-settings-manager , indem Sie

    ausführen
    sudo apt-get install compizconfig-settings-manager
    
  3. Dann führe es mit diesem aus:

    DISPLAY=:0 ccsm &
    

    Der erste Teil teilt dem Terminal mit, auf welcher Anzeige es geladen werden soll (sonst hat es keine Ahnung).

  4. Wenn Sie in Schritt 1 zu einem TTY gewechselt haben, wechseln Sie zurück zum grafischen Server, indem Sie Strg + Alt + F7 drücken (oder Strg + Alt + F8 manchmal).
    Dort sollte ein CompizConfig Settings Manager auf Sie warten.

  5. Finde das Unity-Plugin. Aktivieren Sie es. Sie werden gefragt "Ubuntu Unity Plugin benötigt das Plugin OpenGL. Aktivieren Sie Ubuntu Unity Plugin / Enable OpenGL"

  6. Alles sollte ins Leben kommen, aber wenn nicht, musst du vielleicht neu starten. Sie können das tun, indem Sie zum Terminal zurückkehren und sudo reboot ausführen.

Oli 08.11.2011, 00:23
165

Eine gute Lösung für mich (hat das gleiche Problem gelöst):

in einem Terminal:

export DISPLAY=:0   
sudo dconf reset -f /org/compiz/

und dann

setsid unity
    
user155373 04.05.2013 02:50
72

In 13.04 und 14.04:

unity --replace ist veraltet. Verwenden Sie stattdessen Folgendes:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Neustart, wenn es nicht sofort funktioniert.

    
Brandon Bertelsen 27.04.2013 04:39
60

Für 12.10 und darunter:

Drücken Sie Strg + Alt + T für ein Terminal und führen Sie ccsm aus, und aktivieren Sie dann das Unity-Plugin erneut / p>

Sie müssen dann möglicherweise auch unity --replace ausführen.

    
xyzzyman 02.10.2011 04:33
51

Es empfiehlt sich, zu überprüfen, ob der Grafiktreiber für die Hardwarebeschleunigung konfiguriert ist und ob OpenGL verwendet wird. Versuchen Sie es mit der Suche In den Ubuntu und Ubuntu Foren finden Sie Informationen zu Ihren GPUs und Ubuntus. Für hybride Grafik Benutzer sehen Sie den letzten Abschnitt "Hybrid Graphics" weiter unten.

Vielleicht möchten Sie den compizconfig-settings-manager ausführen Paket und stellen Sie sicher, dass das Unity-Plugin aktiviert ist (siehe Was sind einige der Probleme mit CCSM und warum sollte ich es vermeiden? ).

Für 12.04 und neuer

  1. Wechseln Sie zu tty1 , indem Sie Strg + Alt + F1 drücken und sich anmelden.

  2. Installieren Sie compizconfig-settings-manager , indem Sie

    ausführen
    sudo apt-get install compizconfig-settings-manager
    
  3. Dann führe es aus:

    export DISPLAY=:0
    ccsm
    

    Der erste Teil teilt dem Terminal mit, auf welcher Anzeige es geladen werden soll (sonst hat es keine Ahnung).

  4. Drücken Sie Strg + Alt + F7 (oder Strg <+ + Alt + F8 manchmal), um zur grafischen Anzeige zurückzukehren, auf der sich ein CompizConfig Settings Manager-Bildschirm befinden sollte.

  5. Finde das Unity-Plugin. Aktivieren Sie es.

  6. Alles sollte ins Leben kommen, aber wenn nicht, musst du vielleicht neu starten. Sie können das tun, indem Sie zu tty1 zurückkehren und sudo reboot ausführen.

Wenn die Einheit immer noch nicht geladen wird, versuchen Sie:

dconf reset -f /org/compiz/
unity --reset-icons &disown

Neustart, wenn es nicht sofort funktioniert.

Für 11.10 und älter

Wenn Sie auf eine TTY hoffen ( Strg + Alt + F1 bis F6 ) und run:

DISPLAY=:0 unity --replace

Er setzt Unity zurück auf TTY 7 ( Strg + Alt + + F7 ).

Sie können auch einfach versuchen:

DISPLAY=:0 unity

Aber das funktioniert nicht, wenn ein Windows-Manager bereits auf der Anzeige 0 läuft (es wird Ihnen eine Fehlermeldung geben, verwenden Sie in diesem Fall unity --replace ).

Wenn Unity absolut den Neustart verweigert, versuchen Sie Folgendes:

Installieren Sie gnome-panel :

sudo apt-get install gnome-panel

Dann führe es auf dem Display 0 aus:

DISPLAY=:0 gnome-panel

Sie sollten dann Gnome 2 Style-Panels auf Ihrem Desktop haben, mit denen Sie sich abmelden können.

Hybridgrafik

Einige sehr nützliche Informationen und weiterführende Informationen für hybride Grafikbenutzer finden Sie hier .

Sobald GPUs entsprechend für 3D-Beschleunigung und OpenGL konfiguriert sind, können Sie:

  1. Installieren Sie die Nvidia-Treiber von link :

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    oder:

    Ich würde wirklich die stabile PPA vorziehen, aber es scheint noch keine Pakete für 13.04 zu haben . Update: Diese scheinen ab 25. September verfügbar zu sein. Ich würde dieses stabile PPA installieren - Sie können es versuchen, aber ich habe es nicht getestet.

    Die von Ubuntu gelieferten Nvidia-Treiber wurden bereits installiert und ich habe es einfach von diesem PPA installiert, indem ich es hinzugefügt und ein Paketupdate mit update-manager durchgeführt habe.

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    
  2. Installieren Sie Bumblebee von link

    UPDATE: Ab dem 6. Oktober scheint ppa:xorg-edgers/ppa auch Hummeln zu enthalten. Wenn Sie also von diesem PPA aus installieren, sollten Sie versuchen, das Hinzufügen des Bumblebee PPA zu überspringen und stattdessen von hier aus zu installieren.

    Wenn Sie in Schritt 1 die stabile PPA ausgewählt haben, installieren Sie die stabile PPA für Bumblebee wie folgt:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. UPDATE: Aktualisieren Sie nach dem Hinzufügen der PPA (s) Ihre Paketlisten:

    sudo apt-get update
    

    Wenn Sie bereits Nvidia-Treiber von Ubuntus Standard-Repositorys installiert haben, aktualisieren Sie einfach, um die neue Version aus dem in Schritt 1 ausgewählten Repository zu erhalten:

    sudo apt-get upgrade
    sudo apt-get install bumblebee
    
  4. Führen Sie die folgenden Befehle aus, um Unity zu 'reparieren' (von brandon-bertelsen 's Antwort auf Unity lädt nicht, kein Launcher, kein Dash erscheint ):

    dconf reset -f /org/compiz/
    unity --reset-icons & disown
    
Mark Shuttleworth 27.12.2010 13:45
32

Dies ist am einfachsten, indem Sie Strg + Alt + T drücken, um ein Terminal zu erhalten und dann folgendes ausgeben:

rm -rf ~/.compiz-1 ~/.config/compiz-1

und deine Einheitssitzung wird vor deinen Augen zurückkommen.

Diese Technik ist besser als ccsm neu zu starten, weil Sie in den Fehlerzustand von OP gelangen können, ohne versehentlich die Einheit in ccsm auseinandernehmen zu müssen; Sie können es einfach erhalten, indem Sie versehentlich auf die Schaltfläche "Einstellungen" in ccsm drücken.

    
achiang 10.11.2011 06:55
24

Ich hatte dieses Problem auch. Ich löste es mit dem Löschen des Inhalts der Datei ~ / .config / compiz-1 / compizconfig und relog.

rm -rf ~/.config/compiz-1/compizconfig/*
    
dome cs 30.10.2011 07:23
21

Ich hatte genau das gleiche Problem.

Wenn Sie den Compiz Config Settings Manager installiert haben, ist das Unity Desktop Plugin möglicherweise deaktiviert.

Melden Sie sich bei einem Unity 2D-Desktop an und überprüfen Sie, ob er in CCSM wie folgt aktiviert ist,

Unity Shell wird nicht auf dem Standarddesktop geladen, wenn das Kontrollkästchen nicht aktiviert ist und Sie die Sitzung in Ihrem Bild erhalten.

    
Mark Rooney 22.10.2011 09:09
19

Entwickler beheben immer Bugs, also ist es eine Alternative, zu warten und den Fortschritt bei der Fehlerbehebung zu verfolgen ( abonnieren) zur Unity-Entwicklung im Launchpad ).

  1. Drücken Sie Strg + Alt + F2 .

  2. Melden Sie sich an.

  3. Führen Sie sudo shutdown -r now in einem Terminal aus.

  4. Wählen Sie im Anmeldebildschirm nach dem Neustart Ihres Systems Unity 2D (für jetzt) indem Sie mit der rechten Maustaste auf das Zahnradsymbol klicken.

  5. Warten Sie auf eine Fehlerbehebung für Unity 3D / Ubuntu 11.10 (z. B. eine Woche).

  6. Aktualisieren Sie Ihr System, um das Update zu erhalten. in einem Terminaltyp sudo apt-get update && sudo apt-get upgrade .

UPDATE: Ich konnte dies beheben, indem ich ccsm von der Unity 2D-Anmeldung verwendete.

(Dies wird von diesem Ubuntu-Forums-Beitrag angepasst.)

  1. Wählen Sie im Anmeldebildschirm Unity 2D und loggen Sie sich ein.

  2. Installieren Sie ccsm (CompizConfig Einstellungs-Manager), indem Sie in einem Terminal ausführen: sudo apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra .

  3. Starten Sie ccsm und wählen Sie die Kategorie Desktop . Aktiviere das Ubuntu Unity Plugin ; Wenn Sie aufgefordert werden, Konflikte zu lösen, wählen Sie die MIDDLE-Schaltfläche für alle Konflikte. Schließen Sie ccsm , wenn Sie fertig sind.

  4. Starten Sie neu, wählen Sie Unity (3D) und loggen Sie sich ein.

david6 15.10.2011 23:47
13

Ich habe ein Asus U36SD mit einem "Optimus" (Intel + Nvidia GPUs) Setup. Ich hatte Ubuntu 12.04 funktioniert gut, aber Upgrade auf 12.10, erschien dieses Problem und beharrte in 13.04. Ich habe es geschafft, es durch die folgenden Schritte zu beheben:

  1. Installieren Sie Nvidia-Treiber über den Link .

    ODER:

    Ich würde die stabile PPA im Link , , wirklich bevorzugen aber es scheint noch keine Pakete für 13.04 zu haben . Update: Diese scheinen ab 25. September verfügbar zu sein. Ich würde diese stabile PPA installieren - Sie können es versuchen, aber ich habe es nicht getestet.

    Die von Ubuntu gelieferten Nvidia-Treiber wurden bereits installiert und ich habe es einfach von diesem PPA installiert, indem ich es hinzugefügt und ein Paketupdate mit update-manager durchgeführt habe. UPDATE:

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    (was ich getan habe) oder:

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    

    (stabile Version für 13.04 auch jetzt - nicht von mir getestet).

  2. Installieren Sie Bumblebee von link

    UPDATE: Ab dem 6. Oktober scheint ppa: xorg-edgers / ppa auch Hummeln zu enthalten. Wenn Sie also von diesem PPA aus installieren, sollten Sie versuchen, das Hinzufügen des Bumblebee PPA zu überspringen und stattdessen von hier aus zu installieren.

    Wenn Sie in Schritt 1 die stabile PPA ausgewählt haben, installieren Sie die stabile PPA für Bumblebee wie folgt:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. UPDATE: Aktualisieren Sie nach dem Hinzufügen der PPA (s) Ihre Paketlisten:

    sudo apt-get update
    

    Wenn Sie bereits Nvidia-Treiber aus den Standard-Repositorys von Ubuntu installiert haben, aktualisieren Sie einfach, um die neue Version aus dem in Schritt 1 ausgewählten Repository zu erhalten:

    sudo apt-get upgrade
    

    Installiere Bumblebee

    sudo apt-get install bumblebee
    
  4. Führen Sie die folgenden Befehle aus, um Unity zu 'reparieren' (aus brandon-bertelsen 's Antwort auf Unity lädt nicht, kein Launcher, kein Dash erscheint ):

    dconf reset -f /org/compiz/ 
    unity --reset-icons &disown
    
Thomas Arildsen 02.05.2013 12:45
12

Das Originalposter der doppelten Frage, gelöst in der Bearbeitung seiner eigenen Frage:

  

Lösung gefunden: Löschen Sie .Xauthority in meinem Zuhause (oder benennen Sie es um)

    
mateo_salta 08.08.2012 22:41
10

Für 13.10:

Nur um sicherzustellen, dass alles installiert ist:

sudo apt-get install --reinstall unity ubuntu-desktop

Als nächstes laden Sie alles neu:

dconf reset -f /org/compiz/ && unity --reset-icons &disown

Ich habe es gerade versucht und es funktioniert!

Quelle:

Link

Wenn alles andere fehlschlägt:

Denken Sie daran, immer Backups zu machen! Aber manchmal eine Neuinstallation ist gut, neu installieren Ubuntu?

    
Jared Burrows 06.12.2013 01:07
10

Das ist mir auch in Ubuntu 16.04 nach einem Upgrade von Unity- und Compiz-Paketen passiert. Keines der oben genannten funktioniert.

Der einzige Weg, den ich gefunden habe, um Launcher und Bindestriche zurück zu haben, war, das Verzeichnis .cache in meinem Haus zu entfernen (obwohl NICHT in Unity angemeldet).

    
lorenzo-bettini 20.09.2016 09:27
9

Es scheint ein Problem mit 12.04 Unity 3D und den aktuellen Nvidia-Treibern zu bestehen.

Siehe diesen Post (Unity 3d funktioniert nach der Installation nicht mehr 12.04) für Einzelheiten zur Problemumgehung.

Ich habe einen 32 Bit Pentium 4 3.06 GHz Compaq D520SFF, mit einer Nvidia GeForce 6200, Kernel 3.2.0-24-generic-pae, und hatte genau das gleiche Problem (2D funktioniert, 3D nicht), und Das Herunterstufen der Nvidia-Treiber hat 3D in wenigen Minuten für mich funktioniert.

    
Heimdall 01.05.2012 01:38
8

Für die Symbole ist das auf Nautilus zurückzuführen. Schreibe nautilus & in ein Terminal, schließe es nicht und die Symbole werden wieder angezeigt.

EDIT 10/10/2013 : Für Nautilus können Sie auch Alt + F2 eingeben, um die Unity-Befehlszeile zu öffnen und% co_de zu schreiben % in der globalen Such- / Eingabeaufforderungs-CLI. Ein Datei-Explorer wird geöffnet. Sie können es schließen, wenn Sie möchten.

    
air-dex 26.12.2012 16:14
8

Ich hatte ein ähnliches Problem:

Einheit mit 14.04 in Kombination mit IBM Notes9 führte zu einem seltsamen Verhalten (Mausklicks würden nicht mehr funktionieren). Mein Workaround dafür war, ein Terminal zu öffnen und die Einheit durch Eingabe von unity & zu starten.

Das letzte Mal, als ich das gemacht habe, hat es die Einheit total korrumpiert - den No Dash, No Launcher und nichts. Ich denke, ich habe versucht, jeden Vorschlag, der auf dieser Seite aufgeführt ist - nichts davon hat geholfen.

Aber ein Kollege hatte endlich die Antwort, die für mich funktionierte:
Ich habe das Unity-Tweak-Tool installiert; als ich unity-tweak-tool --reset-unity ausgeführt und neu gestartet habe.

Danach war die Einheit wieder lebendig. Offensichtlich waren alle vorherigen Konfigurationsänderungen an der Einheit weg, aber darum geht es in --reset-unity .

Und der große Vorteil dieser Lösung: Sie müssen nur ein einziges Paket hinzufügen und die Änderungen an der Einheitskonfiguration wiederholen - aber Sie müssen compiz nicht zurücksetzen, ccsm nicht installieren oder all den anderen langwierigen Aktivitäten folgen. p>

Aktualisierung:

Die andere Lösung finde ich sehr hilfreich heutzutage kommt von hier - der Punkt : Manchmal müssen Sie Ihre ~ / .config / dconf / Benutzerdatei entfernen (oder besser: eine "funktionierende" Sicherung).

    
GhostCat 04.06.2014 12:21
6

Wenn Sie auf ein tty hoffen ( Strg + Alt + F1 bis F6 ) und run:

DISPLAY=:0 unity --replace

Es wird Unity wieder auf tty 7 zurückgesetzt ( Strg + Alt + + F7 ).

Sie können auch einfach versuchen:

DISPLAY=:0 unity

Aber das funktioniert nicht, wenn ein Windows-Manager bereits auf der Anzeige 0 läuft (es wird Ihnen eine Fehlermeldung geben, verwenden Sie in diesem Fall unity --replace ).

Wenn Unity absolut den Neustart verweigert, versuchen Sie Folgendes:

Installieren Sie gnome-panel :

sudo apt-get install gnome-panel

Dann führe es auf dem Display 0 aus:

DISPLAY=:0 gnome-panel

Sie sollten dann Gnome 2 Style-Panels auf Ihrem Desktop haben, mit denen Sie sich abmelden können.

Ich finde Unity am 13.04 mit meiner Nvidia-Karte wirklich buggy. YMMV.

    
Seth 19.05.2013 20:07
5

Ich hatte ungefähr 3 mal, wo ich die Strg + Alt + F1 brauchte, um keine Arbeit zu verlieren, und es vermasselte ... Ich habe auch Nvidia. Ich möchte dies vorschlagen:

Strg + Alt + F1 (ok, leerer Bildschirm) Geben Sie Ihr Login ein, drücken Sie die Eingabetaste und dann das Passwort (alles im leeren Bildschirm) Tippe das jetzt ein:

sudo startx -- :1

muss erneut ein Passwort eingeben und Enter eingeben Dies öffnet eine X-Sitzung bei Strg + Alt + F8 (springt automatisch dazu) Erstellen Sie jetzt eine neue leere Textdatei namens runBash.sh und geben Sie Folgendes ein:

bash

Speichern Sie es, ändern Sie seine Berechtigungen in eine ausführbare Datei und führen Sie es aus. Sie erhalten ein wirklich entlastendes Terminal, das Sie daran erinnert, warum Linux gut ist! : D

Wenn Sie fertig sind, denken Sie an Strg + Alt + F1 , drücken Sie Strg + C (beendet die neue X-Sitzung), geben Sie exit ein, Enter, beendet die Terminal-Sitzung (leerer Bildschirm). Wenn du denkst, dass du es versäumt hast, exit zu tippen, drücke einfach Strg + C und tippe erneut, mach es nicht zu schnell.

damit Sie es verbessern können, machen Sie ein Skript, damit Sie so wenig wie möglich eingeben können, aber trotzdem müssen Sie viel eingeben, während der Bildschirm leer ist, aber es ist besser als nichts:)

Suche noch nach definitiver Ctrl + Alt + F1 richtige Lösung Ubuntu 12.04 + nvidia.

    
Aquarius Power 28.05.2012 01:39
4

Wenn Sie eine Beschleunigungsgrafikkarte neben der Standardgrafikkarte verwenden, liegt das möglicherweise an der Installation ihrer Treiber. Einige Aktualisierungen der Grafikkartentreiber für die Beschleunigung in Systemen mit zwei Grafikkarten weisen in einigen Systemen ein instabiles Verhalten auf. Ich habe eine Nvidia-Karte und eine Intel-Karte. Das war bei mir der Fall, als ich Nvidia-Treiber installierte. Launcher und Panel würden vom Desktop verschwinden. Wenn Sie eine Nvidia-Karte verwenden, kann die Installation von Bumblebee eine vorübergehende Lösung sein: Link

    
user153634 01.05.2013 12:46
4

Die erste Antwort funktioniert gut, außer dass ich Unity selbst installieren musste:

sudo apt-get install unity

dann ausführen:

ccsm

und aktivieren Sie Unity:)

    
sobi3ch 26.11.2013 02:22
4

Ich hatte so ziemlich das selbe Problem unter 12.04. Die Unity war langsam mit meiner alten GPU, weshalb ich Unity 2d monatelang als Desktop verwendete. Ohne ersichtlichen Grund hat es sich plötzlich geweigert, Launchpad und Titelleiste anzuzeigen (für alle Benutzer). Die erneute Bereitstellung von Unity in CCSM, wie hier vorgeschlagen, war Teil der Lösung, aber keine der anderen hier vorgeschlagenen Maßnahmen, weder dort noch in mehreren anderen verwandten Themen, einschließlich, aber nicht beschränkt auf:

  • Erneutes Installieren der Einheit

  • Neuinstallation von Ubuntu-Desktop

  • Entfernen aller relevanten Konfigurationsinformationen (z. B. compiz, gconf usw.)

hat mir geholfen, diese Symptome unter 12.04 (64 Bit) vollständig zu lösen.

unity --reset

würde nicht für mich arbeiten. Nach dem Liefern einer Vielzahl von Fehler- und Informationsnachrichten würde es immer hängen bleiben:

Setting Update "run_key"

wie in dem Protokoll in der Thread mit dem Titel "Einheit ist verschwunden" für die Einheit ohne Argumente angezeigt .

Ich habe festgestellt, dass die Fehlermeldung von:

geliefert wurde
/usr/lib/nux/unity_support_test -p

ähnelt einigen der von unity --reset gemeldeten Fehler:

Fehler beim Laden gemeinsamer Bibliotheken: libGL.so.1: Gemeinsame Objektdatei kann nicht geöffnet werden: Keine solche Datei oder Verzeichnis.

Nach ausführlicher Suche habe ich folgende Lösung gefunden:

  • Erhalte den Pfad von libGL.so.1 mit dem Befehl locate libGL.so.1 .

  • Fügen Sie einen Link zur Bibliothek in / usr / lib / hinzu, wie im folgenden Beispiel gezeigt:

    sudo ln -s /usr/lib/i386/mesa/libGL.so.1 /usr/lib
    

    (mit freundlicher Genehmigung von JD Bartlett )

  • Starten Sie den Computer neu.

Dies erlaubte nicht nur das Ausführen von unity_support_test-p und unity --reset , sondern auch das Starten von Unity 2D. Ich habe keine Ahnung, was meine Probleme verursacht hat, aber seit dem Erstellen der Links oben (seit einigen Wochen) hatte ich keine weiteren Probleme.

    
R B 20.12.2013 11:42
4

Als ich versehentlich von 12.04 LTS Ubuntu auf 13.04 aktualisiert habe, musste ich mich mit den gleichen Problemen herumschlagen, wie fehlende Seitenleiste, keine Fensteroptionen, nicht zwischen den Anwendungen wechseln zu können ( alt - tab ) und ich konnte nicht einmal Fenster auf dem Bildschirm ziehen. Nachdem ich so viele Optionen verfolgt hatte, endete ich mit den folgenden Befehlen, um diese Probleme zu beheben.

sudo apt-get remove aspell #may not be relevant
sudo apt-get remove dictionaries-common

reboot (Sie können sudo reboot verwenden)

sudo apt-get install compizconfig-settings-manager
sudo apt-get install dictionaries-common
sudo apt-get install lightdm

reboot (Sie können sudo reboot verwenden)

dconf reset -f /org/compiz/
unity --reset-icons & disown

Ich habe aspell wegen widersprüchlicher Abhängigkeit tatsächlich entfernt. Dies hat möglicherweise keine Korrelation zwischen diesem Problem. Ich denke, das erneute Installieren von Lightdm und das Zurücksetzen von Compiz haben mir geholfen, dies zu beheben.

    
Bunti 16.05.2014 18:20
4

Es passiert, wenn Sie sich mit einem anderen tty anmelden und versuchen, als derselbe Benutzer X (mit startx oder initx) zu starten.

Zum Beispiel läuft Ubuntu in tty7. Mit Strg + Alt + F1 tty1 öffnet sich. Melden Sie sich als derselbe Benutzer an, und führen Sie startx aus. Gehe zurück zu tty7, logge dich aus und logge dich ein. Sie erhalten nur die Desktop-Tapete.

Um das Problem zu lösen, wählen Sie tty1, loggen Sie sich ein, entfernen Sie die .Xauthority-Datei in Ihrem Home-Verzeichnis, melden Sie sich ab, loggen Sie sich ein. Gelöst.

    
user85164 27.04.2013 08:59
2

Ich hatte das gleiche Problem, nachdem ich sudo apt-get install kubuntu-desktop gemacht habe, was meine Lightdm-Installation aus irgendeinem Grund zerstört hat. Ich laufe hier 16.04.

Drücken Sie ctrl - alt - F1 , um zum Terminal zu gelangen, dann:

sudo service lightdm stop
sudo apt-get remove lightdm
sudo apt-get update && sudo apt-get install lightdm
sudo reboot

Das hat es für mich repariert, nachdem ich mir stundenlang die Haare ausgezogen habe.

    
localhost 07.10.2016 17:29
2

Arbeite für Ubuntu 16.04:

Ich setze compizconfig zurück, indem ich seinen Cache entferne (der Befehl erstellt tatsächlich eine Sicherung, so dass er wiederhergestellt werden kann).

Führen Sie die folgenden Befehle aus und melden Sie sich anschließend ab:

mv ~/.cache/compizconfig-1 ~/.cache/compizconfig-backup

setsid unity

Achtung: Dadurch wird Ihr benutzerdefiniertes Unity-Setup entfernt.

    
Oleksandr Shpota 09.03.2018 00:49
1

Ich habe das gleiche Problem und löste es mit pycharm's terminal .

 - Go to my-computer -> user -> share ->  
 - open pycharm and its terminal
 - sudo apt-get update
 - sudo apt-get upgrade 
 - sudo apt-get install --reinstall ubuntu-desktop
    
Muhammad Taqi 02.06.2015 14:26
1

Offensichtlich war das Fixieren des zweiten Monitors das Problem, und dann konnte ich die richtigen Treiber installieren und aktualisieren.

    
user2580915 27.07.2015 20:08
1

Ich habe viele der in diesem Thread erwähnten Lösungen sowie andere ausprobiert. Schließlich hat das für mich funktioniert:

dconf reset -f /org/compiz/

dann

setsid unity

Danke allen für ihren Beitrag.

    
Ashu 17.01.2016 02:00
1

Heute bin ich auf eine Situation gestoßen, in der der Benutzer meines Skripts entschieden hat, das Skript zu starten, indem er den Aufruf in seine $HOME/.profile -Datei schreibt. Daher konnte Unity nicht gestartet werden.

Skripte sind von Natur aus sequenziell, daher wartet .profile im Grunde darauf, dass das Skript beendet wird, und Unity konnte nicht starten, wenn .profile nicht ausgeführt wurde.

Ich habe das gleiche getan, habe das Skript von .profile aufgerufen und das gleiche Ergebnis erhalten - mein Login-Bildschirmhintergrund blieb dort, kein Dash oder Launcher erschien, konnte nicht mit der rechten Maustaste auf den Desktop klicken oder eine andere Aktion ausführen Melden Sie sich bei TTY1 an.

Die Lösung bestand darin, die entsprechende Zeile aus .profile zu entfernen. Es ist möglich, einen Befehl von .profile mithilfe des Und-Zeichens, <command> & Formulars zu lösen, aber das Problem ist, dass jedes Mal, wenn ein Benutzer das Terminal öffnet oder sich bei TTY anmeldet, eine neue Instanz dieses Befehls generiert wird. Daher würde ich dringend empfehlen, keine Programme von .profile zu starten, wenn Sie nicht genau wissen, was Sie tun.

Link zum ursprünglichen Skript und Diskussion hier: link

    
Sergiy Kolodyazhnyy 28.02.2016 04:10
1

Ich hatte dieses Problem, ich versuchte eine Menge Dinge und ermöglichte sogar die Einheit, aber nichts funktionierte. Zuerst müssen Sie TTY (Strg + Alt + F1) öffnen und sich anmelden. Jetzt benutze

    env DISLAY:=0 gnome-terminal        

Schließen Sie TTY mit Strg + Alt + F7 und verwenden Sie dann (im Terminal)

dconf reset -f /org/compiz/

Danach verwenden Sie

sudo reboot
    
TheEpicstarlord 07.01.2017 14:09

Tags und Links