Wie kann ich Bluetooth beim Systemstart deaktivieren?

271

Wie kann ich Bluetooth beim Systemstart deaktivieren?

    
Floqqi 16.10.2011, 23:02
quelle

28 Antworten

187

18.04+ Benutzer, die nicht natürlich eine /etc/rc.local haben, müssen eine erstellen und ausführbar machen. Um die Sache etwas einfacher zu machen, können Sie einfach den folgenden Befehl in ein Terminal einfügen:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Führe sudoedit /etc/rc.local aus und füge dies vor der Zeile mit exit 0 :

hinzu
rfkill block bluetooth

Sie sollten Bluetooth weiterhin über das obere Balken-Applet aktivieren können.

Dieses sollte für die meisten Systeme funktionieren, aber es sieht so aus, als ob einige Fehler im ACPI des Kernels für Thinkpads lauern. Wenn Sie auf einem Thinkpad arbeiten, fügen Sie Folgendes zu /etc/rc.local hinzu:

echo disable > /proc/acpi/ibm/bluetooth

Oder sehen Sie sich ibm-acpi - Treiber für IBM ThinkPad ACPI-Extras an - einige Berichte legen nahe, dass ibm-acpi eine Bluetooth-Steuerung enthält (unter anderen schönen Dingen). Aber ich habe keine Hardware, daher kann ich diese Behauptungen nicht überprüfen. Viel Glück.

    
Oli 18.08.2010 11:00
quelle
67

Ich habe ein How-To mit einem sauberen "Workaround" hier gefunden ( Archivlink für die Nachwelt)

Eigentlich war das Ändern von /etc/bluetooth/main.conf genug für mich.

Aus dem Artikel:

Suche nach dem Eintrag:

InitiallyPowered = true

und ändern Sie den Wert zu:

InitiallyPowered = false

Es war genug für mich, obwohl der Artikel einige andere Schritte beschreibt, die möglicherweise notwendig sind oder nicht.

Auf Ubuntu 17.10 und Ubuntu 18.04 wurde die Option InitiallyPowered durch AutoEnable

ersetzt     
Stepbaer 25.06.2012 20:00
quelle
23

So deaktivieren Sie den Bluetooth-Treiber beim Start:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

hinzufügen:

blacklist btusb

Es sollte später aktiviert werden:

sudo modprobe btusb
    
maco 18.08.2010 18:59
quelle
16

Schritt 1: Gehen Sie zum Terminal und geben Sie den folgenden Befehl ein, um die /etc/rc.local -Datei des Systems zu bearbeiten:

gksudo gedit /etc/rc.local

Schritt 2: Fügen Sie die folgende Zeile vor der exit 0 -Zeile hinzu:

rfkill block bluetooth
    
Varun 04.05.2012 22:44
quelle
12

Ab Ubuntu 16.04 verwaltet Systemd Startup-Dienste wie Bluetooth ... um das aktuelle Statusproblem in einem Terminal anzuzeigen

sudo systemctl status bluetooth.service 

um Bluetooth beim Start zu deaktivieren, geben Sie dies ein

sudo systemctl disable bluetooth.service

dann beim nächsten Neustart Bluetooth ist nicht aktiv ... um Bluetooth-Problem zu aktivieren

sudo systemctl enable bluetooth.service
    
Scott Stensland 01.08.2017 17:08
quelle
7

Geben Sie Folgendes in ein Terminal ein:

sudo gedit /etc/modprobe.d/blacklist.conf

Fügen Sie am Ende der Datei die folgende Zeile hinzu:

blacklist bluetooth

Speichere die Datei und starte neu - Bluetooth sollte jetzt deaktiviert sein.

    
Nathan Osman 16.10.2011 23:25
quelle
7

Sie können die Dienste, die beim Booten gestartet werden, mit Hilfe von BUM ändern.

Installieren Sie es: sudo apt-get install bum

Ausführen: sudo bum

Deaktivieren Sie das Kontrollkästchen und klicken Sie auf Anwenden .

    
desgua 05.05.2012 02:09
quelle
5

Ich denke, dass der beste Weg ist, den Service von vornherein zu deaktivieren. Es gibt eine allgemeine Methode zum Deaktivieren von Diensten, die perfekt funktioniert:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

Das funktioniert für Ubuntu 13.10 und wahrscheinlich auch für frühere Versionen.

    
Felipe 18.01.2014 10:49
quelle
5

Ich füge

hinzu
"/etc/init.d/bluetooth stop"

in

"/etc/rc.local" 

vor dem Befehl "exit 0" für das Booten mit ausgeschaltetem Bluetooth.

    
Saeed Zarinfam 23.08.2012 15:00
quelle
5

1. blockiere bluetooth in rc.local

Fügen Sie diese Zeile am Ende der Datei /etc/rc.local direkt vor der Zeile exit 0 :

hinzu
rfkill block bluetooth

Dies wird den Trick machen, aber nur in älteren Ubuntu-Versionen mit upstart .

2. reenable rc.local auf systemd

Unter Ubuntu 15.10 mit systemd als Startup-Manager wird die /etc/rc.local -Datei standardmäßig nicht mehr verwendet. Rufen Sie dies also an einem Terminal auf:

sudo systemctl edit --full rc-local

Was einen Editor öffnet. Am Ende der Datei habe ich hinzugefügt:

[Install]
WantedBy=multi-user.target

Diese Änderungen werden von

aktiviert
sudo systemctl reenable rc-local

Nun wird die Datei /etc/rc.local verwendet, wie Sie es kennen.

3. deaktiviere blueman-applet beim Start

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/blueman.desktop
gnome-session-properties

Nun ist das blueman-applet sichtbar und Sie können es von Startprogrammen aus deaktivieren

4. Starten Sie neu, um den Effekt zu sehen

    
rubo77 10.11.2015 13:29
quelle
4

Sie können Ihre update-rc.d -Einstellungen bearbeiten. Ich habe etwas ähnlich wie:

verwendet
sudo update-rc.d bluetooth remove

In Debian Wheezy. Weitere Informationen zur Verwendung finden Sie in man update-rc.d .

    
Keith Smiley 13.02.2013 16:50
quelle
2

Vielleicht können Sie es in den Startup-Anwendungen ausschalten. Diese Anwendungen sind jedoch standardmäßig ausgeblendet. Blenden Sie die versteckten Startup-Anwendungen in 12.04 ein: Öffnen Sie das Terminal und führen Sie diese beiden Befehle aus:

cd /etc/xdg/autostart/

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Jetzt können Sie Bluetooth deaktivieren. (Nicht entfernen!)

    
schiemanski 05.05.2012 10:50
quelle
2

Nein. Es ist nicht immer in der Startup-Anwendungsliste. Ich denke, dass die beste Lösung darin besteht, den Befehl rfkill im Skript rc.local hinzuzufügen oder den Parameter InitiallyPowered in /etc/bluetooth/main.conf zu setzen.

    
Robert 05.05.2012 02:06
quelle
2

1) Installieren Sie das Paket smbios-utils und fügen Sie es mit

zu Startup Applications hinzu
sudo smbios-wireless-ctl --bt 0

2) Im Terminaltyp:

sudo visudo

und fügen Sie das Ende der geöffneten Datei /etc/sudoers die Zeile:

hinzu
<your username> ALL = NOPASSWD: /usr/sbin/smbios-wireless-ctl

3) Um Bluetooth während der Sitzung einzuschalten, führen Sie im Terminal:

sudo smbios-wireless-ctl --bt 1

Das funktioniert bei mir auf meinem Dell D630 mit Ubuntu 13.10

    
victor 15.03.2014 16:58
quelle
2

Unter Ubuntu 16.04 habe ich einfach den Start des Dienstes mit systemctl deaktiviert.

Öffnen Sie dazu ein Terminalfenster und geben Sie Folgendes ein:

sudo systemctl disable bluetooth

Sie können entweder neu starten, da Bluetooth jetzt nicht mehr gestartet werden kann, oder wenn Sie nicht neu starten wollen und Bluetooth sofort beenden möchten, können Sie Folgendes eingeben:

sudo service bluetooth stop

    
Ken 22.08.2017 05:57
quelle
2

Wir können den automatischen Bluetooth-Start auf diese Weise deaktivieren:

sudo gedit /etc/bluetooth/main.conf

( gedit ist mein Favorit-Editor, Sie können dies durch xed oder was immer auf Ihrem System installiert ist ersetzen.)

Ganz unten in dieser Datei befindet sich diese Zeile:

#AutoEnable=false

Dekomprimieren Sie es wie folgt:

AutoEnable=false
    
Shayan 20.02.2018 15:47
quelle
1

Ich benutze den Sputnik Kernel , der dies auf meinem Dell Inspiron 14R N4110 behoben hat.

    
Alex Wiedermann 25.09.2012 01:53
quelle
1

Ich denke, du solltest

bearbeiten
/etc/default/bluetooth

und stellen Sie

ein
BLUETOOTH_ENABLED=0

zum Deaktivieren des Bluetooth-Dienstes beim Booten

    
Fabio 06.03.2014 21:17
quelle
1

Wenn die Zeile rfkill block bluetooth (oder eine andere Zeile) in /etc/rc.local nicht funktioniert, versuchen Sie, dieselbe Zeile am Ende von ~/.bashrc

einzufügen

In meinem Setup (Ubuntu 14.04, Thinkpad W540) funktionierte keine Option in /etc/rc.local , aber die erste funktionierte in bashrc. Beachten Sie, dass dies nur für den aktuellen Benutzer und nicht global für alle Benutzer funktioniert.

    
Sam 19.10.2014 14:10
quelle
1

Unter Ubuntu Studio 16.04 können Sie das Bluetooth Applet beim Start in:

deaktivieren
  

Sitzung und Start & gt; Anwendung Autostart & gt; Bluetooth Applet

Hier können Sie in das Feld klicken, um es zu deaktivieren.

    
ateymuri 26.08.2016 20:05
quelle
0

Ich füge

hinzu

"/etc/init.d/bluetooth stop"

in

"/etc/rc.local" 

vor dem Befehl "exit 0" für das Booten mit ausgeschaltetem Bluetooth.

    
Saeed Zarinfam 23.08.2012 15:05
quelle
0

Lösung für mein Notebook

"BIOS - USB-Konfiguration - EHCI2: Deaktiviert"

EHCI1 ist für USB-Ports (eigentlich Mein Notebook hat 2 USB 2.0 Ports)

    
MSP 27.03.2014 19:46
quelle
0

Bearbeiten /etc/default/grub :

sudo nano /etc/default/grub

und ändern Sie die folgende Zeile:

GRUB_CMDLINE_LINUX=""

, um dies stattdessen zu sagen:

GRUB_CMDLINE_LINUX="bluetooth.blacklist=yes"

Aktualisieren Sie dann grub und reboot:

sudo update-grub
    
mchid 21.09.2015 07:58
quelle
0

Dies sollte Bluetooth davon abhalten, auf Debian-basierten Systemen zu starten:

sudo chkconfig bluetooth off

oder auf RedHat-basierten Systemen

systemctl disable bluetooth.service
    
Stanislav 16.10.2017 22:18
quelle
0

Wenn Sie das Bluetooth-Applet im oberen Bereich (blueman-applet) verwenden, hat es eine eigene Einstellung, die Bluetooth automatisch einschaltet, auch wenn Sie es an anderen Orten (wie / etc / bluetooth / main) deaktiviert haben .conf oder / etc / default / tlp).

Um zu verhindern, dass Bluetooth beim Start über die Befehlszeile aktiviert wird:

gsettings set org.blueman.plugins.powermanager auto-power-on false

Oder über die GUI:

  1. Klicken Sie auf das Bluetooth-Applet & gt; Plugins & gt; PowerManager & gt; Konfiguration
  2. Deaktivieren Sie Automatisches Einschalten

Beim nächsten Neustart bleibt das Bluetooth-Applet weiterhin sichtbar, Bluetooth ist jedoch deaktiviert. Um es einzuschalten:

Klicken Sie auf das Bluetooth-Applet & gt; Bluetooth einschalten

    
bmaupin 27.07.2018 19:12
quelle
-1

Ich musste eine Brute-Force-Methode verwenden, um zu verhindern, dass Bluetoothd beim Booten automatisch gestartet wird. Ich habe die ausführbare Datei umbenannt, sodass sie nicht gefunden wurde.

    
bluesdiva2001 06.07.2012 03:02
quelle
-1

Sie können auch diese Grafikanwendung verwenden, die auch diesen Bluetooth-Manager

ausführt     
deFreitas 27.12.2014 14:26
quelle
-3

Sie müssen es in der Liste Anwendungen starten in den Systemeinstellungen deaktivieren.

Klicken Sie auf das Zahnrad in der oberen rechten Ecke der Menüleiste und wählen Sie Systemeinstellungen.

Klicken Sie auf Anwendungen starten, dann scrollen Sie nach unten, bis Sie die Bluetooth-Einstellung finden, nehmen Sie das Häkchen aus dem Kästchen und Sie sind fertig.

    
Mark Rooney 16.10.2011 23:13
quelle

Tags und Links