Wie deaktiviere ich die Gastsitzung?

180

Wie deaktiviere ich die Gastsitzung in Ubuntu 11.10 oder höher? Ich möchte nicht, dass die Leute meinen Computer benutzen können, ohne ein Passwort zu benutzen, um sich anzumelden!

    
Jeremy Bicha 22.09.2011, 17:45

12 Antworten

116

Aktualisiert: 2016-Aug

Für Ubuntu 16.04 LTS (15.10 oder später)

Angepasst von: LightDM Ubuntu Wiki - Konfiguration

  • Die vom System bereitgestellten Konfigurationsdateien in /usr/share/lightdm/ sind nicht dazu gedacht, benutzerdefinierbar zu sein. Stattdessen sollten Benutzer verwenden: /etc/lightdm/
  • Neuere Versionen von LightDM (Ubuntu 15.10 oder höher) verwenden [Seat:*] anstelle von [SeatDefaults]

Führe das (einmal) am Terminal aus:

sudo sh -c 'printf "[Seat:*]\nallow-guest=false\n" >/etc/lightdm/lightdm.conf.d/50-no-guest.conf'

Zum Rückgängigmachen (Wiederherstellen der Guest-Option), Entfernen Sie die erstellte Datei :

sudo rm /etc/lightdm/lightdm.conf.d/50-no-guest.conf

Für Ubuntu 14.04 LTS (bis 15.04)

Adaptiert von: Ubuntu-Foren - Speicherort der lightdm-Konfigurationsdateien in 14.04

Führe das (einmal) am Terminal aus:

sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-guest.conf'

Sie werden bei Ihrer nächsten Anmeldung nicht mehr die Option "Gast" als Anmeldeoption verwenden.

Zum Rückgängigmachen (Wiederherstellen der Guest-Option), Entfernen Sie die erstellte Datei :

sudo rm /usr/share/lightdm/lightdm.conf.d/50-no-guest.conf

Für Ubuntu 12.04 LTS (bis 13.10)

Einfachste Methode.

Führe das (einmal) am Terminal aus:

sudo /usr/lib/lightdm/lightdm-set-defaults -l false

Sie werden bei Ihrer nächsten Anmeldung nicht mehr die Option "Gast" als Anmeldeoption verwenden.

  • Dies fügt allow-guest=false einfach an /etc/lightdm/lightdm.conf an.

  • Sollte ab 11.10 funktionieren (da diese auch LightDM verwenden).

Rückgängig machen (Gast-Option wiederherstellen):

sudo /usr/lib/lightdm/lightdm-set-defaults -l true
    
david6 28.07.2012, 01:38
113
  

Verwenden Sie diese Methode nur, wenn Sie Ubuntu Desktop verwenden. Wenn Sie eine andere Version wie Xubuntu oder Lubuntu verwenden, lesen Sie stattdessen diese Antwort .

Wenn Sie das Standard-LightDM verwenden, bearbeiten Sie /etc/lightdm/lightdm.conf so, dass es so aussieht:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Wenn Sie GDM verwenden (was in früheren Ubuntu-Versionen der Standard war), deinstallieren Sie gdm-guest-session .

Für Ubuntu 13.10 bis 14.10 wurde die Datei in /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

verschoben

Für Ubuntu 14.10 oder höher wurde die Datei verschoben /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

    
Jeremy Bicha 22.09.2011 17:48
23

Geben Sie dies in das Terminal ein

gksu gedit /etc/lightdm/lightdm.conf

Sie werden folgendes sehen:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu

Fügen Sie allow-guest=false zum Ende hinzu, damit Ihr Endergebnis wie folgt aussehen sollte:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Speichern Sie das Dokument und beenden Sie den Texteditor.

Starten Sie den Terminalmanager im Terminal neu. (Dadurch wird die grafische Anmeldesitzung beendet und alle laufenden Programme sofort beendet. Stellen Sie daher sicher, dass Ihre Arbeit - wie bei allen geöffneten Dokumenten - zuerst gespeichert wird!)

sudo restart lightdm

Nach Beendigung der grafischen Anmeldesitzung kehren Sie zum Anmeldebildschirm zurück, wo Sie bemerken, dass das Gastkonto deaktiviert ist.

Das ist es - das Gastkonto ist nicht mehr verwendbar.

    
sarveshlad 25.10.2011 03:08
16

Sie können das mit Ubuntu Tweak tun.

Um es zu installieren, verwenden Sie diese Befehle:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Navigieren Sie nach der Installation zu Tweaks Anmeldeeinstellungen und deaktivieren Sie das "Gastkonto".

    
Eliran Malka 21.10.2012 19:54
11

Einfach ausführen

gksudo gedit /etc/lightdm/lightdm.conf

Fügen Sie die folgende Zeile hinzu

allow-guest=false

Dann (dies wird Sie sofort abmelden und alle Programme beenden, die in Ihrer grafischen Sitzung laufen, also speichern Sie Ihre Arbeit zuerst):

sudo restart lightdm
    
LnxSlck 27.07.2012 18:42
3

Fügen Sie für Ubuntu 13.10

hinzu
allow-guest=false

in die Datei /etc/lightdm/lightdm.conf.d/10-ubuntu.conf .

    
uahummer 20.10.2013 15:27
3

13.04 und später

  1. Führe diesen Befehl in einem Terminal aus

    sudo /usr/lib/lightdm/lightdm-set-defaults -l false
    
  2. Starten Sie Ihren Computer neu oder starten Sie lightdm mit dem folgenden Befehl
    (Dadurch werden Sie sofort abgemeldet, speichern Sie Ihre Daten)

    sudo restart lightdm
    

Anscheinend funktioniert es in 13.10 (kann mich nicht testen, aber es gibt einen Kommentar hier ).

Ich benutze 13.04 und all dies fügt allow-guest=false an /etc/lightdm/lightdm.conf an, aber es könnte in 13.10 anders sein.

Ursprünglich von david6 von hier: Lien

    
kiri 21.10.2013 09:33
3

Wie Sie diese Option in Zukunft deaktivieren

Ich habe gerade das gleiche Problem bei meiner neuen trusty / 14.04-Installation festgestellt. Auch zu meiner Überraschung konnte ich den Ordner lightdm.conf.d nicht in /etc/lightdm/ nur users.conf finden.

Untersuchung

$ find / -iname *lightdm* 2>/dev/null | grep -v /mnt | grep -v /media | grep -v /home
[...]
/usr/share/lightdm/lightdm.conf.d
[...]

Aha, da bist du. Was ist da drin?

$ ls -1 /usr/share/lightdm/lightdm.conf.d/
50-greeter-wrapper.conf
50-guest-wrapper.conf
50-ubuntu.conf
50-unity-greeter.conf
50-xserver-command.conf

Okay, was ist da drin?

$ cat /usr/share/lightdm/lightdm.conf.d/*
[SeatDefaults]
greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
[SeatDefaults]
guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
[SeatDefaults]
user-session=ubuntu
[SeatDefaults]
greeter-session=unity-greeter
[SeatDefaults]
# Dump core
xserver-command=X -core

Fazit

Wir finden eine Reihe von Konfigurationsdateien, die dem INI-Format ähneln und dem Benennungsschema von 50-${some-descriptive-name}.conf und den konfigurierenden Schlüsseln folgen für den Abschnitt [SeatDefaults] .

Wir werden keine dieser Dateien bearbeiten , da diese vom Paketmanager verwaltet werden sollen, aber jetzt sollten wir unsere Benutzerdefinierte Konfigurationsbits für /etc .

Lösung

Da Lightdm der Displaymanager ist, sehen die Konfigurationsdateien wie oben aus. Die folgende Lösung sollte funktionieren:

  1. Erstellen Sie die fehlenden Verzeichnisse:

    $ sudo mkdir -p /etc/lightdm/lightdm.conf.d
    
  2. Fügen Sie eine benutzerdefinierte Konfigurationsdatei hinzu, indem Sie Folgendes ausführen:

    $ sudo nano /etc/lightdm/lightdm.conf.d/50-disable-guest-session.conf
    

    und fügen Sie die folgenden Zeilen ein:

    [SeatDefaults]
    allow-guest=false
    

    Dann speichere ( Strg + O ) und schließe ( Strg <+ X

    )
  3. Melden Sie sich jetzt ab und wechseln Sie zu einem virtuellen Terminal ( Strg + Alt + F1 ), und führen Sie dann:

    aus
    $ sudo service lightdm restart
    

    Die Option für die Gastsitzung sollte jetzt nicht mehr vorhanden sein. Wenn etwas nicht richtig funktioniert, wissen Sie jetzt, wo die Standardkonfiguration gespeichert ist und die Sie nicht geändert haben.

Weiter lesen

LiveWireBT 16.03.2014 03:32
2

Installiere ubuntu-tweak, gehe zum Tweak-Tab, schalte den Gast-Button aus und starte neu. Das ist es!

Man mag das Terminal leichter finden, aber falls das Gastkonto aktiviert werden muss, müsste man diese Seite erneut besuchen und die Anweisungen sehen (oder eher rückgängig machen). Das ist der Vorteil der GUI-Sache ... man erinnert sich leicht daran.

    
tadatma 27.09.2012 19:33
2

Ändern Sie allow-guest=true in 'false' in /etc/lightdm/lightdm.conf

Sie können den Dienst dann entweder im Terminal neu starten oder neu starten:

sudo restart lightdm

Angenommen, Sie verwenden lightdm , das Standard in 11.10 ist.

    
filescraps 21.10.2011 12:42
0

Ich bin in dem gleichen Fall, die Datei /etc/lightdm/lightdm.conf existiert nicht in UBUNTU 13.10.

Ich versuche, die Datei /etc/lightdm/lightdm.conf mit dieser Zeile allow-guest=false zu erstellen, und CRASH, das System startet nicht richtig, nur Konsolenmodus ...

Ich versuche die Datei /etc/lightdm/lightdm.conf.d/10-ubuntu.conf zu bearbeiten und funktioniert ordnungsgemäß.

Bearbeiten Sie die Datei

sudo vim /etc/lightdm/lightdm.conf.d/10-ubuntu.conf

Geben Sie die benötigten Zeilen ein

# to disable guest login
allow-guest=false
# to enable user login manually
greeter-show-manual-login=true

Und die letzte, starten Sie Ihr System neu

sudo reboot

Ich denke, das funktioniert gut, wenn Sie nur den ligthgdm

neu starten
sudo service lightdm restart
    
Foncu 23.10.2013 16:05
0

Terminal öffnen

gksudo gedit /etc/lightdm/lightdm.conf

Fügen Sie die folgende Zeile hinzu

allow-guest=false

Speichern und beenden Sie die Datei.

    
scouser73 21.10.2013 09:29

Tags und Links