Wifi funktioniert nach dem Suspendieren nach 16.04 nicht mehr

135

Diese spezielle Version der "funktioniert nach dem Suspendieren nicht" kam nach dem Upgrade auf 16.04. Anscheinend enthält das Upgrade ein Wicd-Applet (hinzugefügt neben dem regulären Netzwerksymbol zur Metacity Classic Gnome-Taskleiste), scheint aber nach einem Suspend nicht zu funktionieren. Ein sudo service network-manager restart dupliziert dieses Problem. Es dauert einen kompletten Neustart, um Wifi wieder in Gang zu setzen. Irgendwelche Ideen warum?

    
147pm 23.04.2016, 13:42
quelle

10 Antworten

161

16.04 läuft auf systemd. Versuchen Sie Folgendes:

sudo systemctl restart network-manager.service

Wenn dies funktioniert, können Sie ein Skript erstellen, um es zu automatisieren.

Öffnen Sie ein Terminal und geben Sie Folgendes ein:

sudo nano /etc/systemd/system/wifi-resume.service Fügen Sie nun das Skript mit einem Rechtsklick ein. Beenden Sie mit STRG + X und drücken Sie zum Speichern Y. Jetzt aktivieren Sie es: sudo systemctl enable wifi-resume.service

Skript:

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Ich hoffe, das hilft. Es funktioniert auf meinem Laptop.

    
Joakim Koed 23.04.2016 15:17
quelle
13

Dasselbe gilt für ein Lenovo X230. Passiert nicht nach jedem Aussetzen, aber manchmal.

sudo systemctl restart network-manager.service 

behebt das Problem.

    
Martin 24.04.2016 15:29
quelle
10

@ 147pm Haben Sie das jemals zum Laufen gebracht?

Ich hatte ein ziemlich ähnliches Problem, obwohl ich Kubuntu 16.10 (KDE-basiert, nicht Gnome) und ein HP ProBook-Notebook habe. Und im Gegensatz zu Ihnen ist nicht mein WLAN nach dem Suspendieren / Aufwachen gestorben, sondern mein Ethernet-Port. Trotzdem frage ich mich, ob sie verwandt sind.

Ich sehe auch, dass Sie das Problem unter KDE nicht haben. Aber ich würde gerne wissen, ob die Lösung unten unter Gnome hilfreich ist, da die Lösung nicht auf Window-Manager, Desktop-Umgebung oder Applets basiert.

Erstens, um den Neustart des Network Manager-Dienstes zu bestätigen.

$ sudo systemctl restart network-manager.service

hat für mich nicht funktioniert.

Ich habe jedoch eine Antwort gefunden, die dank der Frage und der Info von buzhidao unter funktioniert Es kann keine Verbindung zum Internet hergestellt werden, nachdem Suspend und GAD3R dort einen Kommentar abgegeben haben.

Anhand ihrer Informationen habe ich zuerst herausgefunden, welche Ethernet-Hardware und welcher Treiber / welches Modul ich gerade ausführte, und dann dieses Modul entfernte und erneut installierte, was für mich funktionierte (obwohl es nicht für buzhidao war):

WLAN:

$ lspci -knn | grep Net -A2

Ethernet:

$ lspci -knn | grep Ether -A2

Das zweite davon (Ethernet) war das, was ich verwendet habe, und ich habe gefunden:

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
        Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:1944]
        Kernel driver in use: r8169
        Kernel modules: r8169

Also habe ich den 'r8169' Treiber neu installiert:

$ sudo rmmod r8169 && sudo modprobe r8169

und voila! Das hat funktioniert. Mein Ethernet-Port / meine Ethernet-Verbindung wurde nach dem Suspend / Wakeup wieder hergestellt, ohne dass ein Neustart erforderlich war.

(Ich hatte auch KEIN Realtek-WLAN-Gerät, sondern ein Qualcomm Atheros (mod: ath9k), das vielleicht erklärt, warum WLAN nach dem Aufwachen von Suspendierung weiterhin für mich arbeitete.)

Wie Sie meinem Kommentar zu diesem anderen Beitrag entnehmen können, habe ich mich gefragt, ob das Problem das gemeinsame Element zwischen Buzhidao und mir ist: Realtek Semiconductor Devices. Obwohl sie unterschiedliche Module verwenden, haben sie möglicherweise einen gemeinsamen Code? Oder wird der neuere Kernel-Code jetzt irgendwie anders behandelt?

Haben Sie selbst ein Realtek-basiertes WLAN-Gerät? (mit lspci oben)? Haben Sie Glück, das Modul erneut zu installieren (rmmod / modprobe oben)?

Wie auch immer, nur ein Schuss im Dunkeln. Wenn Sie eine eventuelle Antwort für sich gefunden haben, teilen Sie uns dies bitte mit! Thx.

    
androclus 16.03.2017 23:40
quelle
6

Um NetworkManager nach dem Fortsetzen in einer Umgebung ohne sudo -Zugang automatisch neu zu starten, erstellen Sie ein Skript in /etc/pm/sleep.d (beliebiger Name), legen Sie das ausführbare Bit über chmod +x fest und fügen Sie den folgenden Inhalt ein:

case "" in
    resume|thaw)
        # systemctl restart network-manager.service
        service NetworkManager restart
;;
esac

Für mich hat die Zeile service funktioniert, aber systemctl funktioniert möglicherweise besser für Sie.

Quelle: Link .

    
krlmlr 05.11.2016 08:50
quelle
2

Für mich scheint das zufällig zu sein, aber manchmal trennt sich das WLAN nur, wenn ich verbunden bin, oder zeigt keine Netzwerke an, wenn ich nicht bin. Manchmal scheint es, als würde mein Laptop in den Ruhezustand versetzt, aber nicht immer.

Einige Kombinationen davon machen es normalerweise wieder ohne Neustart:

  • sudo iwlist $(ifconfig | grep -Po '^w\w+') scan
  • sudo service network-manager stop; sleep 5; sudo service network-manager start
    • Einfach nur restart anzurufen, scheint für mich nicht zu funktionieren. Es sieht so aus, als würde es versuchen, es zu starten, bevor es fertig ist, es herunterzufahren. Daher habe ich mehr Glück zwischen stop und start .
  • Schalten Sie das WLAN in der Benutzeroberfläche aus. warte ein paar Sekunden; schalten Sie es wieder ein

Keine davon scheint durchgängig zu funktionieren, aber ich habe sie zuerst in der Reihenfolge ihres wahrscheinlichsten Erfolgs aufgelistet.

    
redbmk 20.12.2016 17:07
quelle
2

Arbeitsmethode unter Ubuntu 16.04:

Erstellen Sie den Service: sudo nano /lib/systemd/system/wifi-resume.service

Der Dienst ruft das Programm auf:
/etc/init.d/network-manager

Fügen Sie den Code ein:

#/lib/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart network-manager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target 

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Dann aktivieren Sie den Dienst:

sudo systemctl enable /lib/systemd/system/wifi-resume.service

Dadurch werden die Symlinks in die angegebenen [Install] -Verzeichnisse von / etc / systemd / system erstellt und der Dienst aktiviert

Anschließend können Sie den Status mit: systemctl status wifi-resume.service

überprüfen     
cryptoboy 23.01.2017 01:59
quelle
1

Ich hatte das gleiche Problem mit Bluetooth: Nach dem Suspendieren funktionierte meine Bluetooth-Maus nicht. Also habe ich die Lösung von oben hergeleitet:

sudo nano /etc/systemd/system/bluetooth-resume.service

hat den neuen Dienst aktiviert

sudo systemctl enable bluetooth-resume.service

und bearbeitete den Dienst

#/etc/systemd/system/bluetooth-resume.service
#sudo systemctl enable bluetooth-resume.service
[Unit]
Description=Restart bluethooth at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart bluetooth.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Ich habe auch versucht zu bearbeiten ...

sudo nano /etc/bluetooth/main.conf

und geändert

AutoEnable=true

ABER dies funktionierte NICHT für das "Resume-Problem" und hatte ohnehin keine Auswirkungen auf neue Bluetooth-Geräte!

    
apos 31.08.2016 13:11
quelle
1

Ich hatte das gleiche Problem auf meinem Laptop Dell Inspiron 15R mit Ubuntu 16.04. Für mich arbeitete das Skript, das in der zweiten Antwort angegeben ist .

Nachdem ich das Skript installiert hatte, habe ich die Aufhängung mit dem Befehl im oberen rechten Menü ausprobiert und sogar die Lippe geschlossen, um das Problem zu lösen.

Ich muss sagen, dass das Problem in seinem Verhalten abwechselnd war (das heißt, manchmal funktionierte es vor der Installation des Skripts).

    
Alessandro D'lncal 18.01.2017 15:58
quelle
0

Für mich bestand die Lösung darin,

auszuführen
nmcli nm sleep false

in einem Terminal

    
tigerjack89 08.04.2017 13:01
quelle
0

Ich hatte dasselbe Problem, nachdem ich mich mit dem WLAN-Anschluss nach dem Suspend-Modus verbunden hatte. Versuchte die verschiedenen anderen vorgeschlagenen Antworten, die gelegentlich funktionieren würden, aber nicht immer.

Eventuell erlaubte der folgende Fix eine konsistente Verbindung zum WLAN:

1) Bearbeiten Sie diese Datei:

sudo vim /etc/NetworkManager/NetworkManager.conf

2) Indem Sie dies hinzufügen:

[device]
wifi.scan-rand-mac-address=no
    
Ray Vega 28.03.2018 08:09
quelle
0

Jetzt wahrscheinlich einfach

sudo apt update
sudo apt upgrade

sollte funktionieren.

In meinem Fall unter den aktualisierten Paketen gab es bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.3) und nach diesem Update funktioniert WLAN erneut.

    
Daniel 05.08.2018 07:08
quelle