16.04 LTS WLAN-Verbindung Probleme mit Realtek-Adapter

116

Ich habe nach der Installation von 16.04 LTS mehrere Probleme mit der WLAN-Verbindung festgestellt.

Erstens stellt Wi-Fi nach dem Schlafen oder Ruhezustand normalerweise keine Verbindung wieder her. Manchmal wird das Netzwerksymbol nach dem Aufwachen zu einem "Pfeil nach oben und unten" (ich weiß nicht, wofür es ist), aber es ist immer noch verbunden. Manchmal ist das Netzwerk einfach verloren und es wird kein Netzwerk in der Liste angezeigt, so dass es überhaupt keine Möglichkeit gibt, WLAN zu benutzen.

Ich habe zuerst versucht, den Netzwerkmanager neu zu starten, indem ich sudo service network-manager restart ausgeführt habe. Es funktionierte, war aber keine dauerhafte Lösung.

Nach einem anderen Thread habe ich SUSPEND_MODULES="iwlwifi" zu

hinzugefügt
/etc/pm/config.d/config

Nach diesem Vorgang scheint das Problem der erneuten Verbindung behoben zu sein (es kann automatisch wieder verbunden werden und das Symbol ändert sich nicht mehr). Ich stelle jedoch fest, dass die WLAN-Verbindung zufällig verloren geht (etwa alle 30 Minuten), selbst wenn der Computer läuft Das Netzwerk-Symbol bleibt verbunden, wenn die Verbindung unterbrochen wird.

Ein weiteres Problem nach dem Hinzufügen des Codes ist, wenn ich meinen Computer in den Ruhezustand versetzt habe, wird der Bildschirm für eine Sekunde ausgeschaltet, schaltet sich dann aber für etwa 5 Sekunden wieder ein (währenddessen unterbricht das System die WLAN-Verbindung). Und dann wird der Computer nach diesem ungewöhnlichen "Zwei-Phasen" -Prozess schlafen gehen.

Bitte finden Sie die Informationen zu den Wireless Cards unter

*-network               
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: [email protected]:02:00.0
       logical name: wlp2s0
       version: 00
       serial: b0:c0:90:5c:1c:d5
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.4.0-21-generic firmware=N/A ip=192.168.0.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 ioport:d000(size=256) memory:df200000-df203fff

00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 730] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK208 HDMI/DP Audio Controller (rev a1)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
03:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller (rev 01)

05/01/2016 Aktualisierung: Ich weiß nicht, was passiert ist, aber das Problem wird jetzt schlimmer. Wifi-Verbindung wird etwa alle 5 Minuten verloren und ich muss den Netzwerk-Manager erneut verbinden oder neu starten.

    
Lixu 25.04.2016, 07:13

9 Antworten

43

Endlich konnte ich die Probleme beheben, nachdem ich verschiedene Methoden ausprobiert hatte.

  1. Erhalten Sie Details zu Ihrer PCI-WLAN-Karte, indem Sie sudo lshw -class network ausführen.
  2. Holen Sie sich Ihre Kartenmodellinformationen entsprechend der Produktlinie.
    Zum Beispiel, wie Sie in der Beschreibung der Frage sehen können, heißt es: product: RTL8723BE PCIe Wireless Network Adapter , also ist das Modell meiner Karte RTL8723BE

    Oder product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller , also ist das Modell meiner Karte RTL8101/2/6E

  3. Geben Sie die Berechtigung sudo chmod 755 /etc/pm/config.d/

  4. ein
  5. Öffnen oder erstellen Sie config und fügen Sie SUSPEND_MODULES="rtl8723be" hinzu (ersetzen Sie rtl8723be durch Ihre eigene Modellnummer)
    Dann führe
    echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
    aus (Beachte, dass wenn ich rtl8723be durch meine Karte ersetze, die RTL8101/2/6E ist, sollte ich nur .../modprobe.d/RTL8101.conf eingeben und /2/6E sollte nicht geschrieben werden)

Starten Sie Ihr System endgültig neu.

Nun sollte Ihr System nach dem Schlaf wieder automatisch verbunden werden können, und die WiFi-Verbindung ist für mich nie wieder verloren gegangen.

"Die Pfeile nach oben / unten sind wahrscheinlich ein Fehler des Netzwerkmanagers, der dazu führt, dass der Netzwerkmanager denkt, dass das WLAN-Gerät tatsächlich Ethernet ist.", so Jeremy31. siehe Fehlerinfo hier Sie sollten es beheben können, indem Sie NetworkManager-1.2.0 installieren.

Danke an Jeremy31 für die Bereitstellung der Lösungen.

    
Lixu 06.05.2016, 05:09
37

Ich habe genau das gleiche Problem. Nach dem Aufwachen funktioniert WLAN zwar noch, aber Netzwerke werden nicht angezeigt. Ich löse das Problem, indem ich den Netzwerkmanager neu starte.

sudo service network-manager restart

Immer noch sehr nervig. Ich hoffe, sie beheben dieses Problem bald.

    
eldosoa 28.04.2016 06:25
30

Das ist sicher ein Fehler. Fehler wurde bei eingereicht Pfandrecht

    
Shinjan 02.05.2016 19:22
10

Zusätzliche Information: Ich habe das gleiche Problem wie OP beschreibt, aber nur das Problem, wo das nm-Applet-Icon zu Pfeilen wechselt und keine WLAN-Informationen anzeigt. Das WiFi funktioniert immer noch, wenn dies passiert.

$ killall nm-applet && nm-applet & 

Führt den Trick aus, um das Symbol wieder anzuzeigen, also ist es nur ein Workaround für den Fall, dass jemand es in ein Skript einfügen möchte.

Kann dieses Problem auf zwei separaten Computern mit dem xubuntu-desktop-Paket bestätigen.

Auch auf beiden Computern habe ich kürzlich Intel-WLAN-Karten laufen lassen. (etwas in der Art von AC-7260)

    
Joel Cressy 26.04.2016 04:40
6

Ich hatte das gleiche Problem. Ich habe das Problem mit dem Suspend-Wake behoben, indem ich dieses Script unter /etc/systemd/system/wifi-resume.service erstellt habe (dasjenige, das vom OP veröffentlicht wurde, funktionierte nur für die aktive Sitzung ; beim Neustart musste es erneut aufgerufen werden):

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Dann geben Sie diesen Befehl im Terminal aus, um ihn zu aktivieren: sudo systemctl enable wifi-resume.service . Diese Lösung stammt aus einer weiteren askubuntu-Frage , und funktioniert sowohl nach dem Aussetzen als auch nach dem Neustart.

Aber selbst nachdem das behoben wurde, bekomme ich das gleiche Verhalten wie beim Aufwachen aus dem Suspend, wenn ich versuche, WLAN-Netzwerke zu wechseln : Das WLAN ist im Wesentlichen tot, mit den zwei Pfeilen, und das Applet sagt " Gerät nicht bereit ." Ich kann das wifi neu starten, indem ich sudo service network-manager restart ausstelle, aber ich kann Netzwerke nicht schalten.

Hat das jemand anderes erlebt und / oder eine Lösung?

    
Rsync 29.04.2016 03:20
2

Ich benutze LinxuMint 18 Mate (ubuntu16.04) und bin in dasselbe Problem geraten.

Der ganze Rest oben hat bei mir auf meinem Thinkpad T440S nicht funktioniert.

Die einzige Problemumgehung, die bisher zu funktionieren scheint, ist das Aktualisieren des Kernels auf 4.6.3

  • Gehen Sie zu dieser Website .

  • Erhalte folgende Dateien:

    linux-headers-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    linux-headers-4.6.3-040603_4.6.3-040603.201606241434_all.deb
    linux-image-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    
  • Gehen Sie von einem Terminal zu dem Ordner, der die obigen Dateien enthält, und führen Sie Folgendes aus:

    sudo dpkg -i *.deb
    sudo reboot
    

Wenn Sie Virtualbox verwenden, führen Sie sudo /sbin/vboxconfig

aus

Wenn Sie sie entfernen möchten, führen Sie:

sudo dpkg --purge linux-headers-4.6.3-040603 linux-headers-4.6.3-040603-generic 

Nach einigen weiteren Tests ist die Situation fast die gleiche, ich habe WLAN, aber mein nm-applet kann nicht alle WIFI um mich herum sehen. Also nicht sicher, ob dies eine gute Abhilfe ist: -)

    
SteF 09.08.2016 11:28
2

Im Moment gibt es keine Lösung, aber ich habe ein Skript gefunden, das mir geholfen hat, weiter aufzustehen:

#!/bin/bash

# Ping you most used DNS Server and reconnect on fail


while true; do
  if ! ping -c 1 -w 1 8.8.8.8 > /dev/null; then

    # with "sudo iwconfig" you can examine your name of 'wlan0'
    nmcli d connect wlan0

  fi
  sleep 2;
done

Um dieses Skript automatisch zu starten, öffnen Sie einfach gnome-session-properties und fügen Sie es zur Liste hinzu.

Das vollständige Skript (ohne erneute Verbindung) finden Sie auf dieser Webseite .

    
Steffomio 17.10.2016 21:28
1

Legen Sie den WIFI-Ländercode für die aktuelle regulatorische Domäne des Kernels fest, wenn dieser nicht festgelegt ist

iw reg get

Um es einzustellen

sudo nano /etc/default/crda
REGDOMAIN=<ISOCODE>

Neustart.

    
Janghou 11.05.2016 11:34
1

nur um die akzeptierte Antwort hinzuzufügen (mit vier Schritten)

Aus irgendeinem Grund reichte mir nur ein Schritt, auch wenn ich nicht weiß, was es bedeutet:

echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
    
nyxee 24.09.2017 02:13