Fehler bei der Installation von Steam auf ubuntu 15.04 [duplizieren]

30
[email protected]:~$ steam
Running Steam on ubuntu 15.04 64-bit

STEAM_RUNTIME is enabled automatically

Installing breakpad exception handler for appid(steam)/version(0)

libGL error: unable to load driver: nouveau_dri.so

libGL error: driver pointer missing

libGL error: failed to load driver: nouveau

libGL error: unable to load driver: swrast_dri.so

libGL error: failed to load driver: swrast

Vorher habe ich auch versucht, Steam vom Terminal zu installieren, aber es wurde nach dem Herunterladen des Updates nicht gestartet.

Kann jemand mir helfen, eine Lösung zu finden, Steam zu installieren?

    
Agung Wahyudi 13.06.2015, 06:08

4 Antworten

65

Kurzversion:

Starten Sie den Dampf im Terminal mit:

LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 steam

statt nur steam

Lange Version:

Steam kann nouveau_dri.so nicht öffnen, die gemeinsam genutzte Bibliothek, die für die Kommunikation mit dem Grafiktreiber zuständig ist. Um zu prüfen, ob der Treiber OpenGL aktiviert ist, führen Sie:

DISPLAY=:0 glxinfo | grep -i direct

Die Ausgabe sollte lauten:

direct rendering: Yes

Dampf im Debug-Modus laufen:

DISPLAY=:0 LIBGL_DEBUG=verbose steam

Gibt uns die Ausgabe, wo die folgenden Zeilen uns einen Hinweis geben:

libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/nouveau_dri.so
libGL: dlopen /usr/lib/i386-linux-gnu/dri/nouveau_dri.so failed (/home/user/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6: version 'GLIBCXX_3.4.20' not found (required by /usr/lib/i386-linux-gnu/dri/nouveau_dri.so))

Es scheint, dass Steam eine andere Version von libstdc++.so.6 verwendet. Wir können überprüfen, welche Version von dampf verwendet:

ls -l ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6  

lrwxrwxrwx 1 user user 19 Jul 18  2014 /home/user/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 -> libstdc++.so.6.0.18

Also hat Steam LibC6 mit ABI Version 18 geladen, wo der Treiber Version 20 erwartet. Die Lösung besteht darin, dem Betriebssystem mitzuteilen, dass es die richtige LibC6-Version mit laden soll LD_PRELOAD Variable:

LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 steam

Der etwas nicht-intuitive $ LIB-Parameter wird in ld.so auf den richtigen Pfad basierend auf der Plattform des gestarteten Prozesses erweitert (man 8 ld.so für Details).

Sie können ein Skript mit dem folgenden Inhalt erstellen, um es anstelle von steam :

auszuführen
#!/bin/bash
# Export so all child processes are affected as well
export LD_PRELOAD='/usr/$LIB/libstdc++.so.6'
export DISPLAY=:0
#export LIBGL_DEBUG=verbose
steam

Ein besseres Skript könnte überprüfen, ob die globale LibC6-Version neuer ist als die in STEAM_RUNTIME und nur dann LD_PRELOAD .

Weitere Details finden Sie auf hier . Beachten Sie, dass ich es auf Debian getestet habe und jetzt wurde es auf Ubuntu vivid 15.04 getestet und funktioniert gut.

    
Tahtisilma 16.07.2015 07:39
27

Eine andere Lösung, die mir geholfen hat, Steam-Client zu starten, wurde hier gefunden -

Link

Ich habe diesen Befehl ausgeführt -

find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

und jetzt Steam startet ohne zusätzliche Vorladungen. Hoffe, dies wird jedem helfen, der das gleiche Problem auf Ubuntu 16.04 hat

    
philfaint 21.05.2016 20:07
6

Vielleicht sind die gcc libs in der Steam-Runtime nicht kompatibel mit Ihren mesa -Treibern. Sichern Sie Ihren privaten Ordner und versuchen Sie dann, diese Bibliotheksdateien zu löschen:

rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6
rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1
    
Zivit 24.01.2016 23:14
4

Offensichtlich tritt dieser Fehler auf, wenn man versucht, Steam in einem 64bit Ubuntu 15.04.

zu installieren

Ich habe eine neue Ubuntu 15.04-Installation auf meinem Rechner installiert. Ich habe auch die NVIDIA-eigenen Grafiktreiber installiert.

Ich bekam diesen Fehler, aber nachdem ich genau hinsah, bemerkte ich, dass es sich bei Steam um eine 32bit-Anwendung handelte, also installierte ich einige 32bit-Bibliotheken und installierte den NVIDIA-Treiber neu, sodass Steam gestartet werden konnte. p>

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386
sudo ./NVIDIA-Linux-x86_64-352.63.run

Wo der letzte Befehl Ihr Treiberinstallationsprogramm sein sollte.

Wenn das Installationsprogramm des Treibers bittet, 32-Bit-Bibliotheken zu installieren, klicken Sie auf Ja.

    
McLeary 22.12.2015 22:13

Tags und Links