Verbinden / Trennen von VPN über die Befehlszeile

111

Ich habe zwei VPNs auf meinem Ubuntu-Rechner eingerichtet, einen mit vpnc und einen mit PPTP. Diese wurden beide über die GNOME Network Manager-Benutzeroberfläche eingerichtet und funktionieren hervorragend. Gelegentlich muss ich jedoch remote auf diesen Computer zugreifen. Gibt es eine Möglichkeit, diese VPNs über die Befehlszeile zu verbinden oder zu trennen?

    
Tim Fountain 16.08.2011, 17:15

2 Antworten

161

Wenn Sie über die Befehlszeile mit NetworkManager interagieren möchten, können Sie den Befehl "nmcli" verwenden.

listet alle NM-Verbindungen auf: nmcli con

Verbindung starten (wifi, vpn, etc): nmcli con up id ConnectionName

Verbindung nach unten: nmcli con down id ConnectionName

(Weitere nmcli-Befehle in der nmcli-Manpage ).

Beachten Sie außerdem, dass normale Benutzer normalerweise keine Berechtigung zum Steuern des Netzwerks haben. Die Verwendung der obigen Befehle mit sudo sollte für die meisten Verbindungen funktionieren, aber VPN kann speziell mit fehlschlagen. "Fehler: Verbindungsaktivierung fehlgeschlagen: keine gültigen VPN-Geheimnisse."

Wenn Ihnen das passiert, ist es wahrscheinlich, dass das VPN-Passwort im Gnome-Schlüsselring Ihres Benutzers gespeichert ist, so dass es für den Root-Benutzer nicht zugänglich ist. Dieser Kommentar erklärt warum.

Um dies zu beheben, bearbeiten Sie / etc / NetworkManager / system-connections / Verbindungsname und ändern Sie unter [vpn] die Passwort-Flags Zeile zu:

password-flags=0

Wenn es eine Zeile gibt, die mit Xauth password-flags beginnt, ändern Sie sie stattdessen.

Fügen Sie dann Folgendes unter dem [vpn] -Block hinzu:

[vpn-secrets]
password=YourPassword

(Wenn Sie im vorherigen Schritt die Zeile Xauth password-flags geändert haben, fügen Sie stattdessen Xauth password=... hinzu.)

Starten Sie den Netzwerkmanager jetzt neu mit:

sudo service network-manager restart

Dann sollte der Start der VPN-Verbindung mit sudo nmcli con up id ConnectionName ohne Probleme funktionieren.

    
ihashacks 17.08.2011, 05:44
4

Ihashacks 'Antwort mit Matts Kommentaren funktionierte für mich ... fast. Musste eine Zeile optimieren.

meine Passwort-Flag Zeile tatsächlich gelesen: "Xauth Passwort-Flag". Die angenommene Antwort würde für mich nicht funktionieren, bis ich zu folgendem geändert habe

[vpn]
...
Xauth password-flag=0
IPSec secret-flags=0

[vpn-secrets]
Xauth password=<my pw> ## This is the one I changed.
IPSec secret=<group pw>

Nicht sicher, warum meine vpn-Verbindungen "Xauth" vor jeder Erwähnung des Passworts haben.

(Entschuldigung, dies ist eine neue Antwort, kann noch keine Kommentare machen.)

    
John 23.03.2015 06:03