Wie deaktiviere ich Tastenkombinationen für F1 und F10 in gnome-terminal?

115

Wie kann ich die Tastaturbefehle F1 (Hilfe) und F10 (Benachrichtigungsmenü) ausschalten?

Zuerst muss ich das Dienstprogramm screen und dann mc in der Konsole beenden.

In den Tastaturkürzeln Systemeinstellungen gibt es keine solchen Tastenbelegungen.

    
Marko Kevac 27.04.2011, 15:55

14 Antworten

106

11.04

Deaktivieren der F1-Verknüpfung

  1. Öffnen Sie in einem gnome-terminal Bearbeiten ➜ Tastaturkürzel .

  2. Scrollen Sie nach unten zu der Verknüpfung Hilfe / Inhalt , klicken Sie auf die Stelle "F1" und drücken Sie Backspace :

Deaktivieren der F10-Verknüpfung

  1. Installieren Sie den compizconfig-settings-manager Paket.

  2. Öffnen Sie CompizConfig Einstellungsmanager .

    • Drücken Sie Super , um das Dash zu öffnen, geben Sie "Compiz" ein und drücken Sie Enter .
  3. Geben Sie "unity" in den Filter Eintrag ein und wählen Sie das Ubuntu Unity Plugin .

  4. Klicken Sie auf die Schaltfläche rechts neben , um das erste Bedienfeldmenü zu öffnen und deaktivieren Sie das Kontrollkästchen Aktiviert .

  5. Dadurch wurde die globale F10 Verknüpfung deaktiviert, jetzt deaktivieren Sie die Verknüpfung F10 von gnome-terminal:

    • In einem gnome-terminal öffnen Tastaturkürzel ( Bearbeiten ➜ Tastaturkürzel) und
      deaktiviere Aktiviere die Menü-Tastenkombination (standardmäßig F10)

  6. F10 wird von etwas in Ubuntu auf menubar_accel gemappt. Gnom? Metacität? Nicht sicher, was genau es ist, das es stiehlt, aber der Schlüssel kommt nicht zu Eclipse.

    • Führe den gconf-editor aus, navigiere zu / desktop / gnome / interface, scrolle dann runter zu menubar_accel und lösche den F10 Wert. [Gestohlen von hier]
Isaiah 23.06.2011, 20:52
44

Deaktivieren Sie F10 in gnome-terminal in 12.04

Geben Sie Folgendes in die Konsole ein:

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Schließen Sie dann alle Terminalsitzungen. Jetzt sollte es so funktionieren wie es sollte (zB in mc ).

Paweł Gościcki 30.04.2012 21:25
23

start gconf-editor und folge /apps/gnome-terminal/keybindings/help

Beschreibung:

"Tastaturkürzel zum Starten der Hilfe. Wird als Zeichenfolge im selben Format wie für GTK + -Ressourcendateien ausgegeben. Wenn Sie die Option auf die spezielle Zeichenfolge" disabled "setzen, gibt es für diese Aktion keine Tastenkombination."

    
Rinzwind 21.08.2011 22:28
7

Ich bin neu in Linux und dieser F10 Schlüssel macht mich verrückt. Alle obigen Tricks haben nicht funktioniert, aber ich habe jetzt eine Lösung gefunden (für Ubuntu 11.10 mit Gnome 3 classic desktop). Geben Sie in einem Terminal den folgenden Befehl ein:

gsettings set org.gnome.desktop.interface menubar-accel ""

Mit dem dconf-editor kann man feststellen, dass der F10 wirklich weg ist. Beachten Sie, dass diese Art von Tricks stark von Gnome / Ubuntu abhängig zu sein scheint.

    
gast128 29.11.2011 20:34
4

Zum Beenden von mc (mit F10-Taste). Deaktivieren Sie "Schlüssel, um das erste Bedienfeldmenü zu öffnen" im Unity-Compiz-Plugin (ccsm)

    
kholis 29.04.2011 12:33
4

@kholis ist korrekt, F10 in Unity zu deaktivieren, aber wenn Sie ein Newb wie ich sind, benötigen Sie ein wenig mehr Informationen, um das zu erreichen.

Wenn nicht bereits installiert, installieren Sie compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager

Starten Sie den neu installierten Einstellungsmanager und filtern Sie nach "Einheit"

Bearbeiten "Taste, um das erste Bedienfeldmenü zu öffnen", um es zu deaktivieren oder zu einem anderen Schlüssel zu ändern.

Ich habe noch keine Möglichkeit gefunden, F1 zu ändern.

Ryan Sorensen 30.04.2011 19:36
3

Die Anleitung im Pfandrecht (unten zitiert) funktioniert auch in Ubuntu 11.04. (Es scheint F1 sowohl auf dem Desktop als auch im Terminal zu deaktivieren. Das heißt, F1 sendet keine Ansi-Sequenz an die Shell im Terminal, wenn OP das was wollte.)

  
  1. Gehen Sie zu System - Einstellungen - Tastaturkürzel
  2.   
  3. Erstellen Sie eine neue Verknüpfung. Nennen Sie es "nichts tun" und schreiben Sie "falsch"   (ohne Anführungszeichen) im Feld "Befehl". Drücken Sie ok.
  4.   
  5. Scrolle zum Ende der Liste und finde deinen neuen Befehl. Klicken   auf der "Deaktiviert", auf der rechten Seite, und drücken Sie F1.
  6.   
    
David Andersson 22.08.2011 04:12
3

Sie können es einfach deaktivieren, indem Sie CCSM verwenden (Klicken Sie hier, um es zu installieren, wenn Sie es nicht installiert haben ).

Dann gehen Sie zu Desktop - & gt; Ubuntu Unity Plugin - & gt; Taste, um das erste Bedienfeldmenü zu öffnen und es zu deaktivieren oder zu einer anderen Tastenkombination zu ändern.

Hinweis : Es scheint, dass diese Methode in Unity2D nicht funktioniert.

    
Binarylife 27.10.2011 00:03
2

Dies ist ein Tipp für Thnkpad-Benutzer, insbesondere T60. Ordnen Sie die F1-Taste neu, um zu entkommen. Dies beseitigt das lästige Popup der Terminalhilfe, wenn Sie F1 drücken. Sie tun dies oft aufgrund der witzigen Platzierung von ESC auf T60s.

    
ncmathsadist 03.12.2011 18:42
1

Wenn Sie dies nur in Gnome Terminal ändern möchten, können Sie im Terminal auf Bearbeiten> Tastenkombinationen klicken.

    
Jeremy Bicha 30.04.2011 20:37
1

Ich empfehle, F1 als Abkürzung für etwas anderes zu verwenden. Ich benutze Tilda, ein Quake-ähnliches Kommandozeilen-Terminal, und die Standard-Verknüpfung ist F1. Es überschreibt die Hilfe, so dass ich nie Hilfe starten kann, wenn ich F1 drücke. Selbst wenn du Tilda nicht besonders magst, ist es viel mühsamer, F1 zu drücken, um es zu verstecken, als die Hilfe zu schließen, nachdem du sie versehentlich gestartet hast.

    
titaniumtux 03.12.2011 20:23
1

12.04

F1 scheint bei 12.04 nichts aus der Box zu tun.
F10 scheint einen rechten Mausklick zu simulieren Als Antwort auf die Besonderheiten der Frage müssen Sie also Hilfe und Benachrichtigungen nicht deaktivieren.

Sie können sie immer noch auf etwas anderes wie folgt abbilden:
Die Zuweisung von Hotkeys in 12.04 wird einfach über das Tastatur-Widget ausgeführt.

Finden Sie im Unity-Launcher die Tastatur.

In dem sich öffnenden Fenster wählen Sie die Registerkarte Verknüpfungen und benutzerdefinierte Verknüpfungen.
Klicken Sie auf das Plus, um eine neue Verknüpfung hinzuzufügen.

Benennen Sie es so, wie es der Funktionalität entspricht, der Sie es zuweisen.
Geben Sie den Befehl ein, der im Befehl ausgeführt werden soll.

Auf der rechten Seite des Fensters klicken Sie auf, wo es deaktiviert angezeigt wird. Dies sollte zu New Accelerator wechseln.

Jetzt drücke einfach F10 .
Der benutzerdefinierte Beschleuniger, den Sie definiert haben, überschreibt das Simulationsverhalten mit der rechten Maustaste. Sie könnten diesen Befehl auf echo 'nope' > /dev/null setzen, wenn Sie nur wollen, dass Ihr F10 nichts tut.

    
RobotHumans 02.04.2012 19:50
1

12.04 Ohne Einheit - Deaktivieren Sie F1 und F11 Verhalten

Ich habe Ubuntu 12.04 / 64 installiert und Unity nach diesen Anweisungen vollständig entfernt. . Viele der Tools, die das Verhalten von Unity ändern, funktionieren daher nicht. Insbesondere "sieht" CCSM die Tastaturkürzel nicht mehr.

Ich habe festgestellt, dass die Methode, die Edit- & gt; Tastaturkürzel im Terminalfenster verwendet, auch nicht funktioniert hat. Nach ein wenig herumspielen fand ich heraus, dass weiter unten im Fenster Keyboard Shortcuts im Abschnitt Shortcut Keys F1 und F11 immer noch mit ihren jeweiligen Shortcuts definiert waren.

Um das zu beheben,

  1. Klicken Sie auf das "F11" im rechten Feld der Zeile, die definiert F11 als Vollbild. Der Text wird in "Neuer Beschleuniger ..." geändert.

  2. Geben Sie eine andere, weniger anstößige Tastenfolge (wie Alt-F11) und Diese Tastenkombination ersetzt die Verknüpfung. Wenn jemand weiß, wie man "nichts" tippt, lass es uns wissen.

  3. Wiederholen Sie dies für die F1-Taste.

Wes Miller 20.11.2013 17:33
0

Strg + F1 funktioniert auch nicht. Die Lösung ist die gleiche wie für Shift + F10. Das Semikolon als Trennzeichen nicht vergessen!

Platziere dies in ~ / .config / gtk-3.0 / gtk.css:

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10";
     unbind "<control>F1";
}

* {
     gtk-key-bindings: NoKeyboardNavigation;
}
    
egmont 16.03.2014 12:46

Tags und Links