Eclipse-Menüs werden abgeschnitten oder werden nicht angezeigt

84

Ich verwende Ubuntu 13.10 (mit JDK 1.7.0_45).

Ich habe Eclipse Kepler für Java EE-Entwickler heruntergeladen und unkomprimiert

Die Softwaremenüs sind fehlerhaft. Ich habe keine ähnlichen Probleme in anderer Software festgestellt.

Wenn ich in Eclipse auf ein Menü klicke, scheint das Dropdown-Menü "abgeschnitten" zu sein. Manchmal wird das Dropdown-Menü angezeigt, die Optionen sind jedoch nicht sichtbar.

Ich habe Eclipse Indigo ausprobiert, aber das gleiche Problem tritt auf.

    
Ralph Rassweiler 18.10.2013, 15:21

6 Antworten

85

So lösen Sie Eclipse-Menüprobleme in Ubuntu 13.10

(Stabile Art, bis jemand den Fehler behebt)

Diese Methode setzt voraus, dass Sie bereits über Ihre eclipse.desktop -Datei verfügen (oder dass Sie alternativ eine neue erstellen können). Ansonsten können Sie kurz den "schnellen Weg" unten betrachten.

  1. Öffnen Sie Ihre eclipse.desktop -Datei:

    sudo -H gedit /usr/share/applications/eclipse.desktop
    

    (Wenn Sie es in diesem Pfad nicht finden können, probieren Sie es mit ~/.local/share/applications/eclipse.desktop . Andernfalls müssen Sie Ihre mit dem Befehl locate finden).

  2. Ersetzen Sie die Zeile Exec= durch Folgendes:

    Exec=env UBUNTU_MENUPROXY= eclipse
    

    Dabei ist "Eclipse" der Pfad zu Ihrer ausführbaren Eclipse-Datei. In diesem Fall handelt es sich nur um "Eclipse", da sich im Ordner /usr/bin ein Symlink befindet.

    HINWEIS: Wenn Sie Ihre eclipse.desktop -Datei nicht finden können, können Sie im obigen Pfad einfach eine neue Datei erstellen und diese mit folgenden Zeilen füllen:

    [Desktop Entry] 
    Type=Application 
    Name=Eclipse 
    Icon=eclipse 
    Exec=env UBUNTU_MENUPROXY= eclipse 
    Terminal=false 
    Categories=Development;IDE;Java;
    
  3. Speichern Sie die Datei.

Jetzt können Sie Eclipse wie gewohnt über das Symbol ausführen.

(schnell, aber wiederholend)

Wenn Sie keine eclipse.desktop -Datei haben und Sie sie derzeit nicht erstellen möchten, können Sie Eclipse einfach mit folgendem Befehl ausführen:

UBUNTU_MENUPROXY= eclipse

wobei "Eclipse" der Pfad zu Ihrer ausführbaren Datei eclipse ist. Beachten Sie, dass dies nur der schnelle Weg ist, Eclipse einmal auszuführen. Wenn Sie sich nicht an diesen Befehl erinnern und ihn jedes Mal verwenden möchten, wenn Sie Eclipse ausführen, folgen Sie dem oben beschriebenen "stabilen Weg".

Oder Sie können einen Alias daraus machen

alias eclipse = 'UBUNTU_MENUPROXY= eclipse'

und der Befehl eclipse funktionieren einwandfrei.

Quellen:

Kurt Bourbaki 05.11.2013, 12:43
10

Ich hatte das gleiche Problem, meine faulste Lösung ist

  1. Öffnen Sie ein Gnome-Terminal (STRG + ALT + T-Standardverknüpfung)
  2. Problem UBUNTU_MENUPROXY=0 eclipse .

Funktioniert für mich.

    
Abel Melquiades Callejo 12.12.2013 23:33
6

In meinem Fall gab es zwei Versionen der Datei in / usr / share / applications:

eclipse.desktop
Eclipse.desktop

Löschen Sie entweder eine davon oder ändern Sie die Exec-Zeile in beiden, wie oben beschrieben. Die dritte Version der Datei befindet sich im Basisordner:

~/.local/share/applications/Eclipse.desktop

Sie können den letzten Eintrag löschen oder auch die Zeile Exec ändern.

Sie müssen lediglich die Zeile Exec wie folgt ändern:

Exec=env UBUNTU_MENUPROXY= /path/to/eclipse/eclipse
    
Karşıbalı 08.11.2013 13:32
2

Sie müssen eine Datei mit dem Namen eclipse.desktop bearbeiten, um die Option MENUPROXY einzuschließen.

  • Abhängig von Ihrer Installation variiert dieser Speicherort. Um es zu finden, geben Sie sudo find / -name eclipse.desktop ein.
  • Wenn Sie den Ort gefunden haben, öffnen Sie die Datei in Ihrem bevorzugten Editor. Für mich ist dies vim, also gebe ich sudo vim /usr/share/applications/eclipse.desktop ein (Beachten Sie, dass sich Ihr Standort möglicherweise unterscheidet, siehe den ersten Schritt.
  • Suchen Sie in der Datei nach einer Zeile, die in etwa wie folgt aussieht- > Exec=/opt/eclipse/eclipse . (Beachten Sie, dass bei Ihnen möglicherweise nur die "Eclipse" ohne den vollständigen Pfad vorhanden ist.)
  • Nachdem Sie diese Zeile gefunden haben, kommentieren Sie sie aus. Fügen Sie dann diese Zeile hinzu: Exec=env UBUNTU_MENUPROXY= /opt/eclipse/eclipse (Bearbeiten Sie nach Bedarf. Wenn Ihre Installation nicht den vollständigen Pfad hatte oder wenn es einen anderen Pfad hatte, passen Sie hier an). Beachten Sie das Leerzeichen nach MENUPROXY =. Das ist wichtig. 'Starten Sie Eclipse und sehen Sie sich oben wieder Menüs an.
Terry 21.10.2013 17:31
1

Sie können dies versuchen: link Das Menü von Eclipse wird nicht in Unity Global Menu angezeigt. Funktioniert mit mir.

    
Philmagno 18.10.2013 23:26
-1

In meinem Fall existiert die Datei nicht,

Ich musste es in ~/.local/share/applications

erstellen

Erstellen Sie einfach eclipse.desktop mit

Version=4.3.0
Name=Eclipse
Exec=env UBUNTU_MENUPROXY= path=/home/abali/apps/eclipse/eclipse Icon=/home/abali/apps/eclipse/icon.xpm
Terminal=false
Type=Application
Categories=IDE;

Vergessen Sie nicht zu tun

source eclipse.desktop

, dann öffnen Sie Eclipse und es funktioniert einfach.

    
user2030755 26.11.2013 10:12

Tags und Links