Lästiges Flackern in 16.04 LTS - Chrome

194

Ich habe ein Upgrade von 4.4.0 auf 4.4.8 und dann 4.5.2 auf Ubuntu 16.04 LTS 64-bit durchgeführt, und es passiert immer noch.

Bei 4.5.2 ist es noch häufiger und hauptsächlich in Chrome (habe noch nicht Firefox oder Oper versucht). Jedes Mal, wenn ich eine neue Webseite öffne. Irgendeine Möglichkeit, das zu beheben, oder ist es ein Fehler?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 81)

Prost.

    
Mookey 03.05.2016, 08:31

11 Antworten

184

Nach einigen Recherchen fand ich eine Lösung für dieses Problem. Es funktioniert jetzt für mich.

Ich habe die Hardwarebeschleunigung für meinen Browser von

aus deaktiviert

Settings > Advance Settings > System > uncheck the hardware acceleration

Ich hoffe, das funktioniert auf Ihrem Rechner.

Ich verwende google-chrome-stable Version 50.0.2661.94 (64-bit) auf Ubuntu 16.04

----- EDIT ----

Wenn Sie scrollende Verzögerung und Bildschirmabriss feststellen. Machen Sie es wie von Amos Folarin im folgenden Kommentar vorgeschlagen:

Gehe zu: chrome://flags/#smooth-scrolling und aktiviere es.

    
sgiri 05.05.2016, 19:54
158

Ich hatte das gleiche Problem, die GPU-Rasterisierung auf "Für alle Ebenen erzwingen" scheint endlich zu funktionieren:

    
Gondy 08.08.2016 09:52
38

Öffnen Sie ein Terminal und geben Sie folgenden Befehl ein:

sudo nano /usr/share/applications/chromium-browser.desktop

und scrollen Sie nach unten, bis Sie zu dieser Zeile gelangen:

Exec= chromium-browser

Fügen Sie dann diese zwei Parameter hinzu

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Drücken Sie Strg + O zum Speichern und Strg + X zum Beenden.

Geben Sie dann diesen Befehl ein:

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

und füge diese Zeilen hinzu

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Drücken Sie Strg + O und dann Strg + X.

Öffnen Sie Chromium und schreiben Sie in die Adressleiste: chrome://flags/ und geben Sie ein.

  • Nullkopie aktivieren
  • Aktivieren Sie die Software-Renderliste überschreiben
  • Anzeige von 2D-List-Canvas aktivieren

Öffnen Sie abschließend die Chrome Einstellungen und klicken Sie auf:

  • Verwenden Sie die Hardwarebeschleunigung, wenn verfügbar
zafer 27.07.2016 10:10
37

Ich habe es wie folgt behoben:

sudo apt-get purge xserver-xorg-video-intel

dann neu starten. Dies ist darauf zurückzuführen, dass Intel-Treiber in modesetting verschoben wurden. Für weitere Informationen siehe diesen Kommentar im Chromium-Bug-Thread .

    
ComBin 19.08.2016 16:25
24

Keine dieser Antworten schien mir zu helfen. Was ich getan habe, welches scheint es repariert zu haben (Meine Referenz war diese Seite Link die flackerte wie CRAZY und jetzt funktioniert es reibungslos) ist das:

1.- Navigiert zu chrome://gpu/ . Dies ist, was es gezeigt hat:

2.- Ich habe versucht, die Probleme einzeln zu beheben. In meinem Fall hat das Aktivieren dieser Flags einige davon behoben: GPU rasterization , Override software rendering list . Dann zeigte es sich so:

3.- Ich habe den Desktop-Launcher bearbeitet und die Parameter --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers hinzugefügt.

4.- Danach werden keine Probleme mehr erkannt, alles zeigt sich als "hardwarebeschleunigt" und vor allem kein Flimmern mehr:

Wenn Sie zuerst die Parameter zum Launcher hinzufügen, sollte die Liste der Probleme kürzer sein und es wird wahrscheinlich einfacher sein, herauszufinden, welche Flags Ihnen bei den verbleibenden Problemen helfen.

    
Nahuel 14.09.2016 14:29
7

Mit Chrome Version 51.0.2704.103 (64-Bit) die Flags

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

funktioniert nicht mehr.

Am besten gehen Sie zurück zu Chrome 50 (Version 50.0.2661.86 (64-Bit)). Hier finden Sie eine Anleitung, wie Sie einen Schritt zurückgehen können: Wie erniedrige ich Google Chrome?

Wichtig ist, dass wir Druck auf Google ausüben, um dieses Problem zu beheben, für den Fehler in Chromium und auf der Google-Produktseite zu stimmen:

Link

Link

    
user157697 19.06.2016 10:02
5
chrome://flags/ > GPU rasterization > Enable,

Das hat endlich für mich funktioniert! Fanden Sie es am Ende dieses Google Formulars! Link

    
Chris Lane Jones 16.10.2016 22:44
4

Ich denke, ich habe die Lösung gefunden:

flags --disable-gpu-driver-bug-workarounds --openable-native-gpu-memory-buffers und auch enable-zero-copy ENABLE

    sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf
    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod"  "sna"
       Option      "TearFree"    "true"
       Option      "DRI"    "3"
    EndSection
    
Hector 07.07.2016 17:14
2

Versuchen Sie, einige GPU-Optionen zu laden:

- disable-gpu-driver-Fehler-Workarounds --enable-native-gpu-memory-buffers

Nachdem Sie das versucht haben, können Sie auch mit einigen der Rendereinstellungen in about: // flags experimentieren und sehen, ob etwas dabei hilft, aber der Großteil meiner Renderflimmer wurde durch die zwei Befehlszeilenflags gelöst. Wenn Sie eine Launcher-.desktop-Datei haben, fügen Sie diese Flags dem obersten Exec-Eintrag vor dem '% U' hinzu. Sie können sie auch zu den anderen Exec-Einträgen hinzufügen, damit die Flags für alle Startmodi gelten.

    
MattCole3 04.05.2016 17:44
2

Ich habe festgestellt, dass die derzeitigen Fixes nicht für die aktuelle Version von Chrome funktionieren, weitere Dinge müssen geändert werden (zumindest für meine Einrichtung).

Ich kann bestätigen, dass das funktioniert (entfernt sowohl Flackern als auch Reißen) - dank Link

Computer: XPS13 9343 Grafik: 00: 02.0 VGA-kompatibler Controller: Intel Corporation Broadwell-U Integrated Graphics (Rev. 09) Chrome-Version: Version 54.0.2840.100 (64-Bit)

Einstellungen

1) Überprüfen Sie die Fehlermeldungen vor und nach den Konfigurationseinstellungen unten

  • chrome: // gpu
  • Machen Sie einen Screenshot, damit Sie nachher vergleichen können.

2) Bearbeiten (für Chrom): /usr/share/applications/google-chrome.desktop oder für (Chrom): /usr/share/applications/chromium-browser.desktop

  • Fügen Sie die Flags hinzu --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers
  • Zeile sollte folgendermaßen aussehen: Exec=/usr/bin/google-chrome-stable --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers %U

3) sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf fügen Sie das hinzu (Sie müssen möglicherweise die Datei erstellen):

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

4) Einstellungen für Chrome-Flags: chrome: // flags:

  • Aktivieren ("zero copy rasterizer"): chrome: // flags / # enable-zero-copy
  • Aktivieren (Anzeigebereich 2d Canvas aktivieren): chrome: // flags / # enable-display-list-2d-canvas
  • Aktivieren ("Software-Rendering-Liste überschreiben"): chrome: // flags / # ignore-gpu-blacklist
  • Aktivieren Sie "2D-Canvas-Liste anzeigen": chrome: // flags / # enable-display-list-2d-canvas
  • Aktivieren (chrome flag für reibungsloses Scrollen in Linux): chrome: // flags / # smooth-scrolling

5) Ich habe die Chrome-Einstellungen beibehalten & gt; Erweitert & gt; Verwenden Sie die Hardwarebeschleunigung, wenn verfügbar [ aktiviert] ]. Wenn Sie das Häkchen bei wirklich entfernen, um die Leistung zu verbessern (obwohl das Flimmern zwar reduziert, aber nicht zerrissen wird), haben die obigen Optionen für mich viel besser funktioniert.

6) Starten Sie den Computer neu.

7) Einstellungen vergleichen. chrome: // gpu

Das hat das Flackern und Reißen für mich völlig eliminiert.

    
Amos Folarin 15.02.2017 15:27
1

Das Deaktivieren der Hardwarebeschleunigung verschlechtert die Leistung Ihres Browsers für die Seiten mit Animationen und anderen prozessorintensiven Aufgaben.

Wenn Sie jedoch keine GPU in Ihrem System installiert haben, wird die von sgiri vorgeschlagene Vorgehensweise zum Deaktivieren der Hardwarebeschleunigung verwendet das Beste für dich.

Aber ich habe eine NVidia GPU in meinem Laptop installiert und benutze Ubuntu Desktop OS. Also habe ich den proprietären Binärtreiber (Version 352.63) installiert. Es hat für mich funktioniert, Hoffnung wird auch in deinem Ubuntu System funktionieren.

    
user4128091 23.08.2016 08:50

Tags und Links